2018 Flex SEL Upgrade from 2.3.17109 to most current BLACK SCREEN

I’ll have to get one of those OBDLink devices. I tried downloading the firmware, it told me I can’t because of my free license.

Its a cheap BAFX Products BT OBDII scanner.

Ordered this part: Amazon.com: OBDLink EX FORScan OBD Adapter : Automotive

Should have it by Tuesday.

Don’t use that…please.

Tell me when you get your adapter and I’ll help you through the process.

Sounds good.
I got the cheap scanner just to pull codes a few years ago.
Amazon says Ill have it Tuesday.

9 posts were split to a new topic: OBDLink EX Adapter

My EX just arrived. Ill get the paid license for FORScan and we can try to get this thing taken care of today.

Update the OBDLink drivers if necessary, ScanTool.net, LLC - Firmware Updates for OBDLink EX

Get the newest FORScan version, FORScan 2.4.5 beta Released 2021-11-25 - Ford / Other - CyanLabs Official Community

Trying to update the firmware for the OBDLink… got this error.


My FORScan version is 2.4.5 release. That should be ok right?

Disregard the above picture. It wont update because the adapter already has the most current version.

I was going to say that…looks fine.

Yep.

Let me know what I need to try, and Ill do it when I get home from work tomorrow and let you know how it goes.

Always first: Read the FORScan tutorials.

You can download the files by selecting the ‘Download’ button at the bottom of the firmware programming page. The 5 red dots should turn green. (Ignore the “Image” USB line, that is not applicable for this.) With the EX connected to the computer, you should be able to do this without being connected to the vehicle.

First thing after connecting to the vehicle, make a new vehicle profile with the EX adapter. The other profiles will not work with the EX so junk those.

Then write the files again to the APIM. Make sure that the 3 selections at the bottom are selected. (Silence Busses, Recovery mode, Overwrite firmware.) If FORScan says the firmware is already updated, write it anyways. The programming will take a few minutes, be patient. Hopefully it says it all wrote successfully.

NOTE: When you program the firmware with ‘Silence Busses’ checked, the vehicle will have some weird things happen, like lights flash, etc. This is normal as the communications on the CAN Busses is stopped. Make sure that after you program to search for DTC’s and clear them.

Important: Watch the vehicle battery voltage. If it drops to under 11.6 VDC, FORScan will complain and may stop you from programming. It is best to have a battery charger connected to the battery while programming. If you do not have a vehicle battery charger, run the vehicle for about 15 minutes before you attempt programming. (FORScan has a voltage readout at the bottom right of the GUI.)

Tip: Shut off the HVAC and vehicle lighting while in ignition mode to save battery. Also, don’t play the music loud. It is amazing how much current these vehicles draw just in ignition mode. When I am programming, with a battery charger connected, the amp meter on the charger shows 6-8 amps consistently in ignition mode.

So the log says it was successful… but the screen is still black.
Not sure what the next step is.

Well, good job! First time through this and using the software and it all went fine. However, the screen still has not come back. I think the APIM looks fine and will program without issue. The asbuilt is fine. This really looks like a screen issue.
Did you try a master reset after the programming?
Try this:
In the wrench icon menu in FORScan, choose reset APIM. Reset the APIM. Let the procedure complete. Turn off ignition, shut down vehicle. Wait a few minutes. Open vehicle, start vehicle, see if the display comes to life. This works on some MY20 screens if the drivers were messed up. If this does not work, I would say the screen has issues.

If anyone else has ideas about what the issue could be, please chime in…Just pinging for suggestions, again.
@bill32399 @Louage @SaNdMaN @avdonr @CyanLabs

I think you have tried everything and then some. We know for sure it’s not MY20 and the APIM seems to be working fine. I would have to say it’s a hardware fault and most likely the monitor out of the 2 of them. Only thing left is to insure there is a good connection between the two.

Also on a side note, This APIM is not in the database.

When I removed the APIM and screen from the car, I did reseat all connections.
How would the APIM not be in the database? Sounds odd to me.

I will try this later today and report back.

1 Like

I noticed this, seems odd, is this even a genuine Ford APIM ?

I have the contact info of the previous owners. Maybe Ill give them a call and ask some questions…

1 Like

Just to clarify, the database is user driven so it’s possible you are just the first with that model, however google also returns 0 results so…

This did not seem to make any change.

Is that the step mentioned above?
I think we are hitting a wall here…

I just wanted to exhaust all options, and you are correct, as I suspected this has come down to a hardware issue. I don’t think there is a way out other than hardware replacement at this point. You could replace the screen only, or APIM only, but I think you’ll find it might be cheaper to replace both as a unit than buying each one of these separately. Just stay away from the APIM’s that indicate they are from China, as those may not be as they seem.

You do not need to have the unit programmed by anyone, as you have the ability to do that and make the changes you want. So remember that when making an offer, especially on eBay.

Any suggestions of a trusted vendor?