Glitchy after latest sync 3.4 update

I did the latest update for sync 3.4 in my 2018 F250, and after it updated i did a master reset. The with android auto, the screen freezes sometimes, has a black screen after the reverse camera goes on and off. It will still play music i just have no control. Ive unplugged and plugged in my usb but it still glitches. Not sure what else to do

SYNC Region: North America & Canada

Navigation Variant: Yes

Install Type: Stock (Original Unit)

Old SYNC Version: 3.4.21194

New SYNC Version: 3.4.2210

Do you have a error message, if so what is it?
No error messages

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version:

Syn3 Updater Documentation Read: Yes

Syn3 Updater Log File

.  .

This is what I would try.
Make sync3 forget about the phone and the phone forget about Sync3.
Then re-pair everything and try again.

I tried that, for some reason it made it more difficult to re-pair them.

If another master reset does not solve it, I would think it’s something hw related.
That being the APIM being faulty, or maybe your cable/USB hub.

Does this happen when the phone is connected? Does it happen when the phone is not connected?
Does the unit work normally WITHOUT the phone paired to Sync?

On the phone, disconnect from Sync.
On Sync, perform a Master Reset.
DO NOT reconnect or re-pair the phone. Do not plug the phone into Sync.
Does Sync work normally without issues, or are there issues and what are they?

Only malfunctions when the phone is connected to sync. everything works perfectly when the phone isnt connected.

I’ve tried a couple different USB cables as well, still the same result

You should look into if there are updates for your phone. Also, sometimes phones can have software corruption due to incomplete software updates or even bad software (apps). This happens to both iPhones and Android, and is more common than you might think. Restoring the phone to factory and then reloading the apps is sometimes needed to fix these issues. I had to do this to my iPhone 8 after it updated to IOS 15. (Which thanks to Apple, IOS 15 has exhibited all kinds of issues with CarPlay, across virtually all vehicle manufacturers.)

This of course rules out the Sync system…

Just wait, IOS 16 is redoing Carplay.

Great. We get to report a whole new set of issues…But I rarely use CP anymore. Not in the truck long enough to be worth it.

Ive got a brand new phone with freshly loaded and updated apps. This issue started to occur before i did the update to the latest cynlabs sync 3.4 update. So i dont think its my phone. I had version 3.4.21194 that i installed august 2021, then a couple days ago when this issue began i updated it to version 3.4.22110

And i have a Android not apple, if that helps

Your comment above indicates that Sync operates properly without the phone connected. Also, a brand new phone does not guarantee it is not without issues.

However, you can downgrade back to Sync 3.4.21194 and see if the issue persists.

K i will try the downgrade tomorrow. What about downgrading right back to 3.0 and the back to the lastest 3.4?

Can’t go back to 3.0.

You can go back as far as Sync 3.2, but it would not really prove anything.


Either the hub or the cable for sure. I know you’ve said you’ve tried a variety of cables, but have you tried quality cables, or cheap non-name-brand cables? If only cheap cables, then order Anker or Cable Matters from a reputable source and try that before you go to the trouble of replacing the hub. Quality of cable makes a huge difference with Android Auto, probably a coincidence that you started having trouble after the upgrade. Also…definitely forget car from your list of bluetooth connections and forget the phone from your car’s list of connections, maybe even uninstall and reinstall Android Auto as well, then start from scratch.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.