Help! SYNC 3.4 latest build > downgrade to 19101

First of all a great thanks to Cyanlabs for the new Windows auto installer. Worked perfect on my original SYNC 3.0 version.

So I took the plunge and upgraded to the latest 3.4 version. Everything works well, but due to the lack of the Auto Dim option, my screen is always flickering as it tries to adjust due to ambient lighting.

I believe that in build 19101 the Auto dim option is present, but not anything later… are there any signifant features/problems with 19101 to stop me downgrading?

So having gone from 3.0 to 3.4, how do I now revert back to an earlier build of 3.4 without changing the maps and the rest? Do I need to reformat again,or what’s correct?

Thanks

James

1 Like

Yes, just “Keep existing maps” and select a new release (old release in this case)

Perfect, thanks. What about Gracenotes? How long does this downgrade take? Is it a full install, 40-50 mins?

Does 19101 lose much in terms of features/bugs or station logos etc?

I wonder if the Auto Dim option will return to newer 3.4 versions or is there any known Asbuilt workarounds?

Of course you will be missing bugs solutions, I believe one of them was related to UBS playback defaulting to something else, not sure to be honest since it’s a build from 2019…

But since you want to solve the flickering screen, that’s kinda irrelevant, and you can also go back to your current version.

Installation time will be lower than that, since you are only installing some packages.

Just make sure your settings are correct at the tool, and make sure to keep maps.

Thanks. I wonder if there is a fix for the flickering issue on some APIMs? I actually retrofitted my SYNC 3 to a non-SYNC car, 2012 build date which had just BVC (bluetooth/voice control). But don’t think that’s related as others have the issue too.

Maybe a way to disable or cover up the physical light sensor so it doesn’t keep detecting light changes?

Not sure to be honest, but that seems convoluted.
I’d go simpler: install previous build, if nothing bothers you, then you are set and problem solved.
Remember that you can go back to the latest build without issues as well, so nothing is permanent.

Yeah, probably best! Thanks.

There is, actually. It has to do with the Illumination Gateway settings. This was discussed in another thread or two. I think it was a setting in 7D0-06-01 x*xx, with CGEA vs. C1MCA.

@Louage, do you remember the exact setting for UK?

If you set the theme to night mode, it will do what you want.

@tedted22 is this a focus or kuga/escape? If so, there’s no known fix for the flicker. I have the same issue.

Focus MK3 pre facelift 2012

I have it set to night mode already, so the problem is not the auto switch between day/night, but the dimming level being constantly adjusted due to the ambient sensor.

What does the 7D0-06-01 x*xx do differently?

Thanks

Like louage said if it’s a focus there is no fix unfortunately

Understood, thanks all!

That’s a shame. Must be something specific about the Focus Illumination Architecture.

Do we know why the Auto dim option was present in build 19101 but nothing since? If Sync 3.4 was only ever meant for the new 2020 APIMs I don’t know why that option ever existed in 3.4!

Is there any way to hack it in to newer builds, reverse engineer perhaps?

A) It’s Ford’s choice actually, it was most likely present in early 3.4s due to a programmer oversight… when they realized, they removed it since clearly they do not want the option to be present.

B) No

1 Like

Do we know what the setting changes? i.e. an APIM As-built setting or some other BCM change? If we know what the Auto Dim option changes, we might be able to change the toggle outside of the Sync 3 software, as turning Auto Dim off fixes the problem properly!

with the not public jailbreak or hardware flashing yes, but in general no.

@SaNdMaN is right. This is also due to the new distraction rules pushed onto manufacturers. It’s not totally Ford…

I get that, just a shame that on our APIMs they’ve made it worse as it’s massively distracting with auto dim on, as its constantly flickering up and down in brightness :laughing:

1 Like