MEM 3 error with available storage

Hi Guys, I was having such a hard time updating my sync for 3.4.2165, but after a few searchs here is what i was able to to:

Downgrade to 3.3, reformat, and install 3.4.2165 package. During this process I was getting MEM erros, and decided to install only the system and voice package for testing. it was successful.

Now, i’m trying to install latest gracenotes but Im still having MEM errors, even with my diagnostics saying there is 1.1 GB available.


SYNC Region: Australia, New Zealand, South America

Navigation Variant: No

Old SYNC Version: 3.3

New SYNC Version: 3.4.2165

Do you have a error message, if so what is it?
MEM ERROR 3

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: 2.10.8.0

Syn3 Updater Documentation Read: Yes

Syn3 Updater Log File

CYANLABS - SYN3 UPDATER - V2.10.8.0
Branch: Stable
Operating System: Microsoft Windows 10 Enterprise (2009)

PREVIOUS CONFIGURATION
Version: 3.4.21265
Region: ANZ
Navigation: False
Install Mode: Auto-Detectar (autoinstall)
Install Mode Overridden: False
My20 Protection Enabled: Auto-Detectar

DESTINATION DETAILS
Mode: Drive
Model: SanDisk Cruzer Blade USB Device
FileSystem: exFAT
Partition Type: MBR

AUTOINSTALL.LST
; CyanLabs Syn3Updater 2.10.8.0 Stable - Autoinstall Mode - Sync 3.4.21265 ANZ

[SYNCGen3.0_ALL_PRODUCT]
Item1 = GRACENOTES - 4U5T-14G423-BC_1615425978000.TAR.GZ
Open1 = SyncMyRide\4U5T-14G423-BC_1615425978000.TAR.GZ
Options = AutoInstall


FILES (1)
4U5T-14G423-BC_1615425978000.TAR.GZ (927,5MB)

LOG
[02/03/2022 16:17:37] Selected Region: ANZ - Release: Sync 3.4.21265 - Map Version: APIM sem GPS 
[02/03/2022 16:17:37] Install Mode: Auto-Detectar (autoinstall) Forced: False 
[02/03/2022 16:17:37] MY20 Protection: Auto-Detectar 
[02/03/2022 16:17:37] Formatting USB drive
[02/03/2022 16:17:37] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
[02/03/2022 16:18:10] Checking Existing File: 4U5T-14G423-BC_1615425978000.TAR.GZ 
[02/03/2022 16:18:16] Validated: 4U5T-14G423-BC_1615425978000.TAR.GZ (Skipping Download) 
[02/03/2022 16:18:16] Preparing USB drive
[02/03/2022 16:18:16] Checking Existing File: 4U5T-14G423-BC_1615425978000.TAR.GZ 
[02/03/2022 16:18:16] Copying: 4U5T-14G423-BC_1615425978000.TAR.GZ 
[02/03/2022 16:21:54] Validating: 4U5T-14G423-BC_1615425978000.TAR.GZ 
[02/03/2022 16:22:36] Copied: 4U5T-14G423-BC_1615425978000.TAR.GZ 
[02/03/2022 16:22:36] Generating Autoinstall.lst
[02/03/2022 16:22:36] ALL FILES DOWNLOADED AND COPIED TO THE USB DRIVE SUCCESSFULLY!

Here is the XML for the diagnostic tool:
Sync_WX4R3GNT_8AFSZZFFCKJ110688.xml (10,0,KB)

Not enough storage left.

You need to follow this tutorial → Tutorial: Sync 3.4 NON-NAV APIM: Failure to Update to Newer Version Sync 3.4

With that, you will be able to succeed.

I followed this exact tutorial. Step by step. When i downgrade to 3.3.19052 i wasnt able to install the complete packages, (system + voice + gracenotes), so I installed only system + voice. Is there any chance that the files are so big that they wont fit in 8 gb at all?

Maybe there is a smaller gracenotes package, or a voice file with only portuguese BR?

You are not following the tutorial then.
The tutorial says downgrade first, then check available free storage. If under 1.5gb, you need to continue removing stuff, and according to your message you tried to perform the upgrade at that point.

Re read the tutorial and follow it, step by step.
There are more things you can remove.

Or maybe I’m not following you.
So the question is: were you able to reformat with all the packages?.

I remove gracenotes and changed the language pack to the smaller one before downgrading, in order to try to update directly. Since i wasnt able to update, i downgraded to 3.3.19052 and tried reformating with all the packages, without success. at the end i’m in 3.4 .21265 without gracenotes.

Do you think I should try again?
downgrade, replace voice package and force reformat 3.4 with all the packages?

You followed the directions and you are where you are supposed to be. With the voice and Gracenotes packages that include portuguese BR, these are larger files. You do not have the available space with these files to install Gracenotes.

If you were to use smaller non-portuguese BR files, then yes it is possible to fit GN on the unit with Sync 3.4. With Sync 3.3, you could use these files because the Sync app is half the size of 3.4.

Oh I see, I misunderstood then, my apologies for that.

@F150chief , even with reformat would it fail?.

It may work with those files but there would be very little storage left to run the APIM. You would not have enough free space to upgrade in the future.

@Joao_Victor_Magalhae please, can you confirm if you tried a reformat will all the packages at once?

Hi Guys, sorry about the time to answer. yes i did try reformat with all the packages after downgrade, without success.

GN seems to be less than 1 gb when you check the size on the flash drive, since i have 1,1 available, wouldn’t it be enough?

So with a full reformat and all packages, you got a red screen. Do you remember the error code you got?

And no, the package you are seeing is compressed, so the APIM needs more storage to allocate that file.

If with a full reformat with all packages did not work, then you can’t fit them all without meddling with the package selection.

i will try everything again and come back to you soon guys. thank you.

Ok, but if you now have 1.1gb of free space and the GN compressed size is close to that, you may receive an error.

If so, you have a decision to make: keeping GN or installing a smaller voice package without Portuguese.

If you ask me, GN is just artwork for the media player… Not sure how useful that is compared to a language package.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.