MY20+ black screen issue

Hi, I have a question related to the “black screen” on an apim MY20+ , due to a “reformat” instead of an “autoinstall”. There has been a lot of talk about it, but has a solution actually been found for this problem, or not (yet)? If yes, which one is it? I have one with this problem, also tried several times to bring it back to life but no success so far…I have UCDS (the real one) and when I scan the apim on the test bench everything is ok, I can view the firmware and all settings (direct config and others) so this means everything ‘works’ but there is no communication with the screen…
That’s the real problem…It was also said that a version of 3.3 build…could be a solution, but I tried (loaded a .img file from 3.3 via an emmc reader) and it did nothing…

Hey Thierry,
Publicly, with Ford supplied files, there is not a solution for the reformat caused black screen. There is a very small exception to this, which involves very early MY20 models manufactured in late 2019. Some of these units can be recovered by swapping the screen with an older one and resetting the APIM thru FORScan (or UCDS). Sometimes they work. I’ve seen about a 50% success with this. It doesn’t work on the later models.

Video drivers are the issue. Unfortunately, there is no way to just recover the video drivers or load different ones to fix the issue. (That I am aware of…).

Although you would think this would do it, it is not the solution. Loading the image file does not properly format the eMMC for the video drivers, etc. That is not included in the image.

1 Like

Thierry replied via email, that’s not something that is enabled… here is the message.

Hi, well I figured it out, that the video drivers are the issue here. They are not ‘embedded’ in the VBF-files?

How are these video drivers installed then? With a computer tool you download the “drivers” and you install them …



They are not.

I am guessing in the reformat tool. I have never directed the file to look.

1 Like