Pkg err04 in Sync 3.4 build 20021

Hi I installed a update from 3.3 to 3.4 (the beta) without the new maps After installation everything works fine but no navigation When I try to install new maps or downgrade I get the message pkg err04.

Any idea?

You need to downgrade manually following the steps on the guide, if your are getting PKG_ERR04 you are not following correctly, if you install WITHOUT MAPS you WON’T HAVE MAPS