Stuck - mem_err03 ( no-nav apim )

What is your SYNC Region?
ROW ( North Africa )

What is your current SYNC Version?
3.4.20351
Do you have Navigation?
NO
Do you have a error message, if so what is it?
MEM_ERR03----

Please describe in detail your issue below

I tried to Add Maps ( about 700MB ) to a Non-nav apim and now i don’t have enough storage to downgrade …
i already deleted Gracenotes…
Can’t replace voice package with the small voice package because i have only 453MB left … ( mem_err03 )
can’t use reformat tool because i have latest sync version

i did a stupid thing and i’m stuck now :confused:

APIM Type: Non-Navigation
APIM Size: 8GB
APIM Free Space: 453M
3/16/2021 12:04:10 AM +00:00

Partition Type = Free / Total
/fs/sd/MAP/ = 260K / 714M
/fs/Nuance/ = 7.0M / 1.7G
/fs/rwdata/ = 990M / 1.2G
/fs/rwdata/quip/ = 35M / 35M
/fs/rwdata/quip/ = 90M / 90M
/fs/mp/ = 128M / 1.4G
/fs/mp/resources = 432K / 73M
/fs/images/ = 453M / 3.0G

any ideas to fix this ? Thanks

I see you have already tried to remove Gracenotes and create a small voice package. Does the final option in this list (Create downgrade USB) work? If you can get down to 3.3, you can use the reformat tool again.

The 3.3 packages are about 450-500MB in size (half that of 3.4), so it may work. If it won’t let you downgrade to 3.3, then we can explore other more drastic options but they involve a lot more risk of leaving you with even less functionality than you have now.

Hi,
Thank you for your reply

as mentioned i have only 453M left in /fs/images/
I tried to downgrade using the file 4U5T-14G381-AN_1552583626000.TAR.GZ
There is no ERR message but it stuck on " Updating …" message and no downgrade performed

The size of Apps.tar.gz in the downgrade file is about 500MB
No enough space to extract

Hmm. So it seems like you are left with very little options besides a direct hardware flash.

The final thing I was going to suggest is using a 3.3 apps package for a 4" system. These are smaller (around 340MB), however if the install is successful you will be left with a system that you can’t directly control via touch input. It should however all you to use the reformat tool. Please note that if this leaves your system in an unstable state, you are proceeding at your own risk.

You should be able to find a 3.3.18201 file linked in the IVSU database.

If that doesn’t work then you will need to take out your APIM and directly program the eMMC chip, but that involves quite a lot of work and necessary skills/system images.

1 Like

There is space to be gained here, create the system voice package with the CN file. This should directly replace the current voice file in this location. The voice file needs to be run alone, not with any other files.

(I should mention loading this file might cause the display to be in Chinese.)

This should yield about 1.3 GB free space. At that point, downgrade to 3.3.19052 and use the reformat tool to install the new version of Sync (APP, VOICE, and GN) and remove the maps.

5U5T-14G391-EM_1598637456000.TAR.GZ 189Mb Sync3 v3.2.20142

[SYNCGen3.0_ALL]
Item1 = 5U5T-14G391-EM_1598637456000.TAR.GZ
Open1 = SyncMyRide\5U5T-14G391-EM_1598637456000.TAR.GZ
Options = AutoInstall

Country Code MA is Morocco?

3 Likes

Thanks @F150Chief. Try doing that first, and leave what I posted as a last resort.

1 Like

@F150Chief Thank you, storage gained using that CN File . now i will downgrade and use reformat tool to remove maps .
Yes Country Code MA is for Morocco

1 Like

I might be missing something but is that CN file not the file that i use in option 2 of troubleshooting?

https://cyanlabs.net/docs/syn3updater/page/troubleshooting

@CyanLabs
No it’s not the same file this CN file is smaller

1 Like

Guys i managed to install latest version for Sync3 with Navigation in my No-Navigation Apim

Middle East & North Africa Map ( ~700 MB )

I still have 1.9G of free storage
I’m using APP, small voice pack ( CN ) , DAB , Map

All is functional, the only thing i didn’t like is that navigation don’t show up on main screen

Is this because it’s ROW Map ? Is there a solution ?

1 Like

Yes unfortunately that’s the way it is on row

Will note this and update the package in v2.4.3/2.5

2 Likes

Just remembered this is a backend API call, i’ve updated the call to use the CN package so existing versions of Syn3 Updater will now use this also :slight_smile:

1 Like

Just note that it could change the language once loaded…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.