Sync gone crazy

hello all, after updating the sync I encountered this problem. Sync moves itself from one part of the menu to another continuously. how can i solve?

On the link there is the video of the problem:

SYNC Region: EU

Navigation Variant: Non Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.0.20204

New SYNC Version: 3.4.22251

Do you have a error message, if so what is it?
no error messages. only the sync that moves by itself

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version:

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

Branch: Stable
Operating System: Microsoft Windows 10 Pro (2009)

Version: 3.0.20204
Region: EU
Navigation: False
Install Mode: Riconoscimento automatico (reformat)
Install Mode Overridden: False
My20 Protection Enabled: Riconoscimento automatico

Mode: Drive
Model: USB DISK 2.0 USB Device
Size: 29,3GB
FileSystem: FAT32
Partition Type: MBR


; CyanLabs Syn3Updater Stable - reformat  Mode - Sync 3.4.22251 EU

Item1 = REFORMAT TOOL  - 1u5t-14g386-cb.tar.gz
Open1 = SyncMyRide\1u5t-14g386-cb.tar.gz
Options = AutoInstall

1u5t-14g386-cb.tar.gz (8,5MB)
5U5T-14G391-AT_1660763323000.TAR.GZ (1,5GB)
4U5T-14G423-AC_1615425645000.TAR.GZ (689MB)
1U5T-14G658-AH_1644006443000.TAR.GZ (57,5MB)
NU5T-14G381-AB_1665525837000.TAR.GZ (869,8MB)

[31/10/2022 18:26:21] Selected Region: EU - Release: Sync 3.4.22251 - Map Version: APIM senza navigatore 
[31/10/2022 18:26:21] Install Mode: Riconoscimento automatico (reformat) Forced: False 
[31/10/2022 18:26:21] MY20 Protection: Riconoscimento automatico 
[31/10/2022 18:26:22] Formatting USB drive
[31/10/2022 18:26:22] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
[31/10/2022 18:27:25] Checking Existing File: 1u5t-14g386-cb.tar.gz 
[31/10/2022 18:27:29] Validated: 1u5t-14g386-cb.tar.gz (Skipping Download) 
[31/10/2022 18:27:29] Checking Existing File: 5U5T-14G391-AT_1660763323000.TAR.GZ 
[31/10/2022 18:28:32] Validated: 5U5T-14G391-AT_1660763323000.TAR.GZ (Skipping Download) 
[31/10/2022 18:28:32] Checking Existing File: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[31/10/2022 18:29:00] Validated: 4U5T-14G423-AC_1615425645000.TAR.GZ (Skipping Download) 
[31/10/2022 18:29:00] Checking Existing File: 1U5T-14G658-AH_1644006443000.TAR.GZ 
[31/10/2022 18:29:04] Validated: 1U5T-14G658-AH_1644006443000.TAR.GZ (Skipping Download) 
[31/10/2022 18:29:04] Checking Existing File: NU5T-14G381-AB_1665525837000.TAR.GZ 
[31/10/2022 18:29:22] Validated: NU5T-14G381-AB_1665525837000.TAR.GZ (Skipping Download) 
[31/10/2022 18:29:22] Preparing USB drive
[31/10/2022 18:29:22] Checking Existing File: 1u5t-14g386-cb.tar.gz 
[31/10/2022 18:29:22] Copying: 1u5t-14g386-cb.tar.gz 
[31/10/2022 18:29:24] Validating: 1u5t-14g386-cb.tar.gz 
[31/10/2022 18:29:24] Copied: 1u5t-14g386-cb.tar.gz 
[31/10/2022 18:29:24] Checking Existing File: 5U5T-14G391-AT_1660763323000.TAR.GZ 
[31/10/2022 18:29:24] Copying: 5U5T-14G391-AT_1660763323000.TAR.GZ 
[31/10/2022 18:34:58] Validating: 5U5T-14G391-AT_1660763323000.TAR.GZ 
[31/10/2022 18:36:09] Copied: 5U5T-14G391-AT_1660763323000.TAR.GZ 
[31/10/2022 18:36:09] Checking Existing File: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[31/10/2022 18:36:09] Copying: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[31/10/2022 18:38:31] Validating: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[31/10/2022 18:39:02] Copied: 4U5T-14G423-AC_1615425645000.TAR.GZ 
[31/10/2022 18:39:02] Checking Existing File: 1U5T-14G658-AH_1644006443000.TAR.GZ 
[31/10/2022 18:39:02] Copying: 1U5T-14G658-AH_1644006443000.TAR.GZ 
[31/10/2022 18:39:13] Validating: 1U5T-14G658-AH_1644006443000.TAR.GZ 
[31/10/2022 18:39:16] Copied: 1U5T-14G658-AH_1644006443000.TAR.GZ 
[31/10/2022 18:39:16] Checking Existing File: NU5T-14G381-AB_1665525837000.TAR.GZ 
[31/10/2022 18:39:16] Copying: NU5T-14G381-AB_1665525837000.TAR.GZ 
[31/10/2022 18:42:53] Validating: NU5T-14G381-AB_1665525837000.TAR.GZ 
[31/10/2022 18:43:34] Copied: NU5T-14G381-AB_1665525837000.TAR.GZ 
[31/10/2022 18:43:34] Generating reformat.lst
[31/10/2022 18:43:34] Generating autoinstall.lst

I have to say that after years of playing around with Sync 1, 2, and 3 versions that I have never seen this issue. But there is always a first.

This looks like it could be a screen issue. Did you disassemble anything in the dash? Particularly the LVDS video cable from the Sync unit to the screen…

This could be due to an interrupted or corrupted reformat also, particularly the screen drivers. The unit was previously on Sync 3.3.20204 and was reformatted to Sync 3.4. You could try downgrading the unit to Sync 3.3.19052 and reformatting again.

See if you can run the APIM Interrogator Utility and post the results here. This will tell us what model of APIM is installed and the software at this point.

no I have never disassembled anything on the car, I tried to reinstall the 3.3.19052 but the problem remains

Versione 4U5T-14G381-AN
Modello di APIM: H1BT-14G371-AHA
Tipo di APIM: Non-Navigation
Capienza APIM: 16GB
APIM Spazio Libero: 6.9G
02/01/2023 12:39:33 +00:00

Partition Type = Free / Total
/fs/Nuance/ = 91M / 1.9G
/fs/Nuance/grace = 59M / 1.0G
/fs/rwdata/ = 428M / 1.2G
/fs/mp/ = 505M / 1.4G
/fs/mp/resources = 260K / 91M
/fs/images/ = 6.9G / 10G

Installed Packages

APIM AsBuilt
DE00: 086A058210009C444080
DE01: 49540001C08A088028B80005
DE02: 0000010004
DE03: 00001DE1010001
DE04: 190819082653
DE05: 40
DE06: 0B0533000000006428000056565D0061

This does not seem related to the upgrade itself.
Is the screen responsive?.
Is the screen super clean?.

yes the screen is clear. and reacts immediately to commands. it happens that for one trip it doesn’t give me problems and on the next trip it moves from one place to another

before the update (version 3.0.20204) the sync didn’t have any kind of problem it worked very well, after the update this problem started. is it possible to go back to the official ford version? can you solve the problem?


Please, in the future, use the edit button instead of posting 2 consecutive messages, thanks.

About going back to 3.0, you can’t do it (it’s clearly stated in the documentation).

I understand you feel like this is related to the upgrade itself, but out of thousands that have performed this procedure, you are the first one to report this kind of issue.
This seems to be a hardware issue, not software related.
Besides, you already tried installing another Sync3 versio, right?, so what’s common about your setup while changing versions?, the hardware.

Could the upgrade process trigger (not cause, trigger, it’s not the same) some hardware malfunction?, it’s possible, but not probable. I mean, if for whatever reason your unit was already unhealthy (without you knowing it), reformatting it could trigger some issues, since new memory locations are used. Again, it’s possible, not probable.

I believe you have already master reset, right?.

This is what I would do if I were you:

  • Perform a master reset (if you haven’t done so)
  • Unplug the car’s battery overnight (if possible)
  • If previous steps fail, unmount the unit (APIM + Screen), make sure all connectors have a solid and clean connection.

Did you use the reformat tool to go back to 3.3.19052? If you did not, changing versions will do nothing for the issue. If you did not reformat, doing so could clear the issue if it is related to the video drivers. From the description above, this does sound like a hardware issue that was waiting to appear. Like we said, this is the first problem like this we have seen.

You should follow the steps that @SaNdMaN outlined above.

as you recommended I formatted to version 3.3.19052, tried to remove the battery. I disassembled the sync to see the links on the back but I’m fine. the problem persists. what should i do now? above you talked about the master reset, do you mean from the sync settings?

Yes, a master reset from Sync3 's settings.
When you checked the connectors, did you re seat them?.

I unplugged the connectors and then plugged them back in

Ok then.

You have tried all the things I would try if it was my unit, I’m out of ideas.

You should probably replace the screen or the LVDS cable at least.

so replacing the screen do i have an original version of sync? is all internal screen software?

The screen is separate from Sync. Replacing the screen does not affect the Sync OS or settings.

so should i change the software components? or the screen?
does it have a name or a code?

This is for the 2018 Ford Fiesta with Sync 3? Looks like this, the screen is separate from the Sync APIM.

The LDVS cable will be longer than the version with the screen and APIM together. Like this:
1.5M 5ft FAKRA HSD Sync3 LVDS Video Harness Cable SYNC 3 System Upgrade Touchscreen to APIM Cable for Ford MyFord Touch or Lincoln Head Unit Stereo : Electronics

According to our screen database, the Fiesta screen is part G1BT-18B955-TD.
2018 Ford Fiesta G1BT18B955TD 6.5" Standard Flat

2013- 2018 Ford Fiesta OEM 6.5" Touch Screen Display Monitor USED G1BT-18B955-TD | eBay

This could be bad connections on the video or power connectors, etc., also. Especially grounding. I searched around and found a similar issue with Explorers, etc.

Some 2020 Explorer/Aviator vehicles built on or before 30-Sep-2020 may experience an intermittent or constant blank/black screen on the center infotainment display due the low voltage differential signaling (LVDS) cable at the SYNC accessory protocol interface module (APIM) not being fully seated. Verify that the connector is fully seated into the APIM prior to performing any other diagnostics or repairs on the vehicle for this concern. If the connection is found loose, re-seat the connection and retest.

Is there any update from your side @jacopofavaretto ?
Since we didn’t hear back from you, I’m setting a 2 day inactivity auto-closure for this thread.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.