SYNC Upgrade Stuck

2017 Focus RS was at 3.4.20021.

Downgraded to 3.3.19052 and first got the red error screen.

Then after reinserting the USB, got the Mustang screen and the clock begins to count, but there is no green progress indicator - it doesn’t show up at all. Waited over 20 minutes and still no progress change?

Please help, tia!

What is the prompt on the reformat tool? Does it say “Insert USB”? Can you please provide your log file?

It’s just the red error screen, no prompt. If I pull the USB and reinsert it goes to the Mustang screen but the green progress bar doesn’t appear or move

It appears that the first portion worked ok, but it’s now stuck and it’s not installing the files in the second part of the process

Where would I find the log file?

The log file should be on the USB stick.

I’m slightly confused with what is happening. Does it immediately go to the red screen when you insert the USB? Is there any error message associated with the red screen?

I would try using a different USB stick if that is the case. Since you are already in the reformat tool, please enter these settings in the updater app (toggle navigation depending on system spec):

Once you have configured the app with those settings, go ahead and select the new SYNC version you wish to go to. Remember to use another USB stick and not the same one you have already tried.

Here’s the log from the USB…

CYANLABS - SYN3 UPDATER - V2.4.2.0
Branch: Release
Operating System: Microsoft Windows 10 Pro (2009)

PREVIOUS CONFIGURATION
Version: 3.3.19052
Region: NA
Navigation: True
Mode: autoinstall

DESTINATION DETAILS
Mode: Drive
Model: Lexar USB Flash Drive USB Device 29.8GB
FileSystem: exFAT
Partition Type: MBR

AUTOINSTALL.LST
; CyanLabs Syn3Updater 2.x - Autoinstall Mode - Sync 3.4.20351 NA

[SYNCGen3.0_ALL_PRODUCT]
Item1 = APPS - 5U5T-14G381-EM_1611967752000.TAR.GZ
Open1 = SyncMyRide\5U5T-14G381-EM_1611967752000.TAR.GZ
Item2 = VOICE - 5U5T-14G391-CM_1598635923000.TAR.GZ
Open2 = SyncMyRide\5U5T-14G391-CM_1598635923000.TAR.GZ
Options = AutoInstall
[SYNCGen3.0_ALL]
Item1 = GRACENOTES - 4U5T-14G423-CB_1598636132000.TAR.GZ
Open1 = SyncMyRide\4U5T-14G423-CB_1598636132000.TAR.GZ
Options = Delay,Include,Transaction

FILES (3)
4U5T-14G423-CB_1598636132000.TAR.GZ (566.3MB)
5U5T-14G381-EM_1611967752000.TAR.GZ (848.6MB)
5U5T-14G391-CM_1598635923000.TAR.GZ (385.4MB)

LOG
[2021-03-24 2:06:07 PM] Selected Region: NA - Release: Sync 3.4.20351 - Map Version: Keep Existing Maps
[2021-03-24 2:06:07 PM] Install Mode: autoinstall
[2021-03-24 2:06:07 PM] Checking Existing File: 4U5T-14G423-CB_1598636132000.TAR.GZ
[2021-03-24 2:06:21 PM] Validated: 4U5T-14G423-CB_1598636132000.TAR.GZ (Skipping Download)
[2021-03-24 2:06:21 PM] Checking Existing File: 5U5T-14G381-EM_1611967752000.TAR.GZ
[2021-03-24 2:06:41 PM] Validated: 5U5T-14G381-EM_1611967752000.TAR.GZ (Skipping Download)
[2021-03-24 2:06:41 PM] Checking Existing File: 5U5T-14G391-CM_1598635923000.TAR.GZ
[2021-03-24 2:07:22 PM] Validated: 5U5T-14G391-CM_1598635923000.TAR.GZ (Skipping Download)
[2021-03-24 2:07:22 PM] Preparing USB drive
[2021-03-24 2:07:22 PM] Formatting USB drive
[2021-03-24 2:07:22 PM] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
[2021-03-24 2:07:30 PM] Generating Autoinstall.lst
[2021-03-24 2:07:30 PM] Checking Existing File: 4U5T-14G423-CB_1598636132000.TAR.GZ
[2021-03-24 2:07:30 PM] Copying: 4U5T-14G423-CB_1598636132000.TAR.GZ
[2021-03-24 2:08:30 PM] Validating: 4U5T-14G423-CB_1598636132000.TAR.GZ
[2021-03-24 2:08:32 PM] Copied: 4U5T-14G423-CB_1598636132000.TAR.GZ
[2021-03-24 2:08:32 PM] Checking Existing File: 5U5T-14G381-EM_1611967752000.TAR.GZ
[2021-03-24 2:08:32 PM] Copying: 5U5T-14G381-EM_1611967752000.TAR.GZ
[2021-03-24 2:10:00 PM] Validating: 5U5T-14G381-EM_1611967752000.TAR.GZ
[2021-03-24 2:10:03 PM] Copied: 5U5T-14G381-EM_1611967752000.TAR.GZ
[2021-03-24 2:10:03 PM] Checking Existing File: 5U5T-14G391-CM_1598635923000.TAR.GZ
[2021-03-24 2:10:03 PM] Copying: 5U5T-14G391-CM_1598635923000.TAR.GZ
[2021-03-24 2:10:43 PM] Validating: 5U5T-14G391-CM_1598635923000.TAR.GZ
[2021-03-24 2:10:44 PM] Copied: 5U5T-14G391-CM_1598635923000.TAR.GZ
[2021-03-24 2:10:44 PM] ALL FILES DOWNLOADED AND COPIED TO THE USB DRIVE SUCCESSFULLY!

This log doesn’t make sense if you are currently in the reformat tool. Based on this log, the USB would simply update you directly to 3.4.20351 and NOT reformat. Are you using the same USB for multiple installs without wiping it?

Regardless, follow the steps in my above post and let the updater app format your USB for you so you start fresh. It should then work.

Working on setting up this USB now. (A different USB than before)

1 Like

Red screen as soon as I plug in the USB.

I also pulled the battery for 10 minutes before reinserting the USB, same result.

Thanks for your help!

Can you provide me with a screenshot of the contents of your USB? As well as the contents of the reformat.lst file?

Also, please ensure that there are no other USB devices/SD cards plugged into your car at the same time.

David, do not take it the wrong way.
But you are making no sense, and you are not answering direct and simple questions…

Do you want help?, then answer what’s being asked.
Avdonr pointed out that the information you are giving us makes no sense, and I second that. You said you downgraded but the logs tell another story.

What have you done?, exactly…
And what are you trying to do now?.

Error says it is not finding a file, most likely due to user error.

image

So this all seems to be ok. Here are some things to try:

  1. Ensure no other USB sticks/devices are plugged into the car
  2. Use another USB port in your vehicle

I am not sure why it would fail to detect the packages on the USB. You may also just have a faulty USB hub.

Had another USB in the armrest. Seems to be loading up now. Thanks a ton!

3 Likes

Sweet, if this is an old version of SYNC you can then update to the latest build via autoinstall after the reformat process is done. Just put in 3.4.xxxxx as your current version and let the updater make a new USB for you with the new version.

Make sure you perform a master reset after this first install is done though.

I’ll confirm that it installed fine in about 25 minutes. Thanks again, you’re a lifesaver! :pray:

1 Like

That’s weird… Did you have that drive connected while the first part? (Downgrade)

Glad you solved it, it should finish ok without issues.

And also, why did you downgrade in the first place?.
If you wanted to update the build only, you can only upgrade APPS.