Update from 2.0.16074 (non nav) to latest ford version failed and blank screen

Hi guys, i’ve tried update my sync 3 from version 2.0.16074 to the latest provided by ford on their website. whilst doing the update i got distracted and the vehicle shut off causing the update to fail.

blank screen, no radio etc.

tried to upgrade via the syn3 updater after puttin gmy vin in… put usb into usb slots, restart using power and seek button… nothing. nothing changes on log file etc. usb slots light up and go off.

tried the interrogator and same as above, nothing.

bought a obd for forscan oblink ex… installed forscan 2.4 beta 3, reinstalled asbuilt data from fords website, had a look at the apim in the programming section and tried to update the firmware, it erases the blocks, installs all blocks then says it looks like the apim is bricked :frowning:

it does same no matter which version i select to update in the available tab.


SYNC Region: Europe

Navigation Variant: No

Install Type: Stock (Original Unit)

Old SYNC Version: 2.0.16074

New SYNC Version: 3.3.19052

Do you have a error message, if so what is it?
BLANK SCREEN

Update Method: Official Ford

Syn3 Updater Version:

Syn3 Updater Documentation Read:

Syn3 Updater Log File

Is the car under warranty?

afraid not

Ok, this is important.
Are you sure you were on 2.x and the update was to 3.2?. Do you have the contents on the Ford’s update USB?, specially the .lst files’ contents.

If it’s not under warranty, can you gain physical access to the unit?. It would be nice to double check the APIM’s and screen’s part number.

Has the unit event been serviced in the past?.

I put the vin into fords website for the update and that told me what was what. No idea if the parts been serviced before etc. Im quite handy with tools so i can get the unit out and check etc

This was taken before doing the update

Ok, and what about the target version?
Can you post the contents of the .lst files Ford provided to you?.

If you can gain access to the screen and apim would be great. This seems a case of reformating a MY20 component, but won’t be able to confirm that until we know both part numbers (APIM and screen) and the .lst files’ contents.

; SYNC3 Consumer Assembly Upgrade - Release 3.0.25 - Only for NonNav/EU assemblies.

[SYNCGen3.0_3.0.20204_PRODUCT]
Item1 = HB5T-14G386-THB
Open1 = SyncMyRide\HB5T-14G386-THB.tar.gz
Item2 = HB5T-14G386-TBC
Open2 = SyncMyRide\HB5T-14G386-TBC.tar.gz
Item3 = JR3T-14G391-AE
Open3 = SyncMyRide\JR3T-14G391-AE.tar.gz
Item4 = JR3T-14G381-AX
Open4 = SyncMyRide\JR3T-14G381-AX.tar.gz
Item5 = JR3T-14G423-AB
Open5 = SyncMyRide\JR3T-14G423-AB.tar.gz
Options = AutoInstall
[SYNCGen3.0_ALL]
Item1 = GB5T-14G386-AC
Open1 = SyncMyRide\GB5T-14G386-AC.tar.gz
Options = AutoInstall,Delay,Include,Transaction

is this what you need ?

Yes, thank you.
So that’s the only .lst file that Ford gave you, right?, the autoinstall.lst file…

That should not cause a black screen since it’s not a reformat process.

Lets wait for other members to jump in, but I’m not sure what’s going on.

Oh, btw, the target version is 3.0.20204, which is the latest 3.0. Which makes sense, since you can go from 2.0 to 3.3 without reformating, but since you are trying to go from 2.0 to 3.0, that’s ok.

Yes thays the only one i can see… not sure if there are any in the actual zip files for each of those files in the list… would you need any info from those zip files?

Not really, the names give them away.
There’s one thing that I could think of, but I’m shooting in the dark here.
Since you already have Forscan and an adapter, check which theme does the unit has.
You can find the code here → https://cyanlabs.net/asbuilt-db/sync3-apim/?search=Visual%20Design%20Variants%20(VDV)%20Sync%20Versions%203.0%20thru%203.4

Another thing I would try, is unplugging the battery for 30 minutes or so to force the modules to reset…

As you can see, I’m running out of ideas.

Sorry mate, total noob question

But how do i use that database? How will i find the modules theme

No worries.
The link I provided goes to the value, you just need to scroll down.
This is what you need to check on your unit:

Location

DE02/7D0-03-01: xxxx-**xx-xxxx

Values

Visual Themes Sync Versions 3.0 thru 3.3
00=Ford Classic (Blue Theme, Multi-colored Buttons) (Default Theme Ford)
01=Ford Timeless (Blue Theme, Blue Buttons)
02=Lincoln Timeless (Gold Theme, Black Icons)
03=Lincoln Next (Gold Theme, White Icons) (Default Theme Lincoln)
04=Ford GT (All Blue Theme for 2017 Ford GT) (N/A Sync 3.2 after My18.5)

For that, you need to check the asbuilt values via forscan.

Ahh i get ya, ok so i had i think version 2.2 maybe of forscan installed… and i couldnt program the module… i could do the as built data i got from ford tho… so i wrote the data to the module which worked fine. I then read about the beta version of forscan and being able to program the unit… i downloaded and installed the beta 3 version, programmed the apim to the recommended version and now i cant install the asbuilt data as it says theres a problem. It will however let me try to program the apim, which says to me it isnt dead. If that makes sense

Just a clarification, I’m not talking about reprograming anything yet.
There are not really a lot of reasons as to why an autoinstall would fail with a black screen.
One of those reasons may be theme related.
So, assuming the autoinstall was able to install 3.0 maybe the boot sequence does not complete because of an incompatible theme configuration.
If so, it’s an easy fix.
So with forscan, check asbuilt value DE02/7D0-03-01: xxxx-**xx-xxxx

7D0-03-01 0200 0003 03E3

00=Ford Classic (Blue Theme, Multi-colored Buttons) (Default Theme Ford)

that should be fine

Your Illumination Strategy is blank, which indicates an issue with the firmware, probably a compatibility issue. Were you able to successfully program the firmware to the -AGF calibration level? Or are you still at -ABB?

You need to program the correct Illumination file for the calibration level.You should force program the original files for -ABB. You need GB5T-14G379-BA.
GB5T-14G379-BA.VBF (1.6 KB)

3.0 APIM NAV Unit Firmware (Production Release, 2016-Early 2017, G-Early H Series)
GB5T-14G376-AA
GB5T-14G374-CB
GB5T-14G375-AA
GB5T-14G379-AA
GB5T-14G379-BA

See this doc for more information, APIM Firmware Flash Rescue - Ford / Information - CyanLabs Official Community but to program the Illumination file:
With the vehicle off, only flash the following:
SBL: GB5T-14G376-AA.VBF
ECU Config/Sound Profile (CAN): GB5T-14G379-AA
ECU Config/Illumination Strat (CAN): GB5T-14G379-BA

See if this works…

@Screwy any update from your side?.