Your current region and selected region do not match, this may not work!

I am trying to update a 2018 Ford Mustang GT premium from 3.0.17276 to latest 3.4.23188 and I get the error message in the title. The mustang has the nav system and the region is United States, Canada, and Mexico. Why am I getting this message?

NOTE: I created a new profile. Region is correct. Language is English. Navigation is enabled. Release branch is stable. I am not editing advanced options. I applied the settings.

On the next screen, I also select United States, Canada, and Mexico. Version is Sync 3.4.23188. Map is 2.23 (2023) - NA. I click Start and so “No” to is it a 2020 or newer vehicle, and then I get that warning.

Why? How do I resolve?


SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.0.17276

New SYNC Version: 3.4.23188

Do you have a error message, if so what is it?
Your current region and selected region do not match, this may not work!

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: 2.12.5.0 (Stable)

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

n/a - I am not creating the USB and attempting to install with this warning. 

It’s an unresolved and uncommon bug.
If the vehicle is NA and you are selecting NA while on the HOME tab, proceed with the USB creation and ignore the region mismatch warning.

The reason was actually found, it’s when you change the application language but don’t restart

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.