Cyanlabs Updater/Launcher Not Working?

I’ve tries to install the latest installer on my computer Windows 10 Home Edition, when installation is completed it will not launch the program, and also when i double click the icon on my desktop, it does the same thing. will not launch the program.

please advise any fix up needed

Do you have Net Framework 4.7.2 installed?

1 Like

i have net framework 4.8 installed.
tried to install 4.7.2, but it will not install as i have a newer version.

I’ve even tried by disabling my antivirus & firewall software, but still will not open up.

Have you tried right clicking the shortcut and launching it as admin?

Just to discard an unlikely compatibility issues, uninstall your current framework version and install 4.7.2. Also make sure to uninstall Syn3updater and installing it again.

Finally, if that does not work, check Windows’ event viewer to see what’s going on when you try executing the application.

1 Like

I ran winver on my computer, and this is the information that might help solve my problem.
Windows 10
Version 21H1 (OS Build 19043. 1387)
which automatically installs 4.8

and when i go to Microsoft website, it informs me that I can not install Net Framework 4.7.2 , it will not run on my operating system.

is there another version of Sync3Updater that will rum on 4.8

thanks and await your reply.
regards Frank

Frank, trying 4.7.2 was one of three things you could try, what about the other 2?

when i uninstall net framework 4.8 from my windows 10 computer, and restart it it automatically installs it again, this version of windows 10 will not accept net framework 4.7.2

also i ran event viewer after trying to execute Sync3Update icon and it’s

please advise what you mean " what about the other 2?"


this is the windows 10 built details

Right clicking the icon and launching Syn3updater as admin, and the even viewer thing that you already tried.

Let me tell you something: there’s something funny with your PC, since you can’t see to even open Event Viewer.

This is what it should look like:


(I know it’s in spanish)

If you can’t launch Syn3updater and can’t view the Event Viewer to see what’s going on, we are running out of options.

Do you have access to another computer to try there?

hi when i run event viewer this is what i get.

i’ve rolled my computer back 1 month, still no good.
I also ran dotnetfx_cleanup_tool - still no good
I also ran netfix repair_tool - also no good

You either have a really broken windows installation or are not administrator.

Problem Solved.

I reformated, and deleted my master boot record on my computer & re-installed Windows 10, etc and also Sync3 Updater and now it works fine.
My windows 10 must have been corrupted.


Good solution, there was something wrong with your previous W10 installation.
Thanks for the update!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.