FordPass: missing lock/unlock buttons and other multiple functions

Hello guys, maybe someone can bring some light here. About a month ago I moved to Poland from Bulgaria and most part of FordPass functionality is just gone. All I have is shown on the attached screenshots. I’ve re-added the car from the account, reinstalled FordPass app, signed out and back in again, nothing helped so far. The most funny thing is when I login into the FordPass account using a browser, it shows the oil level, tire pressure etc, while this information is missing in the app. Has anybody faced this kind of a problem? I would really appreciate some help here. Thanks.





All the useful bits of Fordpass were removed on my model Focus, It lost all functionality so i got rid of it, last i checked i can install it on my phone but the SYNC unit doesn’t show it or any other app anymore. I’d like an update to get the useless button off my screen.

I have also authorized a newly created user to control the car and it has the same functionality as I. Seems like this issue comes from Ford servers :frowning:

Another idea: I’m missing this Connectivity Settings. Maybe it’s the root of the issue? Which APIM config should be edited for this menu item to appear?

Ok, got the above mentioned option enabled with the as-built bellow (I had to activate Customer Connectivity Setting), but still when I press it I get the empty popup.

As far as I can see, bellow options should be available under Connectivity Settings:

Vehicle Connectivity
Location
Veh. Data & Remote Control
Insurance-Related Data

But it doesn’t happen in my case.

Here’s the as-built which I’ve edited:
7D0-08-01: xxx*-xxxx-xxxx
Mobile Navigation (MN)
Message Set (MS)
X40 Setting (X40)
Customer Connectivity Setting (CCS)

0=MN Enabled, MS Legacy, X40: Pre X40 SDARS, CCS Disabled
1=MN Enabled, MS Legacy, X40: Pre X40 SDARS, CCS Enabled
2=MN Enabled, MS Legacy, X40: X40 SDARS, CCS Disabled
3=MN Enabled, MS Legacy, X40: X40 SDARS, CCS Enabled
4=MN Enabled, MS New, X40: Pre X40 SDARS, CCS Disabled
5=MN Enabled, MS New, X40: Pre X40 SDARS, CCS Enabled
6=MN Enabled, MS New, X40: X40 SDARS, CCS Disabled
7=MN Enabled, MS New, X40: X40 SDARS, CCS Enabled
8=MN Disabled, MS Legacy, X40: Pre X40 SDARS, CCS Disabled
9=MN Disabled, MS Legacy, X40: Pre X40 SDARS, CCS Enabled
A=MN Disabled, MS Legacy, X40: X40 SDARS, CCS Disabled
B=MN Disabled, MS Legacy, X40: X40 SDARS, CCS Enabled
C=MN Disabled, MS New, X40: Pre X40 SDARS, CCS Disabled
D=MN Disabled, MS New, X40: Pre X40 SDARS, CCS Enabled
E=MN Disabled, MS New, X40: X40 SDARS, CCS Disabled
F=MN Disabled, MS New, X40: X40 SDARS, CCS Enabled


I don’t believe any year Fusion has connectivity settings. I have a 2020 and it does not have it. If you turned this on with Forscan like you mentioned than you’re wasting your time. This requires HS4 and a TCU that is on HS4 with the correct Firmware which is usually an L+ series TCU. It also requires a GWM that has HS4 in it that is wired to the APIM. Again, no Fusion ever came with this especially a 2016.

Based on what I see in the pics you show that is what it does. Gives a blank close box. You cannot add HS4 either unless you change the firmware in all the modules and replace half of them. When you put the new GWM with HS4 in that changes all the communication paths and will cause a lot of errors if you do it. With the right TCU and wiring you can get the Connectivity settings to work but it will cause havoc with everything else.

As you will find in many cases, just because you can turn it on does not mean it will work. Most items require the supporting hardware and Firmware.

Also just to go back to basics: Connectivity settings have absolutely nothing to do with the basic FordPass functionality and has been discussed previously in some of the other TCU threads here. My own firsthand experience with my C-Max Energi it doesn’t have any of the extra connectivity/hotspot menus enabled in the APIM and all FordPass functionality is there and works. IIRC F150Guy mentioned that is more for higher end vehicles like Lincolns that may have some extra cellular provided multimedia features? My memory is a bit vague on that.

If the remote start/lock/unlock functions worked previously, the only thing I can possibly suggest is doing a master reset to clear the pairing with Ford and re-add the vehicle in FordPass and see if it returns. Looks like everything else is updating normally so I can’t see it being a cellular connectivity issue from the move (but that’s just a guess).

Just to absolutely rule something out: Were any changes made to the TCU AsBuilt between it working and not? If so, can you detail those changes? The 754-01-01: xx**-xx set of bits are bugging me (The 38 you have there isn’t in the DB and I can’t recall what other bits match up so it may be nothing at all).

Thanks for the reply. I never had those connectivity settings working either, however lock/unlock functions always worked before. I used to have them working for nearly two years and suddenly they just disappeared two or three weeks ago. I didn’t apply any changes to any of car’s modules. I did Sync 3 master reset, removed the app from my phone, signed out and back in again with FordPass and nothing helped. I even created a new FordPass user and shared access with him, still no luck. The 754-01-01: xx38-xx corresponds to 38=VA CGEA 1.3, TDR EU, OCS Configured. I doubt the issue comes from these bits since everything used to work well with it before.

I apologize. I’m so used to the H TCU’s which don’t have anything in the 3x range which threw me but the J and later models do. So ignore that part of my post. :sweat_smile:

To me it sounds like you’ve tried all the usual troubleshooting steps for these. And it seems the TCU is functioning normally if all the other data is there. In my second hand experience walking others through this in the past at least on the C-Max, those remote lock/unlock/start buttons should still show even if the wrong architecture is configured but they usually just error out. So with all the troubleshooting you’ve done and the AsBuilt looking ok at least at first glance, I’m at a loss myself as to the cause. Unless Ford is doing some kind of geo-blocking on the backend. But that’s just a wild guess.

I’ll leave this for others that are more knowledgeable to chime in if they have any ideas.

Thanks for the reply. Yes, seems like I’ve done everything but one thing: disconnect the 12v battery and leave it for 5-10 mins. It’s the only solution that comes to my mind so far. Truly saying, I really doubt it will help, but it’s worth trying.

So one extra thing I’ll add and this might be useful for anyone else doing troubleshooting with TCU stuff. Caveat being this uses a third party tool to access Ford’s API which in the past have been somewhat problematic (but I think the biggest issue was the polling rate being used which has since been fixed. YMMV and ‘you do so at your own risk’ of course):

I have recently discovered that the FordPass Home Assistant integration has a kind of ‘diagnostic’ script that pulls a full JSON response from Ford’s servers that has a ton of info including listing what features they are seeing as supported/allowed on your vehicle. There’s some more info on the page below:

Best I can tell you do need to have it set up in HA first to get the auth tokens generated (I want to see if maybe I can fork this and make it work standalone. I have some other potential uses for this myself…) but it could be a useful tool. But as always with the previous issues within the community having accounts locked out for using third party tools (which since have at least been greatly mitigated AFAIK), I’ll leave the disclaimer: You use it at your own risk/YMMV/etc… But a one-off request shouldn’t be an issue.

(If you do choose to use it, keep the REDACTION = True line set. That’ll redact stuff like your VIN, vehicle location, and other sensitive info)

Ok, thanks. Sounds to be a good idea. The only thing I’m not pretty sure how to use it. Can you PM me the steps or instructions? Thanks.