Possible bricked apim (blank screen)

2019 Ford Expedition Limited Edition

Before I did anything my unit was on the following:

SYNC 3, Software Version: 3.4 Build 20136_PRODUCT

I tried to update using ford site with my vin and it said there was an update available and allowed me to download it but when I tried to update using the usb it said this version is not compatible and reset itself.

This sent me down this path of trying to use cyanlabs to update to the current Sync 3.4.23188.

I went through the steps to download using the sync updater tool after carefully watching a video and reading… I selected my usb path, region and from drop down menus I chose version - sync 3.4.23188 and 2.2 updated voice maps.

Next my20 question was a no since it’s a 2019.

(I purchased this vehicle used recently so maybe it was replaced)

The next part took over 3 hours to create the usb. Here’s the weird part though I seen that while it was going through the download and verification steps that it said “downgrade” below install mode… I thought this was weird but felt confident I had selected the most up to date version so I let it continue.

This morning I was so eager to update so I cranked the vehicle and turn off auto shut down assuming it was going to take a long time to update… unit said updating system software for only about 10 minutes then popped up a key cycle screen that said something like “the first step of the process has begun” but then the unit reset before I could read it. When it came back it said unit was successfully updated but looked totally different… I went to see what version I was on and to my disbelief I was on 3.3 but before I could see much else the unit said something about removing the usb stick which was still inserted then bam, screen went black and has not come back on.

I’ve tried soft reset and I’ve disconnected the battery for a while but still nothing… my isb lights light up but not the lights on volume, track buttons, tune etc…

Have I bricked my unit?

Based on what you are describing, it looks like yes, it’s bricked.
The black screen came right after being temporarily running 3.3 which enables the reformat package to be installed. You can’t reformat a MY20 unit.

This is a shame. Should you have answered differently, Syn3updater would have created an USB to check the unit before proceeding.

At this point, you would need to unmount the unit to see which model it is: there’s a sticker on its back.

Do you have forscan an adapter?. I believe that even bricked you could read the APIM’s information through Forscan.

No I don’t have a forscan adapter… would the sticker on the back confirm if it’s a my20 unit?

Yes, it will.
If you go for it, please take a picture of the sticker and send it over.

Just for reference, this is what you are looking for:

While you are on it, check the screen’s sticker as well.

Manufacture date 2021 smh

Is there anything I can do or do I need to get on eBay and order a replacement apim?

Do not post consecutive messages, use the edit button instead. I’ve merged your messages.

That APIM is dead, you will need to get a replacement.
Source one from a respectable seller, do not buy anything from China.

My apologies… does my apim have any resale value? Can it be reflashed on a bench?

1 Like

It can be recovered, but no by the normal/average end user, it needs specialized hardware. So I believe it may have some resell value.

Since you are NA based, you may want to get in touch with https://naviupgrade.com/ , @NaviUpgrade is a forum member as well.

Keep in mind that the replacement APIM will most likely need to be programmed based on your vehicle. This can be done by the user (forscan + adapter), but most sellers will do this for you.

Hey @SaNdMaN thanks for the @!

I’ve actually just ventured into unbricking units, and been quite successful at it! It requires Linux and physical access to the boards inside the module.

If you’d like to reach out via my site I can help you out.

Cheers!


Brian

were you able to fix it ?

In the interest of transparency here is the documentation for the method NaviUpgrade is referring to.

Linux, Physical access to the internal APIM board, Mini USB cable and CAN emulation of some sort (or maybe in the car would work also) are required.

If you struggle to work Syn3Updater, Autoinstall.lst files or anything similiar DO NOT ATTEMPT THIS, instead get someone with more knowledge to assist, whether thats a friend, NaviUpgrade or someone else :slight_smile:

NOTE: This method is not new, but it’s become more widespread and refined more recently

1 Like

This precisely!

Probably going to be making a video on it soon, but I’m not going to show people how to install linux because that’s been discussed on the web moooore than enough.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.