Re-enabling climate domain/repeater options after 3.4 update + parking sensor display

As I’ve posted elsewhere, recently got my 2013 US C-Max Energi (SEL trim, dual zone climate) updated from Sync 2/MFT to Sync 3. Got it preprogrammed and arrived with version 3.4.19101. The climate domain was available at this time and functioned fine.

Updated to 3.4.21020 and that went absolutely perfect. No issues to note other than the expected screen flickering when the ambient lighting changes. No worries here. Also as expected is the climate domain disappeared.

So I’ve been working on trying to get this added back in and on top of that I wanted to add the parking sensor display function if I can.

For the AsBuilt the only change I made was this for the parking sensors:

7D0-01-01: 2328-6503-80
to
7D0-01-01: 2B28-6503-80

Mind you I’m still running old PAM firmware (I believe). I don’t have the equipment yet to update it but I was also under the assumption the update was only required for the automatic parking functions and not the parking sensors themselves. If this is not the case I’m cool with it, just need clarification. Just means I need to move up getting the necessary adapter for ForScan. I have waited about a week and a half at this point and the top-down sensor view does not show on the reverse camera display.

PAM - Parking Aid Module
Part number: CJ5T-15K866-BE
Strategy : CJ5T-14C090-BE
Calibration: CJ5T-14C091-BF


For climate if I read the AsBuilt DB and its notes correctly, it had already been set where it should be (or at least it was going by the initial backup I made):

7D0-04-01: 0100-0401-00

Which correct me if I read it wrong, but for v3.4 XXXX-XX01-XX should enable the climate domain for dual zone systems. So far here no climate domain and no repeater functions. Not sure if I understood the notes incorrectly or if I’m missing another necessary change.


Quick side questions semi-related:

  1. Never paid close attention to it on the previous update, but with the climate domain added will it enable the display of driver/passenger temps on the top bar or is that a separate setting that needs to be enabled? Didn’t notice anything in the AsBuilt DB that seemed to link up to that so was curious.

  2. Very long shot on this one: As this model year vehicle did not come with FordPass but rather MyFordMobile as the telematics service, is it possible to enable the vehicle health stuff in the FordPass app via the Bluetooth link to the car or does that distinctly require a FordPass modem?

I think there are additional settings in the PAM to make on this, but @Louage will know better than I about this one…

This requires a FordPass modem now in the US (NA). The old health report system is discontinued.

Yes

As far as the climate settings, a 2013 C-Max should have “Legacy Climate” which should use the following settings. (Provided it will work…)
NOTE - The values below refer to double bit setting:
7D0-04-01 xxxx-xx**-xxxx
For 3.2 and lower:
00: Enable Climate Control Repeater for Dual Climate Control
01: Disable Climate Control Repeater
For 3.3/3.4:
00: Enable Climate Control Repeater for Dual Climate Control
01: Disable Climate Control Repeater for Dual Climate Control
02: Enable Climate Control Repeater for Single Climate Control
03: Disable Climate Control Repeater for Single Climate Control
80: Disable Climate Control Repeater for Dual Climate Control

NOTE: To disable climate an additional change is needed in 7D0-01-01: xxxx-xxx*-xxxx - a change of climate from dual to single mode is needed. Reverse this for enabling. A master reset is required for changes to take effect.

You will need one of the highlighted settings, whichever is correct for your vehicle.

7D0-01-01 xxxx xxx* xxxx
Digital Audio Broadcast (DAB), Climate Front Zones, Steering Wheel Angle Sensor, HD Radio
0=DAB Disabled, Dual Zone, Steering Wheel Angle Relative, HD Radio Disabled
1=DAB Disabled, Dual Zone, Steering Wheel Angle Relative, HD Radio Enabled
2=DAB Disabled, Dual Zone, Steering Wheel Angle Absolute, HD Radio Disabled
3=DAB Disabled, Dual Zone, Steering Wheel Angle Absolute, HD Radio Enabled
4=DAB Disabled, Single Zone, Steering Wheel Angle Relative, HD Radio Disabled
5=DAB Disabled, Single Zone, Steering Wheel Angle Relative, HD Radio Enabled
6=DAB Disabled, Single Zone, Steering Wheel Angle Absolute, HD Radio Disabled
7=DAB Disabled, Single Zone, Steering Wheel Angle Absolute, HD Radio Enabled
8=DAB Enabled, Dual Zone, Steering Wheel Angle Relative, HD Radio Disabled
9=DAB Enabled, Dual Zone, Steering Wheel Angle Relative, HD Radio Enabled
A=DAB Enabled, Dual Zone, Steering Wheel Angle Absolute, HD Radio Disabled
B=DAB Enabled, Dual Zone, Steering Wheel Angle Absolute, HD Radio Enabled
C=DAB Enabled, Single Zone, Steering Wheel Angle Relative, HD Radio Disabled
D=DAB Enabled, Single Zone, Steering Wheel Angle Relative, HD Radio Enabled
E=DAB Enabled, Single Zone, Steering Wheel Angle Absolute, HD Radio Disabled
F=DAB Enabled, Single Zone, Steering Wheel Angle Absolute, HD Radio Enabled

1 Like

First step is a PAM calibration update or replace the PAM if possible on your vehicle to a newer one. I’m not familiar with the US c-max so can’t comment on part numbers but it physically looks identical to the focus one.

Thanks guys. I’m actually taking her in today for some unrelated work/scheduled maintenance so will be out of commission for the next few days.

Climate control I’ll definitely play with that toggle when I next get the chance but looks like that should solve it. Parking sensors: I’ll push up getting the appropriate OBDLink adapter and try the firmware/calibration update first and see how that goes before moving on to a full module replacement. Will report back on any of this when I have new info. :slight_smile:

If you plan on doing firmware programming with modules, use the OBDLink EX. Don’t mess around with those cheap Chinese knockoffs.

or UCDS :wink:

1 Like

hi,

i have climate working fine but misses the button to activate the heater of the back glass.
Anyone knows how to fix that?

Thanks in advance

Kind Regards

A.F

I have not seen an adjustment for that feature in Sync.

Ok, please feel free to call me a Noob on this, but could someone please make this fix easier to understand!
I just upgraded my 2018 Focus RS last night (latest release from here) NA. It installed fine and seems to work ok.
I do have a question concerning the “Climate” (on-screen option) tho. I have never had this option before on my car, BUT have watched other people with similar car models get it after this upgrade. I was wondering if one of you can tell me if I am doing something wrong or I just need to change something to get this to work?
Please make it as simple as I am a noobie and this … thx

Did you originally have this option on screen before the upgrade to Sync 3.4? What version were you on originally, like 3.0.xxx?

You will need FORScan and a OBD2 adapter to make the changes to the APIM.

So just got a chance to try the necessary AsBuilt changes at least for the climate domain. Sadly doesn’t seem like it worked. Made the change, master reset the APIM, still no climate tab and no repeater popups.


Short of me being dumb and missing something, I’m guessing this is the end of the line for this option on my vehicle. Which is odd considering 3.4.19101 it worked perfectly. But far from an issue for me. I rarely used the on screen controls anyways with MyFord Touch. This was just a nicety to have added. :slight_smile:

3.4.19101 was a broken app, that’s why it worked. It was not supposed to. I’m not familiar enough with a C-Max to say that it would work or not. Maybe @Louage knows…

Try this:

7D0-01-02: ####-#X##-####

A = Mode man climate enabled, climate control Auto, Surround sound not available in occupancy mode, Navigation Repeater Motorola Format

1 Like

Is this just the type of climate control? What is the meaning of ‘mode man’? This seems to be disabled on most US vehicles.

That change did the trick! Climate domain, temp repeater. And the controls do function. Worked without a master reset, just a full power cycle. So to recap, these are the changes made on this:

7D0-04-01 xxxx-xx**-xxxx – from 01 to 00
7D0-01-02 xxxx-x*xx-xxxx – from 6 to A

Only thing I noticed, and it may just have been me playing around (after confirming climate worked, I cycled ignition a few times for another power cycle but I don’t think it fully completed), but the boot screen wasn’t popping up on start or shutdown. Gonna be out later this afternoon and will check on that and do the master reset if needed.

1 Like

Thanks for the feedback, glad it worked for you. Enjoy!

I’m not entirely sure! I know that it seems to enable the climate control on C1MCA vehicles. Setting the auto climate setting also seems to make it available too.

1 Like

This makes sense now…thanks.