SiriusXM Station Logos Gone for Good?

I understand that there are known issues with SXM station logos being lost after an upgrade. That happened to me and I’m looking for advice on what to try next to troubleshoot the issue. Here’s what I’ve done so far to my 2018 Mustang GT Premium with Sync 3, no nav:

  1. Manual upgrade from 3.0 to 3.4. 20136, followed by a master reset. Week passed with no SXM radio station logos appearing. From this point on I have the Calm Screen option and it is persistent.
  2. Windows automatic upgrade (set to NA, no nav) to 3.4.20282 with a reformat (out of memory error without the reformat), followed by a master reset.
  3. Sent repeated SXM refresh signals, waited a few days.
  4. Changed APIM as-built config 7D-02-03 from X4-XX-XX to XC-XX-XX (I have not attempted to upgrade the APIM calibration firmware). Performed master reset. This didn’t appear to do anything.

What else can I try to get my SiriusXM station logos back?

Honestly, not a lot. The NON-NAV units seem to really have issues with SiriusXM logos. This is documented in many forums. Just on F150Forum.com, this is discussed at length.

https://www.f150forum.com/search.php?searchid=18810639

Updating the APIM firmware will not help.

Thanks for the info. I’ll keep experimenting as time permits. Today I removed the Gracenote database to see if freeing up some storage space would help with the SXM station logos - it did not.

My 2017 Ford Escape Titanium with Nav unit that is having issues with no Sirius logos…
its bizzare though,
My other 2017 Escape SE, also with Nav, I updated directly from sync 3, to 3.4.20282 and bam, I got Logos…

So 2 of the same model year, one has the logos and one does not. It doesn’t make sense. I am debating on doing a downgrade and reformatting and reinstalling direct to 282 again…

If anyone has had any success in restoring them, please share how.

Try going into the sirius channel guide, then select on all channels, then on the right there should be a button that says “update”. If this doesn’t fix it, maybe a master reset will do.

1 Like

Thanks for the suggestion. The “update” button didn’t work, and I’ve done a number of master resets while trying to solve this issue,

Then go into siriusxms website and look for a button to refresh your radio. Put your Sirius esn or vin and refresh it.

Tried that as well. - twice. No logos, even after waiting a few days.

no dice here either…

thoughts as to why the SE had the logos and the titianium not. Both are Nav units.
My titanium has the tech package, so I have the self parking feature which shows on the Sync…I am guessing there is a memory limitation issue at play.
I do plan to try to restore as low a version as I can to see if I can get the logos back, downgrade, and reformat and reinstall the same base 3.4 version. if still no logos then I think I will be officially hooped and stuck without.
Everything works, just my OCD going bonkers not having the logos…

Let us know if downgrading works. Going to 3.3.19052 is the last version of non 3.4 software. As far as storage (memory) space, this will be close to the same as 3.2.xxx versions. I have seen reports of this working, and also not.