SYN3 Updater was getting Error Invalid Class

Just wanted to throw this up here. I had an updated Windows 10 Home Edition on a 2013 Lenovo Yoga Laptop.

Tried to download Syn3 Updater. A red box would pop up and say “error invalid class” and I could not see a flash drive or select a different place to download the update file. I searched the forum for solutions; looked like there was a couple fixes that worked for people (.NET issues, enabling WMI on the firewall, etc.). I tried all of those, reinstalling the updater and restarting my computer every time just in case.

What ended up fixing my issue was backing up my files and reinstalling windows. Must’ve had some corrupted files or programs or something. No clue, not super computer savvy. Just wanted to put this out there as a potential fix for people who may find the same issue as me.

SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: Retrofit

Old SYNC Version: 3.3.18266

New SYNC Version: 3.4.22251

Do you have a error message, if so what is it?
invalid class

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: Stable

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File


Thank you for letting us know, also glad that it got sorted out somehow.
I’m moving the thread to the correct section on the forums.

Your namespacees were disabled or corrupt Invalid Namespace Error - #13 by CyanLabs