Syn3 updater wont download

Tried loads of times coz i’m trying to upgrade Sync 3 to Sync 3.4 can someone help please

Do you get an error message? If so, what is it?

it just say’s Launcher has stopped working

Install net framework 4.7.2 as mentioned on the application page

1 Like

I tried the update to sync 3.4 manually coz the syn updater wouldn’t download. Take the advice everyone when it says use the automatic one. My screen just cycles from Ford logo to Shelby logo then the mustang logo. Been to my Ford dealership & the module in my car is now totally corrupt. Waiting for new module & been told it’s £500 plus vat for new 1 & fitting. Think I’ll stay to just doing the Ford updates in future :see_no_evil::see_no_evil::see_no_evil::see_no_evil:

It isn’t corrupt, just recreate a new usb properly using the automatic download and let it finish the install. If you’ve done it manually you’ve undoubtedly made an error. Don’t pointlessly throw money away.

The trouble is I couldn’t get the windows updater to download to my computer :scream: I asked on all the forums if anyone else had this problem but no answer. So I tried the manual way & that’s where I am (release) is hanging in the download portion. No error message… just freezes and must force close it to restart in Task Manager. I already running net framework 4.7.2 or later.

Do download ONLY, do not select a USB… eventually, after a couple hangs where I need to Force Close the application, everything gets downloaded.
Then I restart it again and do the same but this time selecting the USB and it writes successfully and ready to install.

I’m having this issue, too. I’ve tried to download the syn3 windows installer file with Chrome, Firefox and Edge, and the download fails every time. It’s a partial download, and when I try to run the exe, Win10 says it won’t run on my PC. But every browser says, “Download Failed” before I try to run whatever partial download gets here. Is there a download mirror somewhere other than this site, or can you download an exe install file form Github?

My download link works fine, the issue is your provider or security software. No mirrors will be provided