TCU Wait for home status

Hi all.
I’ve got 2019 Lincoln Navigator from Canada that was imported to US. I’ve exchanged TCU for the one I’ve purchased on eBay locally in US that has the same part number (jl3t-14g087-ck). After the update, no matter what I do the TCU_AUTHSTATE doesn’t go beyond “Wait for home” status.
TCU_STATE: Operational
Netword_Indetity_TCU: 410
Country_Identity_TCU: 310
TCU_AUTHSTATE: Wait for home

I’ve tried the following:
-Updated 754-01-01 from B142 (initial state after the swap, before the swap it was B132) to B103 to push it to the Factory mode(B100 didn’t make any effect) and made Master reset for Sync(3.4) on this step.
-Switched to B100, the status was updated to Unprovisioned mode from the Factory mode.
-Switched to B132, the status was updated to Searching for provisioning (something like that) for a second and then to Wait for home and doesn’t go any further.

I’ve also tried updating APIM Country from CA to NA and repeating the procedure, but it made no effect.

How I can push this process further?
Thanks in advance.

SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.0

New SYNC Version: 3.4.22110

Do you have a error message, if so what is it?

Update Method: CyanLabs Manual Method

Post the TCU and APIM asbuilts, please.

Quick update here. After one week of waiting, I connected the computer to check the status and it was updated to Waiting for authorization (I did nothing after the last check). After that, I was able to connect the application. It looks like either TCU was downloading something from the server that took additional time or it required some authorization from the server that was received during the past week.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.