TCU Waiting For Home URL

Hello i need some Help Please.
i got used Ford fusion energi 2017. i decided to get access true the Ford pass and then i founded my car is with 3G modem, and need to be updated to 4G i did some research and founded some info, (obviously not enough). So got 4G modem install it with correct antenna and extension cable and all are working on forscan showing like unit its working but I’m getting message only " Waiting For Home URL" and is no way to activated from app. spoke with Ford Pass team they say no connectivity to the car

Some info:
My old Unit :HS7T-14G087-ED (old
Updated to : HJ5T-14G087-UF (all pictures for this unit)

and from this point i don’t know what to do.

Please Help i try multiple settings for TCU no Change same message

Sync 3.0.20204
Picture attached

Thank you

Not sure which TCU AB picture is for what TCU Model number so if you could notate that above them that would help.

With the quick little bit of looking I did it would seem you just replaced it with another 3G TCU. Not 100% sure though as there is no public database I can find to confirm this.

Not knowing which is which I also think you AB settings are wrong when I looked over them real quick.

That would be the same part number which was in my 2018 Fusion Hybrid Platinum and it’s a 4G unit.

Have you added the correct PIFA antenna?
The antenna in the kit for the Energi is part number NL1Z-190A390-A or you can use a Ford PIFA pulled from an F150, Fusion, Escape, etc.
This is the kit patch antenna:

This is the rear deck of a 2018 Hybrid with the TCU and factory antenna.

Here’s my factory AB for the TCU, you can try just dropping it into your TCU and seeing if it will activate since you’re in the same platform (Fusion). If not try following the instructions to get the unit into factory mode first and change 754-01-01 xxxX to a 3
2018 Fusion Hybrid TCU.abt (268 Bytes)

Yes I used antena from F150 because first I try one from Amazon but that one was giving error so got original

So now no errors only problem I’m getting this message waiting for Home URL

Not able to sync with my ford pass app

Thank you for TCU data.

My be some one have data from Working TCU from PHEV car?

Thank you in advance

If you use my AsBuilt, once you get it registered, online and working in FordPass, all you need to do is flip the bit 754-01-01 x3xx xx to x8xx xx.

1=Conventional gas engine

You won’t need to re-register it afterwards.

If you haven’t looked at F150Chief’s TCU guide, here’s a link.
Granted it refers to adding a JL3T series, but it explains the steps to move the TCU through the necessary modes.

By this information looks like I have Canadian TCU ? Is this correct ?

Ordered from California

I’m right ? Or I’m understanding something wrong ?

“Canadian vehicles will use 754-05-xx (754G5G1/754G5G2) rather than 754-06-xx (754G6G1/754G6G2) for
US models for Block 5 data. Canadian TCU’s will not work in the US, and vice versa.”

Remember his doc is based around a J series, you have an H.
The part you need to pay attention to are the activation instructions on page 5.
With the engine RUNNING go into the TCU AsBuilt and flip 754-01-01 xxx2 to xxx3, don’t stop the engine after doing this, ignore ForScan and tell it you did it.
Then go to the table and look at the state, if you’re in good cell coverage you should see it go to factory mode, once it does this flip it back to xxx2.

With the number of vehicles coming back across the border its possible to have a Canadian car here in the US, the AB I provided is for a US Fusion with an H series TCU.

Can you please take picture of your TCU settings to see section 5 with what number starts ?

Or may be you have it?

Thank you for your help

Not sure what you mean by this, you can drop an AB file in directly using ForScan and you can compare AB files using AsBuilt Explorer.

Do you have the VIN of the TCU donor?

I ask for Vin and they give me wrong one

Also you can see in as-build numbers witch can be modified , but it m asking for one can’t be modified

I think you’re missing the forest for the trees here.
The goal is to get the TCU to activate FIRST without changing any other values that were in it from the donor.
Have you made the changes to the APIM so that it knows you have a TCU?
Next, the TCU
IF you did a backup of the TCU AB as it was when you received it, restore it and change 754-01-01 xxxX to a 3, it has to be in factory mode to authorize, whether its a PHEV, Hybrid or conventional at this point doesn’t matter. The goal is to get it activated.

Once you get it activated, you can’t use anything from your Energi’s AB since it’s for a different model of TCU. My suggestion here is that you drop in the AB that I provided above, it’s a known good zero modification config from my 2018 Fusion Platinum Hybrid the alert types are in it for the HVB, BECM, etc as is the correct keep alive for a Fusion. Unlike the Energi of any trim or year, the Platinum Hybrid received a 4G TCU H series from the factory.

After you have that in, change 754-01-01 xxxx to 0832 and leave it be to give Fordpass time to check in.

Hello so today after many try and used TCU settings from different car
founded difference between my TCU and Ford Fusion Hybrid 2018 TCU is only difference 754-01- my is B832 and your car is hybrid B332 that’s it everything else is exactly the same.

and Check APIM and all configuration its correct

Then change settings to ***1 and it go in Factory mode and stay like that wait about 30 min then change it to ***3 same thing nothing change getting Unprovisioned mode mode about 30 min no change. then switch back to ***2 and getting and I’m getting : First when getting all signals after I’m getting from

Unprovisioned mode fast to:
Waiting For provisioning mode Ack Mode : less then a second
Waiting for Home URL and stay in this mode

so its not Helping

And yes my module come from CANADA i still don’t have right VIN from donor car
now im looking to send it back and try to get correct part from USA

Call today local dealer and they say for my car correct part number is Hs7z-14G229-Q and this part is from series of my OLD TCU witch was 3G.

so I’m confused where to get right part because at the dealer they don’t know exact witch is 3G, and witch is 4G

and on eBay both units (HJ5T-14G087-UF) available are from CANADA.

any advice ???

i will check my be part for ford fusion hybrid platinum my be i will get right part.

Thank you

Check your PM

What firmware is loaded in the TCU? You need at least -UM. That is showing in the pic above but what does the Forescan module listing say.
These H series TCU’s are for NA, does not matter the country. Your settings look correct for the TCU and APIM as long as you are installing this in a hybrid.
Does the TCU serial number appear on the ‘About Sync’ info page?
In your description of what you did to activate the unit, you say you changed the B832 value to B831. Change it to B830, wait for factory mode.
Before you do all this, make sure you have deleted your vehicle from the FordPass app, deleted the FordPass app from the phone, reboot the phone. Do a master reset on Sync, wait for Sync to reboot. Now shut down the vehicle for a few minutes. You need the TCU to stop activity.
After all this, start the vehicle, reset the TCU. Now you can start the activation process.
All this is to clear the data in the FordPass system, which must be done for you to use the modem in your vehicle. This one is being a bit stubborn it seems.

Hello so try today what F150Chief instructed

So first check real firmware on forscan and founded

is UM but it have upgrade

Then used used for FJDS updated to latest one

after tested again with forscan if it see it updated and correct version and all was working good

after this try settings firs from B832 move it to B830 and nothing change it wait about 10 min in this mode and reset sync same message i was getting same message WAITING for HOME URL

Then change it to B831 and i got message Factory mode, wait about 10 min in this mode and reset Sync

Then decided to change it in B830 from B831 and i got different message , and same thing i was resetting again Sync and wait about 10 min nothing change it also turn of car and lock it for other 5 min.

After was staying in this mode i got error from TCU and no communication until i remove fuse from BCM and reconnected and i got access to it message was the same then switch it back to default B832 and again i got same message: WAITING FOR HOME URL

No success

al this time car was removed from my for pass app and app removed from phone

P.S. Sync see modem SN

Unrelated, but just want to say kudos for the FJDS screenshot! I’ve always been unsure of what the latest available firmware is for these for those of us who have DIY’d this with just Forscan available. Now we know it looks like UP is the latest available per Ford’s own systems.

Just FYI there is a new version of Fordpass coming out this week. I know it was mentioned they are fixing some syncing issues among other things.

I have not seen this message on a TCU activation before, but maybe Ford has changed some things. The pic of the TCU label definitely defines this TCU as NA (TCU-B1). With the J series and on this would indicate a Canadian TCU.

The messages in FORScan for the TCU authorization show factory mode and provisioning correctly, and the TCU sees and communicates on the proper cell network (410 = ATT). Is shows it is in the US (310). There is something more to this than just the authorization failing.

How is the cell signal in your area where you are activating?

I noticed that virtually all of the feature reporting is turned off in the TCU for 754-03-xx. This is indicated by the 7C settings. The TCU Connection Status Alert and the User Authorization Response Alert are muted. Just for grins, try this asbuilt configuration. This will turn everything on, some things that will not be applicable, but will determine if the asbuilt is an issue.

;Block 1
;Block 2
;Block 3
;Block 5

See if this procedure helps.
FordPass Connect TCU Authorization Thru FORScan TCU-H.pdf (790.8 KB)

Hello again to all so today i received new TCU provided by warlock12118 THANK YOU !!!

Install it in my car without doing nothing i got this message:

So all what i did just change settings to from B332 to B832 and added car to my app and i got pop-up on my SYnc and accepted

and then i got status in my ForScan

after all was done in couple minutes i got access to all futures on my CAR

Now if anybody know if any other futures my be enabled just let me know Thank you

New TCU info :

Thank you to all who try to HELP me, it seems like CANADIAN version its something different then USA and its not working, as TCU for car no errors all good only not communicating with USA carrier for remote access.

i will send it back Canadian one.

And Thank you one more time to: warlock12118 who sell it to me for reasonable price and good support and fast shipping. ( your unit working perfect ).