Try to update ACM firmware and now can't get into it

First time using this site I hope I did this right if not please give me advice on what to do

Or if this question has been answered somewhere else please point me that way

You might email the Forscan guys on this. I have had this problem before and I went that route with them. They had me change a bunch of settings to do it and it worked.

Although looking at your pic I don’t see that what you’re doing is an upgrade.

Right now I’m trying to get it to do anything it won’t do nothing I tried to update the firmware and it locked up on me but I’ve emailed for a scan and I’m waiting on their reply thank you though

Download the original firmware and install that to recover the unit if necessary. First perform a module reset thru FORScan.

Where would I get the original firmware from? Because ford don’t keep a copy of it from what I understand and I have the number that was on the side of the ACM. but forscan wrote several different programs for me to try to help me and I’m going to put a screenshot of what their last message was because of the way it shut down it won’t let you click on ACM module and it just says operation stop and it says ACM has no DTC function like you click on it and nothing it just stops the forscan program.

But me and that guy connected he did his thing remotely and said he had to update his OBD link ex codes and I haven’t heard nothing else back from them so basically if I can’t get it fixed by the first of the year I’m just going to buy a whole new head unit and just replace it but I would like a radio between now and then because Bluetooth through a JBL flip 4 speaker and then I got my MTX amp and sub Bluetooth and now JBL battery crapped out so now I have no radio I kind of like a radio soon

This looks like the ACM is bricked by the attempt to update it or that FORScan is not reading or writing the function correctly. There is a new update, FORScan 2.4.9, that you should try before giving up on this. It has better message handling for the comm from the modules.

If you cannot see the module with FORScan, try a new scan and see if it shows up. You should perform a new scan any time you update firmware in a module.

Yes that is the version that I have on my laptop now and they had wrote me three special of them versions I don’t know what they did I don’t know nothing about it but they gave me three different versions of it to try to get the module to start the erasing process cuz that’s where it shuts down at is after it loads the secondary bootloader it starts erasing and then it just stops right there but like I tried to tell them it’s done erased everything while it was writing the new update something glitched and that was the end of it. But I don’t know much about the modules I know what to do how they work but I don’t know really is a complexity of them but I did the doors the ACM and then I stopped I haven’t done the acim which I’m assuming I think is connected to the ACM in some way so I don’t know if that has something to do with it or not I’m too scared to try to update it because I don’t want it to brick cuz I can’t afford to buy modules and this is my daily and my everything I think I covered everything right if not I hope you can understand what all that says but yes I do have the latest version of the beta

I totally understand where you’re at. I have a feeling the module is bricked but let me look at a few ideas.

Just a suggestion, Brian at NaviUpgrade – SYNC 3 Upgrades & Guides specializes in Focus and others. He is a good guy and is on the forum here. You might try dropping him a note.



Okay I will touch base with him and see what he thinks. And I appreciate you taking the time to stop and try to help me out

yeah I’m thinking about if this module is Bricked I’m just going to get one of them like aftermarket ones you see on eBay or Amazon that’s the whole face plate the bigger screen to like Tesla type stuff for my daughter wants a big touch screen so she can watch movies in the car while we’re riding. :roll_eyes::roll_eyes: kids​:smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.