Updating APIM Firmware (Calibration Files)

Great job @Louage and @CyanLabs.

For those that are trying to get the FORSCAN 2.4 beta, I got this DM from the Forscan forums:

Version 2.4.0 has serious issues, so we have stopped testing on it. We currently work on version 2.4.1 that will most likely be publicly available. It is recommended to wait for 2.4.1 (no exact ETA yet, though). We can provide 2.4.0 if you want to use it at your own risk (knowing it has serious problems).

Regards,
FORScan Team

It sounds like you can get 2.4 through some members, but I tried with the 2.4 software and got this result: https://photos.app.goo.gl/qXc2A1nJ8P8sxA2w5

It looks like the calibration buttons error on downloading some of the files needed.

1 Like

Hi, yes it seems the forscan downloads are failing, you can manually get the files needed from here UCDS Calibration File Download

@Louage can probably assist further but I believe you just put them in the folder it said when it errored.

As you may or may not know k don’t personally use forscan so louage is the guru for that :wink:

Oh also 2.4 can be found in the pinned post on the discord server but as per the forscan info I would also suggest waiting for a more stable version.

1 Like
  • Updated the original post with instructions on how to firmware update your OBDLink EX

  • Added stark health warning about the risk of bricking your APIM

@Fma965 @josharmour - I’ve updated the prereqs to say latest 2.4.x version rather than just 2.4, I’d advise always going to grab the latest version as I am aware Forscan regularly bug squash newer versions. Probably best not to use any older versions people link for reasons mentioned above.

2 Likes

what files do i have to download manually to update the APIM module

Anyone who can do this for me?

please contact me at my email [email protected]

Thank you!

1 Like

The files are different for each APIM model, due to the risk of bricking your module I do not recommend doing this manually. The above steps will allow you to flash your APIM to a newer version thst will allow radio logos and calm screen.

1 Like

it is known if it can already be downloaded from forscan

not sure i understand correctly but currently Forscan download function appears to be broken so it doesn’t automatically get the files.

1 Like

From where is forscan getting calibration files? UCSD or fordservice website?

Good question, not sure.

Think from fordtechsercice… Same file that @josharmour was trying to download througt forscan is available on ucsdsys but not on fordtechservice :thinking:

Today I’ve receive my Obdlink ex device, and I’ve update the firmware. As I had my car profile saved, I’ve test the apim firmware module to check if automatic downloads are available, it seems to be working for me…:thinking:

1 Like

Excellent news, thanks for the update. I wonder if those with issues are using an old version…

I’ve just tested the download capability, I didn’t update the apim firmware yet… Just the obdlink firmware… Next week I will give pics of the catastrophe… I will make the update at work, in my garage I have no were to plug the battery charger…
:blush:

Well, finally I’ve updated my apim calibration files, no issues, everything was OK. Downloading, SBL Test and Program. Before updating I made a backup of the Car Profile and the APIM asbuilt configuration. Everything is working OK, radio logos (I cannot check calm screen because I’m still on 3.3 software version). But now I have the DTC on the APIM, U2100. I tried loading the asbuilt file I previously saved but it says no changes and, although I re-write, the DTC is still there. I cannot download the ASbuilt original file from motorcraft because my sync3 is a retrofitted unit, originally my Focus has a SYNC1 Unit. If I try to download, obviously I get the message that number of blocks do not match the actual number of blocks. Also, before starting I get the message “firmware part number GB5T-1G373-AA do not match with expected GB5T-1G379-AA” . This correspond to the Sound Profile / Calibration…In any case everything seems to be working OK. Following @Louage steps everything should work… Thanks a lot to him for his help and patience :slight_smile:

5 Likes

DTC U2100 “Initial configuration not complete”

thats fixed by re-writing all the asbuilt to the unit usually

1 Like

I had this same issue and a re-write of the AsBuilt and resets didnt work straight away, but it did fix itself a week or so later.

1 Like

After second re-write the DTC has gone… Thanks a lot :blush:

1 Like

Hi all.
Is it safe update APIM firmware? Which is the forscan latest version, 2.4.0 or 2.4.1? Forscan beta version needs a extended license? I have tried put a free license but it isn’t possible.
Thanks

Hi, this is an inherently unsafe procedure as the title states. You will need to ask these questions in the Forscan forum not here.

1 Like