Voice Recognition not working on a retrofitted Sync 3

After a retrofitting upgrade from Sync 2 to Sync 3 (from a crached donor car) I have noticed that Voice Recognition is not working. When I push the voice button on the steering wheel nothing happens. I have been browsing through the Sync 3 APIM DB here at Cyanlabs but can’t find any setting which I can relate to voice recognition.
This is a non-nav Sync so it’s the general Sync voice recognition I’m looking for, not the navigation voice. But perhaps it’s the same…?
I have not made any update of the Sync 3 FW, it’s the version that the donor had (3.4). I have however loaded an as-built file reflecting my car (a Sync 3 modified version of my original Sync 2 ab).
Does anyone knows if there is a setting in the APIM that enables voice recognition or how it is controlled?

This could be a wiring issue related to the microphone. There is really no asbuilt setting controlling the voice control specifically.
Was the vehicle equipped from the factory with Sync 2?
Could you please post your Sync 2 and Sync 3 asbuilts here.

Thanks for clarifying.
I’ll upload the .ab-files as soon as I’m at my computer.
Yes, the car was originally equiped with Sync 2. It’s a 2016 Galaxy.

The microphone worked fine as long as I had Sync 2. When I pushed the button on the steering wheel with Sync 2 a female voice said, “Please say a command” and some options appeared on the Sync 2 display…
Now with Sync 3 nothing happens. No voice, no change on the screen. Other buttons on the steering wheel, like volume up and down, works however.

I read somewhere on this forum about someone who had voice recognition problems with the Nav after a Sync 3 software update and the solution seemed to be a factory reset of the APIM.
What will a factory reset do in my case? Will it for example go back to the donor cars APIM settings, or to the ones that I have added with the .ab-file, or to somrhing else?

This may be a stupid question, but do you know what packages your current APIM has installed?. If the answer is no, create and run an interrogator log against it and post back the results (redact the VIN from the file’s title and content if you care about it).

Pins for the Mic are the same for the APIM connector between Sync2 and 3. Did you upgrade from a 4" setup?

The screen sizes are the same on my old Sync 2 and the new Sync 3.
I have no idea about the APIM packages, I will try to create an interrogator log if I manage to understand how to do it. I don’t know if I have a MY20+ APIM, I don’t even understand what MY20+ means…
Manufacturing date of my Sync 3 (KB3T-14G370-MAB) is 12/29/2020 if that gives some clues.

I have attached my original and my new asbuilt-files. Note that the new one is created by myself based on the DB here on Cyanlabs.
Original_SYNC2.abt (196 Bytes)
New_SYNC3.abt (495 Bytes)

MY20 Is model year 2020…
So yeah, you have a MY20 unit that can’t be reformatted.
About the packages, all I want to check is that the unit has a proper voice package installed.

Ah, MY = Model Year. Makes sense… :laughing:

Interrogator log attached.

Thank you for the log.

What’s the origin of the Sync3 APIM?.
I read it was a donor car, but was an EU donor car?.
The log says it’s a 16GB NON-NAV APIM.
As you said before, based on the L series part number, this is a MY20/+ APIM which can’t be reformatted. Keep that in mind, it’s very important.

Also, there could be a mixture of packages on the APIM.
You have 3.4.21020 installed, which is not the latest build.
But that’s ok, you do not need the latest build to get voice commands.

What’s odd is that there are 2 packages that according to Syn3updater do not match with 3.4.21020: ENH_DAB and VOICE. They seem to be a bit older than the ones for 3.4.21020.

Is that the issue?, not sure really, since you are mentioning that pressing the button does not do anything, nothing. I mean, the screen does not show anything right?, so it’s like the button is not functioning…

So I’m not sure if this has something to do with it…
Lets wait what the other have to say.

Also, should you choose upgrading your Sync3 version to the latest stable one, all would be performed with autoinstall, which is safe to use on MY20 APIMs.

A big thanks for all help, really appreciated!
The donor car was from Norway (formally not EU but I’d guess they are included in EU anyway :slightly_smiling_face:) and I’m in Sweden.
Can you explain a little bit more about this with reformatting? What does it mean? In what situation would you like to do that? Is it the same as doing “factory reset” from the settings menu in Sync or is this only relevant to when doing stuff with Syn3Updater?

I looked through my asbuilt-files again and noticed that the 5:th parameter in 7D0-01-02 also codes for “Hardware Steering Wheel Controls (SWC)”. On Sync 2 this was a 0 which means “TPMS Enabled, SWAC Not Available” and therefore I changed it to a 4 in Sync 3 which means “Diesel Vehicle, SWAC Not Available”.
Can it be that SWC should be set to “SWAC with Volume, PTT, etc. (Variant C)”?

You have an outdated Sync voice file installed for a newer Sync version. This is an absolute problem. You need to keep the App and Voice files in sync.

5U5T-14G381-ER 847Mb Sync3 v3.4.21020 20.01.2021 (Jan 20, 2021)
5U5T-14G391-AH 1.5Gb Sync3 v3.2.19164 13.06.2019 (Jun 13, 2019)

5U5T-14G391-AN is the correct voice file for 5U5T-14G381-ER and 5U5T-14G381-ES.
5U5T-14G391-AN 1.5Gb Sync3 v3.2.20339 04.12.2020 (Dec 4, 2020)

OK, thanks!
So is the best approach to just update the voice file or should I also update Sync 3.4 to the latest stable release? And which release is that?
Do you know if other languages than English are supported in the voice file, Swedish for example? Or are there separate files for different languages?

You can update to the latest Sync 3.4.22251 thru the Syn3 Updater. It will choose the appropriate voice file by version automatically. Set the region in the Syn3 Updater for the appropriate language.

Based on your asbuilt data, the country code is 5357, or Sweden. The appropriate voice file would be xxxx-14G391-Ax.
SWS - Swedish

The files are logical groups of languages for the region.

Thank you for confirming this, I was about 75% sure this was the case since I remembered reading it somewhere many months ago, but was not really sure.

The fact he mentions the button does not do anything made me doubt…

I have now (hopefully) updated to sync 3.4.22251 but still experience the same issue that the “push to talk”-button on the steering wheel is not working. New Interrogator log attached:

If all packages are correct it feels like it must be something in the asbuilt-data…(?)

Any comments around my previous though of the 5:th parameter in:

It seems to codes for “Hardware Steering Wheel Controls (SWC)” and can be set to:
“SWAC with Volume, PTT, etc. (Variant C)”.

Can PTT be this function? (Push To Talk)

My Sync2 was set to “SWAC Not Available” and still it worked so this is a bit of a long shot.
Hopefully I will get some time tomorrow to do some tests.

Sync 3 should be set the same…

Problem solved!
I changed the “CAN Steering Wheel Controll Switches (SWC)” setting in
7D0-01-01 xx**-xxxx-xxxx from 6B to 6A, that is changing SWC from “SWFC” to “SWMT” where SWFC means “C1MCA: (With Function Buttons)” and SWMT means “C1MCA and CGEA 1.3: (Cursors and OK Button over CAN)”, and now it works.

These settings seems to be the same in both Sync2 and 3 so it is strange that 6B worked on Sync2?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.