2017 Explorer 4x4 no gear indicator in sport mode


I have a strange problem with my 2017 Explorer. I can’t put my gearbox in manual mode. S doesn’t light up on dash. When in drive, D is on when i put the lever further back D is no longer on but S isn’t either. Furthermore i don’t see gear number. It’s not a mechanical problem. I removed center console and i checked lever operations. I also checked if gearbox linkage is properly adjusted.

Funny thing is that when i put lever in S, car appears to recognize it. It is not shifting gears unless i do it with paddles. Only things wrong is lack of S indicator and no gear number shown.

Any ideas?

BR Marcin

Your talking about the gear indicator in the left IPC screen and also the mode on the bottom middle of the IPC right? Have you made any changes with Forscan? Did the error randomly appear or did you do anything to the selector like use the override button or install anything?

In SPORT mode, the gear indicators will not light up. This is simply a transmission adaptation, not manual mode. In MANUAL mode, the gear indicators will light and will indicate what gear the vehicle is in. Be aware that the transmission will still shift on it’s own if you ride the rev limiter or come to a stop.

Manual mode is not sport mode.

Sorry, you are right. I did not express myself precisely.
Some time ago when i shifted to S, car would’t change gears on it’s own (besided “safety” rules, e.g when stopping at trafic lights it automatically shifted to 1st from let’s say 6th). S indicator apeared on dash and at the same time gear number was displayed on the left (see pic). Gear number also appeared when i was in D when i manually forced gearbox to e.g. change gear to lower gear before passing (only for cuple second but it was there)

Now when i shift to S light is doesn’t come (dash is not showing any gear when i switch to S). Car is working normally, tested yesterday ( i mean only manual shifting when in S and when in D i’m able to change gear manually and after a while car takes over). Everything works fine from the machanical perspective.

Only that dash is what annoys me. It worked like mentioned above previousy. Don’t know what is going on. I don’t think this is related to forscan mods, as far as i remember this problem occured before ECU reflash but i’m not 100% sure.

I think this is a menu display option in the IPC.
What ECU flash are you referring to?

I’m rendering to this : SYNC 3.0 to 3.4 with maps from NA to EU

I have also noticed today that Teresin management system doest work either. There is no fault or check engin light.

I think your Asbuilt settings are wrong and need to be corrected. The IPC more specificlly and you need to return the asbuilt back to OEM.

I remember. I would make a backup of your IPC asbuilt settings and then load the factory IPC asbuilt settings to see if there is an issue or not with the settings. (As Bill suggests…)

Sorry, terrain management works fine. Yesterday i removed center console and i didnt secure one of the connectors. Check that a minute ago and it works fine now.

So only thing not working is that gear informatorom and S position confirmation.

I would still check your asbuilt

Have you taken anything apart like behind the glovebox, IPC, or console before? The wiring for the up/down commands that go to the IPC could have been disturbed. In F-150’s, the wiring for the Manual Mode goes clear across the dash to the passenger side and back to the console.

Did you ever load new firmware into the IPC, referring to the other thread?

Yes, the dash was off but long time ago. I dont think thats the reason. You mentioned IPC module. And no, i didnt do anything except that thread with Sync upgrade.

Can it be this setting in IPC? I don’t have a cable righ now so i need to order again to check it.

Should GS be set to “SST”?

I would try that, but it might only apply to the “SST” version vehicles.

Courious as to what it is set to right now. That would effect it.

@cinek, Were you able to make any progress or resolve the issue?

@F150Chief yup. Half an hour ago i did connect and i changed SST in IPC (not As build, the other one withoud codes but with descriptions). SST stands for Selecs Shift Tech. It was “disable” and i changed it to “enable”. Went for test a drive and now it works as it should be. Maybe it was changed during reflash. I know i did not change it on my own.

Anyway, not it works :slight_smile:

Thanks for the update, glad it’s resolved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.