2018 Ford Edge Titanium 3.4 issues

Strange, never seen that error myself before. It means “VER_SETTING_VER_INFO_ERROR”.

I once flashed a 4" version to my 8" system before as well, however in my case doing a downgrade to a 8" 3.3 build fixed it. From there I was able to reformat to the latest 8" 3.4 build. So there should be no issue with downgrading off a 4" build to an 8" build based off my experience.

Perhaps try loading this file next (not quite sure exactly which version of SYNC this is but it is older than your current build and newer than the one @F150Chief linked so it may work to help move you off the current one):


Item1 = 5U5T-14G381-FB_1581452370000.TAR.GZ
Open1 = SyncMyRide\5U5T-14G381-FB_1581452370000.TAR.GZ
Options = AutoInstall


At this point it’s just try to get anything loaded successfully. This may ‘heal’ the unit to where it will accept a downgrade or reformat. I don’t know of anything else to try, I’ve never seen this issue, and it could possibly be a hardware issue as far as we know.

Any suggestions will help…

5U5T-14G381-FB 408Mb Sync3 v3.4.20022 22.01.2020


Yes, the main objective is just to get you off the version that was given to you. Once you are off that build, the downgrade and reformat should work as expected (you clearly have enough space on the APIM).

For reference, I’m pretty sure that the 4" version I once installed on my system was 3.4.20196 and it let me downgrade to 3.3 off of that. However, my APIM is a 32GB nav model (not that it should matter).

I will give that a try tomorrow and see what goes. The update that screwed this up went smooth too, no issues until it rebooted lol. Im hoping something works, if not I truly appreciate all the help. I’m gonna donate some cash over as well after I get this all said and done!

1 Like

Tried no luck. Ordering a new APiM . Appreciate all the help!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.