3.4.22251 Question

I have been reading through the various forums related to this but decided to start new to keep it separate. Recently updated a pre My20 (validated via interrogator prior to install) and noticed afterward that I didn’t have SXM logos so started searching forums to determine why. After digging through, I have a few additional questions now. I have ran a master reset 3 times so far.

  • I ran interrogator to determine the space on rwdata which looks good, however it does not list my model of APIM
  • Ford’s site shows my VIN is listing 3.0.20204 as the update available, do I go ahead and downgrade to that? Wasn’t sure if this is causing the interrogator to have this result
  • For logos, do I go ahead and try to re-install gracenotes? About Sync screen shows version (NA-0020) installed

SYNC Region: NA

Navigation Variant: Non Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.0.18093

New SYNC Version: 3.4.22251

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version:

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

Branch: Stable
Operating System: Microsoft Windows 11 Home (2009)

Version: 3.0.18093
Region: NA
Navigation: False
Install Mode: Auto-Detect (reformat)
Install Mode Overridden: False
My20 Protection Enabled: Disabled / Not MY20

Mode: Drive
Model: PNY USB 2.0 FD USB Device
Size: 14.4GB
FileSystem: FAT32
Partition Type: MBR


; CyanLabs Syn3Updater Stable - reformat  Mode - Sync 3.4.22251 NA

Item1 = REFORMAT TOOL  - 1u5t-14g386-cb.tar.gz
Open1 = SyncMyRide\1u5t-14g386-cb.tar.gz
Options = AutoInstall

1u5t-14g386-cb.tar.gz (8.5MB)
5U5T-14G391-CS_1660783942000.TAR.GZ (385.5MB)
4U5T-14G423-CC_1615429225000.TAR.GZ (564.2MB)
NU5T-14G381-AB_1665525837000.TAR.GZ (869.8MB)

[4/30/2023 12:08:40 PM] Selected Region: NA - Release: Sync 3.4.22251 - Map Version: Non Nav APIM 
[4/30/2023 12:08:40 PM] Install Mode: Auto-Detect (reformat) Forced: False 
[4/30/2023 12:08:40 PM] MY20 Protection: Disabled / Not MY20 
[4/30/2023 12:08:40 PM] Formatting USB drive
[4/30/2023 12:08:40 PM] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
[4/30/2023 12:08:59 PM] Checking Existing File: 1u5t-14g386-cb.tar.gz 
[4/30/2023 12:08:59 PM] Downloading: 1u5t-14g386-cb.tar.gz
[4/30/2023 12:09:01 PM] Validating: 1u5t-14g386-cb.tar.gz 
[4/30/2023 12:09:01 PM] Downloaded: 1u5t-14g386-cb.tar.gz 
[4/30/2023 12:09:01 PM] Checking Existing File: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[4/30/2023 12:09:01 PM] Downloading: 5U5T-14G391-CS_1660783942000.TAR.GZ
[4/30/2023 12:09:26 PM] Validating: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[4/30/2023 12:09:27 PM] Downloaded: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[4/30/2023 12:09:27 PM] Checking Existing File: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[4/30/2023 12:09:27 PM] Downloading: 4U5T-14G423-CC_1615429225000.TAR.GZ
[4/30/2023 12:09:50 PM] Validating: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[4/30/2023 12:09:52 PM] Downloaded: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[4/30/2023 12:09:52 PM] Checking Existing File: NU5T-14G381-AB_1665525837000.TAR.GZ 
[4/30/2023 12:09:52 PM] Downloading: NU5T-14G381-AB_1665525837000.TAR.GZ
[4/30/2023 12:10:53 PM] Validating: NU5T-14G381-AB_1665525837000.TAR.GZ 
[4/30/2023 12:10:56 PM] Downloaded: NU5T-14G381-AB_1665525837000.TAR.GZ 
[4/30/2023 12:10:56 PM] Preparing USB drive
[4/30/2023 12:10:56 PM] Checking Existing File: 1u5t-14g386-cb.tar.gz 
[4/30/2023 12:10:56 PM] Copying: 1u5t-14g386-cb.tar.gz 
[4/30/2023 12:10:58 PM] Validating: 1u5t-14g386-cb.tar.gz 
[4/30/2023 12:10:58 PM] Copied: 1u5t-14g386-cb.tar.gz 
[4/30/2023 12:10:58 PM] Checking Existing File: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[4/30/2023 12:10:58 PM] Copying: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[4/30/2023 12:11:43 PM] Validating: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[4/30/2023 12:12:08 PM] Copied: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[4/30/2023 12:12:08 PM] Checking Existing File: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[4/30/2023 12:12:08 PM] Copying: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[4/30/2023 12:13:14 PM] Validating: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[4/30/2023 12:13:48 PM] Copied: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[4/30/2023 12:13:48 PM] Checking Existing File: NU5T-14G381-AB_1665525837000.TAR.GZ 
[4/30/2023 12:13:48 PM] Copying: NU5T-14G381-AB_1665525837000.TAR.GZ 
[4/30/2023 12:15:32 PM] Validating: NU5T-14G381-AB_1665525837000.TAR.GZ 
[4/30/2023 12:15:35 PM] Copied: NU5T-14G381-AB_1665525837000.TAR.GZ 
[4/30/2023 12:15:35 PM] Generating reformat.lst
[4/30/2023 12:15:35 PM] Generating autoinstall.lst

Interrogator Log After Upgrade
Version NU5T-14G381-AB
APIM Model: Unknown
APIM Type: Non-Navigation 
APIM Size: 8GB 
APIM Free Space: 1.7G 
5/2/2023 8:55:33 PM +00:00

Partition Type = Free / Total
/fs/Nuance/ = 3.2M / 465M
/fs/Nuance/grace = 5.8M / 775M
/fs/rwdata/ = 1.0G / 1.2G
/fs/rwdata/quip/ = 35M / 35M
/fs/rwdata/quip/ = 90M / 90M
/fs/mp/ = 84M / 1.4G
/fs/images/ = 1.7G / 3.0G

Installed Packages

APIM AsBuilt

What is the model and year of your car and could you please confirm the exact update now showing in your ‘about’ section as you appear to have done everything correctly and it should show 3.4, build 22251…NA 2.21 (if maps) as you are aware.
If so, does everything appear to be working ok including voice, radio, phone pairing etc?

Just for info I have recently done the same Cyanlabs update for my 2017 Escape and my Gracenotes version now shows (GL-0011). I am in Australia.

Have you master reset ?

Was it read correctly before upgrading?.

You can forget about Ford, since you are way passed Ford’s upgrade path and won’t be able to return to it. You can’t downgrade to 3.0.

Not required. About logos, wait a few days to see if those start populating.
From what I recall, logos are always “a thing” for NA users, I’m sure others will help you out.

1 Like

Thanks for the reply. This is on a 2019 Expedition Max XLT. So far, everything else does appear to be working correctly but I haven’t used it all that much yet. Below is a pictures of the current about screen.

I have master reset a few times with the same result. I have also sent the Sirius signal 3 or 4 times as well. Before upgrading, i only used the interrogator tool to validate it wasnt a My20 version and then overwrote the stick, so I dont know what it showed before. For downgrading, would that potentially bring back my sxm logos? I wouldnt go back to 3.0, but possibly a differnt version of 3.4 or the last 3.3. Also this is a non nav and i updated with non nav selected.

I wouldn’t worry about it if everything else is fine but if you really want Sirius you could try going back to version 3.4. 21265 as that is the most stable by all reports.
After the advised master reset upon uploading you may have to link sirius again as you do with your phone etc.
Please keep us updated.

I have a new issue that has cropped up. My wife’s phone wouldn’t connect via usb cable for carplay so i moved it to the other usb port and it connected. I made that phone the primary but now my phone won’t connect to either port (it did before). I have tried another cable to no avail. For downgrading options, is there any risk to having that fail and bricking the unit? What is the correct process of creating the downgrade stick to 3.4.21265?

Version: 3.4.22251
Region: NA
Navigation: False
Install Mode: Auto-Detect (autoinstall)
Install Mode Overridden: False
My20 Protection Enabled: Auto-Detect

Mode: Drive
Model: PNY USB 2.0 FD USB Device
Size: 14.4GB
FileSystem: exFAT
Partition Type: MBR

; CyanLabs Syn3Updater Stable - Autoinstall Mode - Sync 3.4.21265 NA

Item1 = GRACENOTES - 4U5T-14G423-CC_1615429225000.TAR.GZ
Open1 = SyncMyRide\4U5T-14G423-CC_1615429225000.TAR.GZ
Item2 = VOICE - 5U5T-14G391-CP_1626959995000.TAR.GZ
Open2 = SyncMyRide\5U5T-14G391-CP_1626959995000.TAR.GZ
Item3 = APPS - 5U5T-14G381-EU_1634769242000.TAR.GZ
Open3 = SyncMyRide\5U5T-14G381-EU_1634769242000.TAR.GZ
Options = AutoInstall

4U5T-14G423-CC_1615429225000.TAR.GZ (564.2MB)
5U5T-14G391-CP_1626959995000.TAR.GZ (385.4MB)
5U5T-14G381-EU_1634769242000.TAR.GZ (847.2MB)

[5/9/2023 12:22:51 PM] Selected Region: NA - Release: Sync 3.4.21265 - Map Version: Non Nav APIM
[5/9/2023 12:22:51 PM] Install Mode: Auto-Detect (autoinstall) Forced: False
[5/9/2023 12:22:51 PM] MY20 Protection: Auto-Detect
[5/9/2023 12:22:51 PM] Formatting USB drive
[5/9/2023 12:22:51 PM] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
[5/9/2023 12:23:01 PM] Checking Existing File: 4U5T-14G423-CC_1615429225000.TAR.GZ
[5/9/2023 12:23:01 PM] Downloading: 4U5T-14G423-CC_1615429225000.TAR.GZ
[5/9/2023 12:23:20 PM] Validating: 4U5T-14G423-CC_1615429225000.TAR.GZ
[5/9/2023 12:23:24 PM] Downloaded: 4U5T-14G423-CC_1615429225000.TAR.GZ
[5/9/2023 12:23:24 PM] Checking Existing File: 5U5T-14G391-CP_1626959995000.TAR.GZ
[5/9/2023 12:23:24 PM] Downloading: 5U5T-14G391-CP_1626959995000.TAR.GZ
[5/9/2023 12:23:40 PM] Validating: 5U5T-14G391-CP_1626959995000.TAR.GZ
[5/9/2023 12:23:42 PM] Downloaded: 5U5T-14G391-CP_1626959995000.TAR.GZ
[5/9/2023 12:23:42 PM] Checking Existing File: 5U5T-14G381-EU_1634769242000.TAR.GZ
[5/9/2023 12:23:42 PM] Downloading: 5U5T-14G381-EU_1634769242000.TAR.GZ
[5/9/2023 12:24:19 PM] Validating: 5U5T-14G381-EU_1634769242000.TAR.GZ
[5/9/2023 12:24:25 PM] Downloaded: 5U5T-14G381-EU_1634769242000.TAR.GZ
[5/9/2023 12:24:25 PM] Preparing USB drive
[5/9/2023 12:24:25 PM] Checking Existing File: 4U5T-14G423-CC_1615429225000.TAR.GZ
[5/9/2023 12:24:25 PM] Copying: 4U5T-14G423-CC_1615429225000.TAR.GZ
[5/9/2023 12:25:32 PM] Validating: 4U5T-14G423-CC_1615429225000.TAR.GZ
[5/9/2023 12:25:54 PM] Copied: 4U5T-14G423-CC_1615429225000.TAR.GZ
[5/9/2023 12:25:54 PM] Checking Existing File: 5U5T-14G391-CP_1626959995000.TAR.GZ
[5/9/2023 12:25:54 PM] Copying: 5U5T-14G391-CP_1626959995000.TAR.GZ
[5/9/2023 12:26:40 PM] Validating: 5U5T-14G391-CP_1626959995000.TAR.GZ
[5/9/2023 12:27:04 PM] Copied: 5U5T-14G391-CP_1626959995000.TAR.GZ
[5/9/2023 12:27:04 PM] Checking Existing File: 5U5T-14G381-EU_1634769242000.TAR.GZ
[5/9/2023 12:27:04 PM] Copying: 5U5T-14G381-EU_1634769242000.TAR.GZ
[5/9/2023 12:28:43 PM] Validating: 5U5T-14G381-EU_1634769242000.TAR.GZ
[5/9/2023 12:29:24 PM] Copied: 5U5T-14G381-EU_1634769242000.TAR.GZ
[5/9/2023 12:29:24 PM] Generating Autoinstall.lst

I did the download to 22251 recently and both my phones connected but by bluetooth, not carplay.
From your log it appears that you have already gone back to version 21265 successfully from 22251.
Have you done a master reset and tried connecting your phones again?

I haven’t applied the downgrade yet, just posted the config of the usb to make sure that is how downgrades are done. Can someone confirm that this is the correct method and I just update it like i did originally? Is there any chance of things going awry or is this generally pretty safe to do?

That looks ok but just for info a new update has just been released version 3.4.23088, maps 2.2 replacing 22251 and the older maps.
There was mention in the details of a sirius update so it’s possible that may solve your problem.
I updated today from 22251 with no issues so far.

Thanks for the reply. I tried to create the update USB, however it wouldn’t work when inserting it into the USB hub. Tried both ports with no luck. I went back and tried my wife’s iphone, however it wouldnt charge/connect to carplay anymore. I did a master reset and noticed the “USB error - bad connector or cable” message on restart. I have searched around and it seems like the USB hub needs to be updated to support the newer versions of sync. The odd thing is that it worked for a while before it completely stopped. I was able to run the interrogator tool as well but now nothing works. Any ideas?

The USB hub only needs to be upgraded if it was a 2016 part and just for Carplay. Everything else is still functional. If you don’t get the telltale ‘USB hubs not supported’ message on startup, this likely is not applicable to you.

You can try pulling the USB hub and reseating the connectors behind it and see if it helps. Next thing beyond that would be trying a new one.

It’s a 2019 so doesn’t sound like that’s the issue. I also tried the USB plugs in the back but those don’t work either. Feels like a compatibility issue with 22251 but not sure. I will try to disconnect reconnect but since it’s been fine until the upgrade, I doubt that is the issue. Any other ideas to get the update to apply?

Hey, do not take this the wrong way, but you asking the same question over and over won’t change the answer. As Vchat20 said, this is not related to 3.4.

Then you misunderstood. Even if the hub was not fully compatible and a warning appeared on screen saying so (“usb hub not supported, please remove” or something like that), you would still be able to connect a pendrive with MP3s and also connect phones. Android Auto should also work, but Car Play would not (but it would charge).

So, check the connections, reseat them to be sure and try again. Connect things to the USB port once the engine is running, we are also assuming your battery is ok and you do not have weird electrical issues.

If that fails, get a new hub and replace it. Things work fine until they don’t.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.