3G to 4G TCU upgrade 2016 MKZ 2.0 w sync 3.4

Needing help with the TCU upgrade on my 2016 MKZ 2.0. Bought a used 4g TCU (JL3T - 14G087 - CK) alongside the cheap antenna from amazon and installed it. Went to forscan and let it create a new profile and it picked up the new TCU. I performed a hard reset of the TCU followed by sync 3.4 reset. I then performed the steps in Ford’s service document to reset the car connection with my phone (valet mode on/off while cycling ignition on/off). I reinstalled lincoln way and added my vehicle back. The app however does not provide any prompts to activate the vehicle and i just have a blank homescreen where the start/stop buttons usually are. Is there anything i am missing?

Picture for reference…

Update: Drove around the block and it updated the PIDs. I was then able to connect to the lincoln way app and it updated my vehicle mileage, oil life etc but i am not able to remote start/stop as of yet. Tried a few times and it failed so i will give it a few hours and try again when i awake.

Log completely out of the app and restart the phone, then log back into the app and see if the features begin to work.

i had contacted lincoln way tech support and we were able to start from scratch and get to the same point i got and could not get it to work. He put in a ticket and escallated the issue with their engineers. It has been 2 weeks and i am yet to hear back. In the mean time, i deleted the car from my app, reinstalled it, did all the usuals again (sync reset, reset TCU in forscan). Now i am not even able to authorize the vehicle in the app. The APIM sees the TCU, country identity is 310, signal in the 150 range, network identity of 410 as well as authorized mode in forscan. firmware version for TCU is the latest available for the J type units.

Can you post your TCU asbuilt? Is remote start factory equipped on your vehicle? Is it displayed in the IPC menu?

Yes it is equipped with factory remote start. Works on the fob, also worked when 3G modems were still active. The service guy said the TCU was communicating with their servers and perharps some sort of request timing out when authorizing, he was not sure. Also tried steps in the ford service bulletin after TCU upgrade (valet mode on/off) and it did not work.

1 Like

You should have 754-01-01 B132 0000 0040 for the first line. The MKZ is CGEA 1.3. Once you make this change you will need to set the TCU to “Factory Mode” and then reauthorize the TCU to reset the info on the Ford servers.

Follow the “Authorize the TCU” section in this doc…
APIM & TCU Files and Programming 20220108.pdf (511.8 KB)

i am pretty certain i tried that last week alongside changing it to B100 XXXX. I followed the document for factory mode and it never went back to factory mode, stayed authorized. I even disconnected the harness to the unit and let it sit a while to see if it will reset. I will try again tomorrow morning and get back on how it went.

Update: I reset the APIM again but this time by holding the track forward and radio power tactile buttoms simultaneously for about 10 seconds. The screen shutoff then back on and the ambient light was off and so was my phone disconnected. I downloaded the lincolnway app again and was able to activate the vehicle in less than minute. All remote functions work and i could read tire pressure etc. Will keep an eye out through the week to make sure all is still good. Thank you for the help!

i tried the steps in the pdf as you recommended. I was able to get all the way to the activation page in the app but when i clicked to activate, i get an error after about 2 mins saying they were unable to complete my request to change authorization rights on the MKZ. Something else i noticed was when i reset the APIM, one thing that does not reset is the ambient light which makes me think maybe doing the master reset from the screen is not doing a complete reset?

1 Like

Your Ambient light is controlled from your BCM. Resetting the APIM will not shut off the Ambient light.

Correct but the control for the ambient lights is on the screen and when you successfully reset the APIM, it will reset that too.

The app won’t update this morning. Still showing vehicle started from last night. logged out/uninstalled app- turned on/off phone - reinstalled app/logged in and still not updating speedo, range etc. TPMS values disappeared too. Scheduled start did not work this morning either. Any suggestions?

When you perform a Master Reset, all BT devices are erased and your phone should unpair and you will need to add it back to Sync. If this does not happen, you have not done a master reset.

Keep in mind that the app does not update unless there is an update from the vehicle. In most cases the vehicle needs to be running to update the Ford servers. Tire pressure, etc., does not update unless you drive the vehicle for a few miles.

i drove it to work this morning (over 20 miles) and once there, i checked and tried refreshing the app for updated status and it did not work. Still showed vehicle was started from yesterday. Did not get any error message from the failed schedule start this morning. TCU needs reset maybe?

You might try that along with another master reset of the APIM. Do the TCU first.

Ended up reseting both TCU and APIM, then doing the authorization again. Worked on first try and i had full function both on phone and watch. As soon as i drove a couple of miles and stopped, it won’t update vehicle page and remote functions won’t work once again. Hooked up to the car and disconnected bluetooth and added it back. PID was reading as expected and then i tried to first refresh the vehicle page and later use remote function. Both times i tried, the Network ID and Country ID went to 0 and none of the prompts worked.

In the photos it shows “KEY OFF”. You must have the vehicle running for the TCU to function fully and talk with the other components. The TCU can operate with the key off, but will not populate new info.

You have a 4g TCU (JL3T - 14G087 - CK). Have you updated the firmware? You should update to the latest firmware -CT.

The fact that it all worked and then quit working shows either a firmware incompatibility or authorization issue with the Ford servers.

I only turned the vehicle off to save battery as I was not plugged in. When I sent the commands, the vehicle was running. I had checked the firmware version when I upgraded and it looked to be up to date.

1 Like

I talked to a lincoln way tech rep to find out what they were seeing on their end. Apparently when i send remote commands, it results in a downstream module error. She’s not sure what that means and what troubleshooting is required.

The author of the post linked seems to have had similar issues that even the dealership did not resolve.


So the tech did not realize that this is not a Ford authorized modification for the 2016 MKX?

Just a thought, but maybe if you used an HJ5T modem it would work. That is what is authorized as a 3G replacement for 4G.

Do you have any DTC’s active on the vehicle? Anything related to the BCM or low battery voltage or charge? This will cause the remote start to not be available.

1 Like