Always SIGN_ERR01 on USB insert on Sync 3.2

What is your SYNC Region? NA

Do you have Navigation? Yes

What region is your SYNC APIM? NA

What was your old SYNC Version? 3.2 b.18004

What is your new SYNC Version? -

Do you have a error message, if so what is it? SIGN_ERR01

How did you update, Ford Website / CyanLabs Website / Syn3 Updater?
I have tried Ford Website and the Syn3 Updater. Always with the same result.


If you answered Syn3 Updater above;

  • What version of Syn3 Updater did you use? 2.10.3.0

  • Have you read the documentation at Syn3 Updater Documentation - CyanLabs ? Yes

  • Please paste your log output or provide the URL to your log file below
    (Log files can be found on the root of your USB drive or in %localappdata%\CyanLabs\Syn3Updater\Logs)


CYANLABS - SYN3 UPDATER - V2.10.3.0
Branch: Stable
Operating System: Microsoft Windows 10 Pro (2004)

PREVIOUS CONFIGURATION
Version: 3.2.18004
Region: NA
Navigation: True
Install Mode: Auto-Detect (autoinstall)
Install Mode Overridden: False
My20 Protection Enabled: Auto-Detect

DESTINATION DETAILS
Mode: Drive
Model: Generic USB Flash Disk USB Device
FileSystem: FAT32
Partition Type: MBR

AUTOINSTALL.LST
; CyanLabs Syn3Updater 2.10.3.0 Stable - Autoinstall Mode - Sync 3.4.19101 NA

[SYNCGen3.0_ALL_PRODUCT]
Item1 = GRACENOTES - 4U5T-14G423-CA_123766.tar.gz
Open1 = SyncMyRide\4U5T-14G423-CA_123766.tar.gz
Item2 = APPS - 5U5T-14G381-AP_1555085337000.TAR.GZ
Open2 = SyncMyRide\5U5T-14G381-AP_1555085337000.TAR.GZ
Item3 = VOICE - 5U5T-14G391-CL_1580862907000.TAR.GZ
Open3 = SyncMyRide\5U5T-14G391-CL_1580862907000.TAR.GZ
Options = AutoInstall


FILES (3)
4U5T-14G423-CA_123766.tar.gz (724.2MB)
5U5T-14G381-AP_1555085337000.TAR.GZ (891.2MB)
5U5T-14G391-CL_1580862907000.TAR.GZ (385.4MB)

LOG
[12/09/2021 14:03:35] Selected Region: NA - Release: Sync 3.4.19101 - Map Version: Keep Existing Maps 
[12/09/2021 14:03:35] Install Mode: Auto-Detect (autoinstall) Forced: False 
[12/09/2021 14:03:35] MY20 Protection: Auto-Detect 
[12/09/2021 14:03:35] Formatting USB drive
[12/09/2021 14:03:35] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
[12/09/2021 14:03:43] Checking Existing File: 4U5T-14G423-CA_123766.tar.gz 
[12/09/2021 14:03:45] Validated: 4U5T-14G423-CA_123766.tar.gz (Skipping Download) 
[12/09/2021 14:03:45] Checking Existing File: 5U5T-14G381-AP_1555085337000.TAR.GZ 
[12/09/2021 14:03:54] Validated: 5U5T-14G381-AP_1555085337000.TAR.GZ (Skipping Download) 
[12/09/2021 14:03:54] Checking Existing File: 5U5T-14G391-CL_1580862907000.TAR.GZ 
[12/09/2021 14:03:58] Validated: 5U5T-14G391-CL_1580862907000.TAR.GZ (Skipping Download) 
[12/09/2021 14:03:58] Preparing USB drive
[12/09/2021 14:03:58] Checking Existing File: 4U5T-14G423-CA_123766.tar.gz 
[12/09/2021 14:03:58] Copying: 4U5T-14G423-CA_123766.tar.gz 
[12/09/2021 14:06:44] Validating: 4U5T-14G423-CA_123766.tar.gz 
[12/09/2021 14:06:46] Copied: 4U5T-14G423-CA_123766.tar.gz 
[12/09/2021 14:06:46] Checking Existing File: 5U5T-14G381-AP_1555085337000.TAR.GZ 
[12/09/2021 14:06:46] Copying: 5U5T-14G381-AP_1555085337000.TAR.GZ 
[12/09/2021 14:10:10] Validating: 5U5T-14G381-AP_1555085337000.TAR.GZ 
[12/09/2021 14:10:12] Copied: 5U5T-14G381-AP_1555085337000.TAR.GZ 
[12/09/2021 14:10:12] Checking Existing File: 5U5T-14G391-CL_1580862907000.TAR.GZ 
[12/09/2021 14:10:12] Copying: 5U5T-14G391-CL_1580862907000.TAR.GZ 
[12/09/2021 14:11:43] Validating: 5U5T-14G391-CL_1580862907000.TAR.GZ 
[12/09/2021 14:11:44] Copied: 5U5T-14G391-CL_1580862907000.TAR.GZ 
[12/09/2021 14:11:44] Generating Autoinstall.lst
[12/09/2021 14:11:44] ALL FILES DOWNLOADED AND COPIED TO THE USB DRIVE SUCCESSFULLY! 


Please provide any further details below

I think that the certificate check could fail due to a wrong date on the Sync 3. When I tried updating it with the WiFi updater in the car, the date it was giving me was: “Last Checked for Updated 01-01-2000 12:10:29”. I seem not to be able to find how to set it to 2021.
I have tried all the versions available on the Syn3 Updater, all gave me the same error. I also tried formatting the USB stick on a different Windows 10 and 7 machines, with no success. 5 different USB sticks (USB2 and USB3) were also tested… Nothing seems to fix my problem.
Maybe previous owner changed something with Forscan (I have one too if needed), or maybe he flashed it in a bad way before?

Can you please help me out? :slight_smile: Maybe there is a simple fix that do not know about yet.

Sounds like you don’t have sync 3 post a photo of your “about” page

Here it is :slight_smile:

Ok that’s sync 3 not sure then tbh

I know that someone was changing it to support EU frequencies - its imported from the US originally. I swapped back the ACM 727-04-01 to North America (0) and the Country Code to 5553 (US) when it didn’t want to update, but I had no luck. Is it possible that some other options are forbidding me from updating?

Run the APIM Interrogator Tool in the troubleshooting page of Syn3 Updater and post the results. You are missing the MAC addresses for wifi and hotspot, and I suspect other things.

Go to Index - FordServiceInfo.Com (motorcraftservice.com) and enter your VIN to get the OEM asbuilt for your vehicle. Download the .ab file. Put that in the AsBuilt folder in FORScan. You can restore the APIM with that info to factory specs.

Thanks for the suggestions.
The APIM Interrogator Tool turns out to cause exactly the same error as the update USB - the SIGN_ERR01.
I did also reset the ACM and APIM AsBuilt to original manufacture AB file, but it changed nothing.

I am wondering if I should try to update the APIM firmware by using the new 2.4.3 Forscan version. What do you guys think? Could it fix the missing MAC adresses and the SYNC update problem?

Use FORScan to connect to the APIM and save the asbuilt file. Post it here, the ,abt file.
Also, go to the Configuration tab or Firmware tab and post the info for the APIM:
Part Number
Strategy
Configuration

Firmware will have no affect on the Sign error…not that I am aware of.

Did you use the -AC version of the Interrogator Tool file? And you mentioned the date being wrong, is it correct date and time on the Sync unit? Regardless of the latest update check message.

My APIM abt file generated by Forscan:

;Block 1
7D0G1G16A2A01020474
7D0G1G2020802008A70
;Block 2
7D0G2G155530602C04A
7D0G2G202009000006D
7D0G2G3400521
;Block 3
7D0G3G10000010100DD
;Block 4
7D0G4G10000090006EB
7D0G4G20001DE
;Block 5
7D0G5G11856195A29E7
7D0G5G2D6B4
;Block 6
7D0G6G1805E
;Block 7
7D0G7G1100033000022
7D0G7G200000B650050
7D0G7G3005656750002
7D0G7G44C2E
;Block 8
7D0G8G1002000000000
7D0G8G20000000010F1
;Block 9
7D0G9G10000000000E1
7D0G9G20000000000E2
7D0G9G30000000000E3
7D0G9G40000000000E4

My APIM Module firmware update tab in Forscan:

Time and date
I have a feeling that the wrong date on the SYNC3 unit could be culprit of failing the certificate verification of the update files. The SYNC3 could think that the certs are expired for example. In other projects not related to cars I encountered similar problems a few times.
I can’t know for sure what date I have on the SYNC because in the clock menu, I can only change the time and not the date. I did not think that this is normal, but I am a very fresh SYNC user.


The only indicator that I have a wrong date that I find is in the Automatic Update menu where after failed update I get now “Last Checked for Updated 01-13-2014 15:48:20” message.

Also, when I turn on and off the ignition, the clock changes and I think that it should stay the same, right? - Sync3 strange clock behavior when turning on/off ignition - YouTube
What is also interesting - when the ignition is off, if I change the clock on the SYNC3 unit, it resets to what it was after a few seconds.
Maybe the RTC is broken on the board?

Interrogator Tool file
Its created with the Syn3 Updated 2.10.4.0 and the file version is GB5T-14G386-AD_1606255780000 and I also tried GB5T-14G386-AC from https://cyanlabs.net/fhub/sw-db/.

A few observations:
The firmware is up to date for your APIM, there should be no issue there. The APIM is a 2018 model (3U5T). Software version is Sync 3.2, probably original from the factory.

The clock seems not to be locked to GPS. The clock issue is either due to no GPS lock or APIM settings.
The asbuilt coding is correct for the clock for your vehicle.
7D0-01-01 xx** xxxx xxxx is 2A.
You have NAV, does it work properly and does NAV have GPS lock? Is there a small red circle on the NAV screen?
This is how the clock works: Ford Master Clock.pdf (298.8 KB)
You have Type B, where the BCM is the Clock Master. Resetting the APIM and BCM to Factory Asbuilt might solve the issue, as long as you have GPS lock.

Another issue noted is the lack of Hotspot MAC address on the Sync screen shown above. This indicates that the TCU (Telematics Control Unit) hotspot has been disabled. This looks to be an issue, but would not upset the clock as the time is derived from GPS, not cellular phone networks.

What country are you in now?
Be aware that the TCU would need to be changed to an EU model to make that work. I am assuming you are in EU…
Also, the ACM would need to be changed for DAB if desired.

So it seems that there could be a couple of issues, lets hope that there is only 1 cause to all of it :slight_smile:

The TCU would need to be changed and I am already browsing for the TCU-E1 and E2, but so far with no luck. Thank you for pointing it out. If we are sure that the Clock Master is not set by the TCU, that is good news since it will not work in Europe (Poland) where the car is right now. Maybe the missing MAC addresses will show up when I will switch the TCU to the Europe version?

The Master Clock Master is set at 7D0-01-01 xx** xxxx xxxx to 2A, that I checked before and it doesn’t seem to be the problem. Just in case, I also swapped this value to 22, 32 and 3A, but even with resets, it did not help.

Now, going back to the thing that seems to be the main problem for now: I have no GPS lock. I do have GPS reception, the APIM sees the satellites, but this is it. Did you guys come across similar problem?
As you can see, it knows or knew where it was:


And it can see the satellites:

But here I get nothing:

And when I press the ''Reset Clock To GPS Time", I get:

Unless you have GPS lock the clock will have issues, as the time is set from the GPS.

Is that the current location or just the last it remembers…?

Read thru this thread, it might be helpful…pay attention to the “Location Diagnostics” screen discussion.
No GPS signal after updating from 3.2.18124 to 3.4.21098 - Ford / Sync 3 - CyanLabs Official Community

I can’t say for sure, because I do not have EU maps on it and without zooming in, I can only say that it is accurate with ~50km accuracy.

I will read this thread very thoroughly. Thanks!

Maybe there is an APIM AsBuilt that I could change which will disable the NAV and the option to set the date would became available on the Clock menu like in some SYNC3 models?
I am gonna check today the 7D0-01-02 x*xx xxxx xxxx and 7D0-01-02 xx*x xxxx xxxx.

Those settings are independent of each other. NON-NAV APIM’s set the clock by GPS also.

That approach doesn’t help me then. Too bad :confused:

I decided to buy new European APIM: JK2T-14G371-FCC with 64GB and NAV to see if the problem is linked to the current APIM or something else inside the car. I will post my results here as soon as I get it :slight_smile:

1 Like

So, I did swap the APIM to JK2T-14G371-FCC (SPC5644CVLU8 chip) with and it worked fine, but it seemed quite slower than my original APIM with SPC5644CVLU1 chip.

The new JK2T-14G371-FCC managed to update to 3.4 even when the date in the Master Clock was not updated yet to the current date. The GPS fix was very fast and there was no problems whatsoever (apart from the fact that even on 3.4 it seemed slower than the APIM I have before).

So it seems that my original APIM is broken is some way, either hardware or software. After the Master Clock was set correctly with JK2T-14G371-FCC, I swapped back my APIM and tried to run the update and the APIM Interrogator Tool and the SIGN_ERR01 was still present in both cases.

If you have any other ideas, please let me know, I would love to fix this issue.

If I understand correctly, it is not a good idea to flash with the 4U5T-14G371-CJB calibration level that Forscan proposes?

The calibrations that FORScan presents actually come from Ford systems, like IDS and FRDS. Those are the recommended firmware versions for the hardware as outlined by Ford.

You should be able to take the JK2T-14G371-FCC APIM up the this:
3.2/3.3 APIM Navigation Unit Firmware (Production Release 2018)
GB5T-14G376-AA
1U5T-14G374-DA
1U5T-14G375-DA
GB5T-14G379-AA
JB5T-14G379-BA

Ok, now I know everything, or at least enough to finish this topic for now.

The car was equipped with 3U5T-14G371-CDC (US 32GB APIM with SPC5644CVLU1 chip, manufactured 04/2018). Every time I tried to update it or to run the Interrogator Tool, it displayed SIGN_ERR01 error.

I bought a 4U5T-14G371-GJA (EU 64GB APIM with SPC5644CVLU1 chip, manufactured 08/2019), placed the ‘smaller board’ (with memory) from the US-32GB inside the EU-64GB assembly and it showed the same symptoms. On the other hand, the smaller board from the EU-64GB worked fine with ‘big board’ from the US-32GB.
That suggests that (choose one):

  • the ‘smaller board’ from US-32GB is bad
  • the US-32GB memory chip is corrupted
  • only the data on the memory chip is corrupted and it can be simply flashed on another controller.

I will not be diagnosing it any further since I do not have the tools required to do the job and simply use the new EU-64GB APIM :slight_smile:

@F150chief, thank you for your help! I very appreciate it.

2 Likes