Android Auto constant disconnects

Hi Everyone,

I’ve been trying to figure out a way to make Android Auto work on my car and hoping you guys can help.

Here are the details

Vehicle: 2018 Mustang Ecoboost (Sync 3.4 Build 20196)

Phone: Samsung Galaxy S10 (Android 10), Android Auto version: 5.6.603444. Also tried my wife’s S10 and a spare S7 as well - same issues.

Cables tried: Anker USB 3.0, Aukey USB 2.0, OEM cable from Samsung

Ports tried: both front and armrest console

Steps I have tried: Master Reset. Delete cache/data/updates on AA app and reinstall. Disabled all battery optimizarions. Factory Reset phone. Clean out USB ports in phone and car.

Problem: I plug in the phone and AA shows up on the screen and works fine. Within 1 minute, it disconnects/crashes. Sometimes within 10 seconds, sometimes longer. This is without moving the phone or car at all. Same problem with the different cables and ports as mentioned above. Its weird because the same phone and cables work perfectly fine in my wife’s 2020 Escape that is running Synd 3.4 as well. Not sure if helpful, but Apple CarPlay also works on the Mustang without any issues. I have reached out to Google and Ford and all have been useless.

Any thoughts or steps here I’m missing?

As you’ve tired all the troubleshooting steps I’d normally recommend, the only two things I can think of:

  1. Most common issue is lint (dust) embedded inside your usb-c ports that allow normal charge, but push the cable out just a bit. It often isn’t very visible, but for completeness just run a tooth pick/compressed air/both and ensure it is clear even if it looks like it is.

  2. your usb hub is faulty. The second port you are using links into the main hub, so if they has a fault it’ll be same for both ports. Id pull the hub out and check the power and USB connections are good, and if you are under warranty take it in and get it replaced. Or, swap it with the one in your wife’s car if the same size.

Try another phone, if it also fails then there’s something particular with your car (USB hub or other thing).

Did it work in the past?
Which sync version did it have?.

Thanks for the responses.

I have cleaned out the USB-C port multiple times along with trying by wife’s phone and spare S7 i have.

Previously I was running Sync 3.0.19205 and I was having similar issues at the time. I will try to check the USB hub. I’m hoping upgrading to 3.4.20196 did not void my warranty for the USB connections (still have 4 months left)

Sorry Louage, forgot to ask.

Are you aware of any guides that I can follow to check the USB hubs? The one by armrest is probably easier to check. But the one on the dash seems a tricky one to get to

You only have one hub in the armrest, three cables go into it. Power (check that), USB to the apim, and USB to your front port. You can ignore the front port as it won’t be that.

Pull the hub out and check connectivity with it pulled out, if stable is is a loose or broken connection. If not, replace it or warranty it in my opinion

I would bet that the hub is on it’s way out. The older hubs don’t supply much current, the newer ones have been upgraded. This is a common failure. If you have another phone rather than an S10, try that and see if the hub holds up. S10’s draw pretty good, and it sounds like when the phone is starting to charge, the hub gives up. Try it with a fully charged phone or turn off charging and see what happens. However, long story short, replace the hub with a new one.

The part number is HC3Z-19A387-E. Several on EBay, etc. Run about $55.00 average.
Do not buy one of these off Amazon unless it is from a real Ford Dealer, as there are a lot of counterfeit or remanufactured ones from China.

Are you sure about the part number? I unplugged the USB Hub and cleaned all cables amd ports - still the same issue.

The part # installed is HU5T-14F014-AB. I’m just curious as CarPlay has no issues. Same goes for charging Android or even having the USB plugged for updates. I know those probably draw more power but there must be other Mustang owners using the same hub for Android Auto on S10 with no issues. Just trying to cover bases here before going to Ford or ordering the part with the issue still being there.

I think it’s worth noting. Even after AA doesn’t display on Sync after couple seconds, in the phone it still showd “Android Auto Connected to Car” and the “USB Accessory Connected” under notification panel saying the connected is still there

That part is for the 2 port rectangular unit. You have a single port unit, so either will work but you are right, the single port is the one you want. The latest part number for yours ends in -AC.

You’ll need the single port as the double doesn’t have a pass through for your front port.

Unless there is a problem with the cabling it can only be your hub, so it’s the next logical thing to replace. I’ve never seen your issue mentioned before so it won’t be a software related issue.

We have the same issue with our Fiesta MY19 (no NAV)- With Samsung S7 and iPhone 7
I figured out, that as soon as I pick up the iPhone and it recognise it (start up screen) carplay lose the connection.

On My Focus MK4 MY20 I dont have such issues.

Ford dealer dont know what to do. it is annoying

Did an experiment last night with a fully charged phone and it worked for about 10 minutes.

Just ordered a replacement hub. Will report back once it arrives hopefully with good news!

2 Likes

You could swap hubs between the two vehicles you have to see if the problem ‘moves’

Just make sure to use some soft plastic dash tools to remove the hubs as they scuff up easily

I found this article that is admittedly a little old (March of last year) but basically states that people were having trouble with S10s and Sync. https://www.valuewalk.com/2019/03/galaxy-s10-android-auto-issues/ . I agree with SaNdMaN that you should try another phone and see if it works.

Just got my replacement part # HU5Z-19A387-B.

And it finally works! Did not crash at all during the one hour commute.

Thanks for your help everyone! You guys know your stuff :smile:

3 Likes

Glad to help, enjoy!