Android Auto Issue Sync 3.4

Hi all,

I have a 2016 F250 Lariat which I upgraded to the newer radio hardware and Sync 3.4. When I plug in my phone, Android Auto launches fine and everything appears to work, but if I’m navigating with Waze or Google Maps I can’t hear turn by turn directions. If I have music playing, I hear the volume of the music go down as if it’s going to provide an instruction, but no instructions are heard and then the music volume is restored. Any ideas? By the way this is the same behavior on my wife’s Pixel 3A and my Essential phone both running Android 10.

I assume you already performed a Sync Master Reset, right?.

Someone in the discord server said this could help solving Android Auto issues:

1. Unplug phone from USB
2. Master Reset Sync Screen
3. Remove the Ford Sync from Android Bluetooth settings. (Unpair)
4. Open Android Auto App. Select Three Line menu -> Settings -> Connected Cars -> Three dot menu -> Forget all cars
5. Via Android Settings-> Apps
5b. Android Auto -> Storage -> Clear Data
5c. Go back to App list, Select the three dots menu -> Show System Apps
5d. From App List locate Google Play Services -> Storage -> Manage storage -> Clear All Data
6. Connect phone to Sync USB while screen powered on and unlocked for both devices
7. Setup prompts should start on Sync and phone for Android Auto and Bluetooth.

Give it a go and see if it helps.

turn the volume up while that prompt is happening also make sure you master reset the sync unit after upgrading

Thanks for the suggestions guys. I tried both and still have same issue. The strange thing is when I try to turn the volume up during a prompt it just turns the master (like music) volume up and nothing changes on the directions audio.

i use android auto basically all the time and not experienced this issue, did you master reset when you upgraded?

I purchased the upgrade kit from ebay from the link below, installed it, did a master reset (now several times), and still can’t get the dang audio to work for turn by turn. Everything else seems to work properly though. Any other ideas?

Thanks very much!

Not to crazy about those Chinese made units. Try contacting the seller for support.

Android auto audio is played via Bluetooth not via USB as far as I know therefore i would be checking Bluetooth settings rather than usb cables etc.

Didn’t realize that was bluetooth. I will check those settings again, thanks!

I was able to hear audio instructions from google maps if I only connect via Bluetooth. As soon as I plug in the cable (and use Android Auto) I am no longer able to hear the turn by turn instructions. Any other ideas or thoughts on how to continue troubleshooting? Thanks all!

Apparently i am partially correct, Music is via USB, Notifications/Calls are via Bluetooth.

Just to provide a final update. I contacted the ebay seller and he remotely programmed the radio with my laptop and Forscan. Took him a couple tries but now all controls work including volume up and down for instruction prompts. Thanks everyone for all your help! Really great forum here!

1 Like

Glad all worked out for you! :+1: