Anyway to fix XM logos?

What is your SYNC Region?


What is your current SYNC Version?


Do you have Navigation?


Do you have a error message, if so what is it?


Please describe in detail your issue below

17 Fusion, The update went smooth and I don’t have any issues to note except the fact that my XM Radio will not show logos. I’ve refreshed the signal and performed a master reset twice. It’s there any known work around?

This is a well documented issue with non-nav Sync units, which can affect NAV units also. It is believed that it has to do with the reduced storage available. Other than a master reset and refreshing the authorization, like you have done, there is no immediate solution. Over time however, you might see the logos come back when SiriusXM pushes updates to the radios.

Thanks for the response. I will wait for XM to update and see what happens. Sometimes they were showing incorrectly before but only ever on one or two channels. Its annoying when there is no logo because it replaces it with alt text that doesn’t have the entire station. Classic Rewind for example shows as ClsRwnd. Annoying. I’ll keep an eye out!

Yep, I see the same behavior on different stations and I have a NAV unit. Some have logos, some don’t.

I had similar issue but over a couple days of changing channels they came back. On one of them I had to Direct Tune the station several times and the logo came back. I still have issues where I will be listening to one station and its actually playing the audio of that station out loud but the logo shows the radio tuned to another totally different station.

1 Like

Had my first XM Radio update today since I did the update and nothing changed on my end. Drove 300 miles yesterday visiting a family member and back, no change still. Tried the direct tune also just to see if it would work and nothing. I’m just going to leave it be for now and assume it’s broken. Not the end of the world considering everything else worked perfectly, but have others said, the little things can drive you crazy :grimacing:

1 Like

I have a 17 Fusion as well with the same issue. I have NAV however after changing my APIM data board to a NAV one, everything functions perfectly with the exception of no Sirius logos. Upon some research, in other forums, I’m hearing it’s due to the 2017 ACM having Sirius only tuner and the 3.4 software changes the way it handles data from the tuner because the newer vehicles having the “SirusXM” hardware instead. I have no clue how accurate this is but I’ve tried everything and can’t get my logos back. I was going to try to install a newer ACM and see if it changes anything.

SiriusXM transmits the metadata for each song embedded in the audio data stream, it’s just that the older FORD APIM’s cannot read it, because they only get Sirius, not the XM data stream. Some of the other vehicle manufacturer’s systems work and display the data correctly. The newer APIM’s (Late 2019 and up) can read the “XM” stream. Depending on the firmware in the ACM and APIM, that data is displayed. That’s the theory…in practice it is less than reliable.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.