APIM bricked after firmware update


Today, I’ve failed with the firmware update on my APIM HB5T-14G371-CCA, North America 32gb with Navigation. I will really appreciate your comments or suggestions.

I followed guide “Updating APIM Firmware (Calibration Files)”:Updating APIM Firmware (Calibration Files)

Process failed on updating first file Strat: GB5T-14G374-CB.VBF

After fail screen remained black.

Then I’ve tried recovering with the following instruction: " APIM Firmware Flash Rescue"

Followed suggestion from guide, to use GB5T-14G374-CD instead of GB5T-14G374-CB but it failed same way.
“Uploading strategy file GB5T-14G374-CB may brick the module. Solution is to upload GB5T-14G374-CD instead of GB5T-14G374-CB.”

Initial state:

I will really appreciate your suggestions.

What adapter are you using?

Thank you for response

VIAKEN Vscan STN2120 USB, I think it should not be an issue… it’s really well made product.

Translated product page:

You are using a non-nav cal file with a Nav unit. You should be using 375-DA.

Hi, thank you for suggestion. I’ve retested using GB5T-14G375-DA.VBF but issue is still there.
Generally, it is failing a phase before while loading *374-

Disconnect power from the unit for about 5 minutes and then try again.


Did you resolve the issue?

Instead of loading all the files at once.

Try loading one file at a time until you load the file that is corrupted and hopefully recover it.

It worked for me. After trying like 20 times, I tried one last before I surrendered. Tried loading just one file, the one I suspected was giving the error and boom, it came back to life.


Unfortunately no. I’ve tried yours suggestion first. I disassembled the car dashboard and accessed the APIM directly. Then I’ve tried:

  1. Disconnected APIM, waited 5min, connected and tried to update…FAILED (repeated at lease 10 times)
  2. Updated FORscan to 2.4.5 beta3 and tried the ‘recover’ option. So, I disconnected the plug from APIM, waited for a while, started flash on FORSCAN and plugged in APIM…FAILED (repeated at least 10 times)

@Yan I’ve also tried to flash only “*374-” since it is failing. Without success :frowning:
Maybe I should also try to do this 100 times. Maybe after few rounds it would work.
Have you made a short power supply disconnect time each time after unsuccessful cycle ?

1 Like

have you tried loading a different version of every file ?

I did not disconnect the power supply that I remember


You need to find out if the adapter you are using is a Chinese clone ELM device. If it is, it will not work and is not supported by FORScan. Contact the FORScan team and make sure you tell them you are a paid licensed customer.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.