APIM U0159 Error communicating with PAM

Hello guys, maybe someone can bring some light here. I’m facing the Lost communication with PAM error and can’t do anything with it.
So, what I have for now:

  • Ford Fusion Energi 2016 with swapped Sync 3 64Gb EU version (Was taken from Ecosport 2019);
  • BCM was installed from Mondeo 2016,
  • PAM firmware was taken from Mondeo 2019, Fusion Energi 2020, Edge 2022, however all of them gave the same error.
  • Tried making asbuilt edits to PAM with no success.

Hope to hear some ideas if anybody else already faced this issue and has it addressed. Thanks!


SYNC Region: EU

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: Retrofit

Old SYNC Version: 2.0.0

New SYNC Version: 3.4.22251

Do you have a error message, if so what is it?
APIM: U0159 Error communicating with PAM

Update Method: Official Ford





Did you load the original As Built for it? That should fix it.

@JoSS,
Your APIM Sync version may not support what you did, and it can’t talk to the PAM anymore. Try loading Sync 3.3.19052 and see if the PAM communication is restored and the DTC goes away. This is mentioned in the PAM Firmware Upgrade thread at 2GFusion.net.
PAM (Parking Aid Module) Firmware Upgrade - 2GFusions http://www.2gfusions.net › showthread

Code: U0159:00
Definition: Lost Communication With Parking Assist Control Module “A”: No Sub Type Information
Cause: Set by the APIM when network messages are missing from the PAM for more than 5 seconds with the ignition in RUN.

Also, The KT4T-14C647-AB file would probably not be compatible in your vehicle. I would install the original firmware back into the Mondeo BCM/PAM, with the original asbuilt for the Mondeo PAM, as @bill32399 stated above.

Thanks for the answer. Yes, I tried many different firmwares as well as asbuilts, including the original Mondeo firmware, nothing helped to get rid of the DTC. The only thing left to try is to roll back to Sync 3.3.19052 and see if it helps.

I also tried to contact that guy from the mentioned thread, however he hasn’t answered my messages yet. However he managed to get this issue resolved without rolling back the older Sync version.

Yes, I did. Still no luck.

Guys, I just thought that my APIM’s firmware might require an update since it was taken from Ecosport 2019. I’ll check the firmware from Mondeo 2019 and will compare them. Maybe this is the root of the issue? How do you think?

That is a possibility. Most likely the asbuilt data for the park assist or architecture.