Asbuilt from a 2020 Fusion

Does anyone happen to have an AsBuilt from a 2020 Fusion Titanium non-hybrid handy? I’m mainly looking for APIM, ACM, and IPC.

I want to compare w/ my factory Asbuilt and see if I can figure out why an X40 ACM/APIM swap is not going the best (yes, I tried before, but I still have the parts and I’m trying again :sweat_smile:)

You can pull them from here and use a VIN from a used car site:

That said the biggest difference between the 2020 & the 2019 is in the APIM and ACM.
The ACM is a one off year due to the change to support Sirius X40.
2020 Fusion Ti non-Hybrid.ab (44.6 KB)

If you look on here you’ll see my DACMC saga from doing a 2020 X40 upgrade.
What year are you coming from?
The change details are in that thread?

I’m a 2018 as well, I’m getting no GPS when I throw in the new APIM/ACM combo. The X40 upgrade part was successful, I activated a trial and it’s working. Plug the old stuff back in, GPS starts working again. If I leave the GPS antenna out of the APIM it throws a code in ForScan so it seems to be fine with the antenna.

I was wondering about the IPC because I don’t get FM and Sirius info in the dash any more either, but that’s not a deal breaker.

Are you using your original factory AB file for this?
If you’re not, drop your factory AB into the ACM using Forscan, save and then load the AB into the APIM make the X40 bit change, save and once the APIM comes back up use ForScan to do a module reset/reboot.

Lest I forget, there is also a comm change between the 2018MY and the 2020MY, if you’ve got that wrong it can screw up other things.
Easiest way to check it would be to see if your right side steering wheel buttons work.

I did try that, along with a master reset and unfortunately no luck :slightly_frowning_face:

Steering wheel buttons are working correctly as well

Ok, lets break this into pieces.
Pull the X40 ACM, put your original in and drop your factory AB into the “new” L series APIM.
What happens?
If the problem follows the APIM and you’ve loaded your factory AB in I would think that the GPS Fakra connector is either bad or not all the way seated.

Just looked at your thread on 2gfusions.

  1. is your APIM still having the “its in Detroit” issue?
  2. are you trying to do this with the K series APIM it shows on that thread? (KU5T-14G371-GJA)
  3. Do you still have 7D0-08-01 set as xxx3-xxxx-xxxx like it was in your post last year? It should be a 2 not a 3.

If you aren’t using an L series APIM that’s where the problem is coming from.
The calibration/firmware between the K & the L are different.

Yes, it’s still convinced it’s in Detroit. It’s the same APIM. The referenced value in 08-01 was actually set to A, I have changed it to 2. Still in Detroit :joy:

The sitting in Detroit is a bug in Sync 3.4.22251.
What build are you running?

To the best of my knowledge and someone on here can correct me a K series APIM is not fully compatible with X40 even though the APIM can see the stations.
What part number is the ACM?


It was pulled from a wrecked 2020 Fusion. No clue on the history of the APIM, other than it thought I was somewhere in Germany when I got it.

Last time it was in, I tried doing a downgrade to an upgrade (have my original screen still so I don’t have to worry about MY20) and it didn’t work on the downgrade either.

The MY2020 is more than just the screen.
What does the interrogator show?

If you’re referring to downgrading the 3.4.x build you need to run the RW data cleaner.

Not true. The K series APIM is fully compatible with any ACM running X40 with the proper firmware and asbuilt settings. If you are not running the latest APIM firmware you should update and wipe the APIM settings to factory and make the changes for the X40 handling. Since you have a 2018 vehicle, you need to make sure that the Legacy messaging is maintained. This will resolve the dash information also.

This is correct, but the rwdata must be cleared for this to be resolved in some cases.

This APIM can be reformatted, does not rely on which screen you have. It is the screen drivers in the APIM eMMC that matter.
KU5T -14G371 -GJA , 64GB, WITH NAV. You will need to load the correct firmware for this unit for NA market if you have not done so.

Alright, sounds like I’ve got some homework :laughing:. It is the “bad” version that’s being discussed here.

I do remember in the past being provided a different calibration file by F150Chief. Is there a way I can confirm on the “release” version of FORScan? I had the one that would let you update calibrations and firmware but since I hadn’t used it in a while, I upgraded it to the latest and completely forgot the versions that let you do module updates are separate and hard to find.

I’m assuming that a reformat will do the “rwdata clear” being mentioned here. I found the “safe” versions of SYNC 3 in a different thread so I should be good there.

One more question: I do have “legacy” messaging enabled in the APIM, is there a similar bit somewhere in the ACM config?

Nothing in the ACM, with a 2018 Ti you can literally just drop in your factory AB as the 2020 factory AB will have the 2nd AM/FM antenna disabled, your AB will have it enabled and it will just enable the white antenna port on the ACM.

As F150Chief stated, a 2019 APIM will work with the proper firmware/calibration in it will work with X40.

And just to make sure I’m clear what order is everything supposed to be done in? Rw wipe, do I do a reformat, etc. I did it with Auto today and still am stuck in Detroit.

On a side note, it’s kind of hilarious how much SXM effed up the channel logos. After I did it I got the ones the software came with, then after about a half hour they all changed to the SXM logo.

Typical SiriusXM. They spend all their money on advertising.

Update- I see it is fixed on mine now.

Use the Updater to create a RW data cleaner USB, pop it in let it run for a bit then do a master reset and install either 3.4.21265 or 3.4.23188.
3.4.21265 was rock solid, 3.4.23188 was the build to fix all the sins of 3.4.22251.

The issue with being in Dearborn is more than likely the world region of the APIM firmware.
I got around to jail breaking my science project APIM that came our of a UK Puma today and loaded the maps in using both the FMods map remover method (45 minutes) and the FMods reformatter add on (25 minutes).
With the EU maps that were already in it I didn’t have a GPS error but it was showing the location at Bristol in the UK.
US maps loaded in I’ve got the GPS offline error with the NAV showing the location as Ford Corporate in Dearborn.

GPS is definitely working, FordPass shows the correct location for the car.

Interesting, I have read success stories from changing the APIM region, and I swear in the past that F150Chief sent me a different calibration file to try.

Like I said, it does seem to “see” the antenna, as I don’t get a FORScan code for open GPS circuit, and it was my understanding that my SXM would also not be working as the antenna is a single module that’s split.

I’m making drives to do what was just suggested in the order suggested, and I’m also going to run the interrogator. At this point, I couldn’t care less if I blow up this APIM trying some crazy things (I’ll just put the old stuff back in) so if folks have some crazy firmware/calibration stuff they want me to try I’m more than open to it.

1 Like

Ford Pass does not use the GPS for location. It uses Cell Tower Triangulation through the TCU.

1 Like