Australian Focus RS 2018 Sync 3.4 Update Warning

I just performed the Sync 3.4 update on my Australian Ford Focus RS Limited Edition Mk3 while it was successful in the end, two things happened that I saw no warnings for or even as possibilities or how to correct them, and an average user may panic and not know what to do.

I used very high quality USB drives and made 2 just in case.

first part of the install went as specified, I removed the USB when instructed, the Sync rebooted and I replaced the USB drive when requested.

the screen turned orange and stated no update files found. I had seen this on one video, which said to ignore it, remove and replace the USB drive. On mine this made no difference, it remained orange with the same error. I tried turning the engine off, and on again, the update restarted and went back the orange screen with the same error no matter what I did.

By trial and error I found, remove the USB, turn engine off, open driver door, close driver door, turn engine back on, replace USB. This worked and it proceeded to re partition and load updates. My USB drives were very fast so the update took 17 minutes and stated 100% successful. It stated to remove the USB Drive and the system auto rebooted.

I expected the Mustang logo at least once, but mine went straight to the RS logo, all ok so far.

Just after loading, it popped up a blue box stating update not complete, please insert USB so it can complete. I did this and it gave a Navigation error, contact the dealer. I though oh damn. Then another window suggested to download the files and try again. I tried this several times but no go, Navigation was disabled and not working and any attempt to update as it suggested failed. I thought I would try the engine off/on and door open/close again but that also failed.

I thought I would try a master reset. I removed the USB. Found and chose Master Reset in the menu, the screen went black and took several minutes. It finally rebooted, and it all came up working with no issue found so far. Even Climate control was auto enabled which I never had before and it works great.

It sounds like you’ve used the outdated YouTube video guide to upgrade, the app available on the main site uses a single USB that avoids the issues you mention.

No, I used the very latest app available on the site V2.1.0.5 using a single USB not the old guide, and it did not avoid these issues.

Not sure what you did, but I’ve a couple of comments:

A) About the sequence to start the process over (turning the engine off, opening the door and so on) is clearly stated in the tutorial. It should not had been “trial an error”, since it was covered by CyanLabs’ tutorial.

B) Performing a master reset after the update is also clearly stated as the final step in the tutorial hosted by CyanLabs. So “Error 2” is not an error, you just didn’t do what you were supposed to.

We assume you use the tool and performed an AUTO install, right?.
Nothing done manually?.

Besides these hiccups, glad it worked and thanks for sharing the experience; I’m sure it will come handy to someone else.

Which version did you upgrade to?

You must have removed the USB sooner than you should have. do not remove the USB when SYNC tells you to.