Black screen after splash logo/boot

Hey there,

It’s been more than a year that I’ve had Sync 3 retrofitted into my 15 Focus ST with the 3.4 update. Last winter my APIM would always reboot constantly when it was very cold ( between -20° and -45°) which I thought was normal.

This winter it kept doing the same, but two days ago we had super cold nights (-42°) and now it is stuck on a black/gray screen (you can see the display is still on but it’s blank).

I thought letting it warm up would potentially solve the issue but it didn’t, I even tried to soft reboot it by pressing POWER and NEXT until the splash screen came back, but after a while the splash screen goes away and goes back to the blank screen.

So I waited a few days so the weather gets better. Today it’s 1°C outside and it still does not work. I connected my car to forscan, I checked for DTCs the only code the APIM threw was B108E - Display. I cleared it and tried a module reset. Nothing changed.
I even unplugged the APIM completely, and plugged it back in. Still no luck.

So I’m back to square one, Splash Screen comes on… stays for a while and then, blank.
If I’m quick enough I can get my reversing camera to come on but I get back to the blank screen anyway after I get out of reverse.


Hello there.

Assuming there’s no issue with the power supply, that hints some kind of hardware failure. I’ve not read on the forums a case like your before (that depending of the temperature the unit would or would not work).

About the rear camera feed, that does not goes through normal Sync3 path, so it’s kind of a bypass, that’s why it might work.

Which APIM model did you get?.

Besides the screen, is the unit operative? (radio, power to the USB ports, something like that).

This is likely a hardware issue with cracked solder joints on the internal electrical boards. Likely nothing you can do about it. You will likely need a replacement APIM.

I’ve actually searched through the Forum a few days after posting this and someone has had the same issue as me :

I get power through USB, screen turns on with splash logo but no sound/radio or Bluetooth

@Just21 , is there any update from your side?
I’m setting a 4 days inactivity auto-closure

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.