CarPlay - GPS Prompts


I recently switched from Android to iPhone 14 Pro and noticed that when navigating with either Google Maps or Apple Maps, I am unable to hear the audio prompts if I talk on the phone and navigating at the same time. Once the call is ended, I can hear the prompts again.
to confirm, i reconnected my old Galaxy S21 and tested the same and could hear the prompts during the call.
I also tested the CarPlay with other iPhones (12,13 and 14) and got the same results - no audio prompts during a call.
I tested my phone in another car with CarPlay (not Sync) and it worked as expected with audio prompts during a call.

It looks like the implementation of CarPlay may have a small bug.

Any ideas if and how I can resolve this?

SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.0.20204

New SYNC Version: 3.4

Do you have a error message, if so what is it?
No Error Message

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version:

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

Lost The Log File

Have you tried to turn the volume up WHILE the system is prompting?

1 Like

Yes and I can change the prompt’s volume when music is playing or when it is by itself
However when on a call, the prompts are completely off and the volume only affects the call.

It looks like when a call is in progress, the call’s audio is taking over any other audio channel so it leads me to think the issue may be in either the SYNC3 software or the CarPlay implementation.

By the way, I got one of those wireless BT CarPlay receivers to test. It connects via USB cable to sync3 and the phone is then paired with the BT on this device rather than the BT in the car. I got the same results - no navigation’s audio prompts during a call.

Any other ideas?

This is an issue with CarPlay with iPhone. This is documented on the Apple forums. If your source in set to Apple CarPlay, your prompts will probably work, but will not otherwise.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.