Clock changes on ignition

Hi all,

I’m really hoping that I can get some help with this problem:

When I turn the ignition on, the clock changes to a random time. If I try to reset the time, it reverts back to the random time after a few seconds. As soon as the ignition is turned off, the clock returns to the correct time. (I have taken a video of this - https://youtu.be/jc3jxDTMK8M?si=vBrssD9zvpIRSAve

This is such a big problem for me as android auto will not connect whilst the clocks do not match the same time.

The car is a 2018 Ford Fiesta. Sync 3.3. Build 19052. Maps F12.

The only thing which may have caused this change was it had it’s MOT and service at a Ford Dealership, so potentially the APIM was changed?

I am quite a novice so any help will be appreciated.


SYNC Region: EU

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.3

New SYNC Version: 3.3.19052

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version: Latest

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

N/A

While the APIM may not have changed, from the factory your 2018 should have come with 3.0.x not 3.3.x

It possible that the dealer tech reloaded the factory AB into the APIM if he was trying to clear a DTC.

Have you tried doing a master reset?

So to add, a couple of years ago I upgraded to 3.4 which was perfect and I had no problems.

Since this issue started, I have downgraded back to 3.3 thinking this may have solved the issue, however this made no difference. My aim is to fix the clock and then upgrade again to 3.4.

I have master reset and soft reset but this has not made a difference.

The only ‘change’ would have been the service by Ford.

Which the tech could have done, most don’t think about the fact that Sync 3.0.x was in this model/year & 3.4.x in this one.

I would suggest taking it to either 3.4.21194 or 3.4.21265 to see if this cleans up your issue.

I did previously do that exact step to 3.4.21265 but unfortunately the problem persisted and then I downgraded again to 3.3 which also did not fix it.

Did you do a master reset after the downgrade to 3.4.21265?

I did yes

Is there a specific reason you would suspect this? If you have your receipt it should state what was done.

Run the Interrogator Utility and post the results. This will tell us exactly the APIM status.

There is no real reason, just reading other forums it seems that this could be the issue, however I have just ran Forscan and the values are the same as factory so this seems unlikely.
This service by ford was the only thing that I could think could have caused this clock problem as I have not modified anything else within this period.

This is the clock master details:
Screenshot 2024-04-19 111546

The Interrogator Utility is:
Version 4U5T-14G381-AN
APIM Model: H1BT-14G371-FEC
APIM Type: Navigation
APIM Size: 64GB
APIM Free Space: 10G
17/01/2089 23:59:40 +00:00

Partition Type = Free / Total
/fs/sd/MAP/ = 804K / 1.2G
/fs/sd/MAP/ = 15M / 2.9G
/fs/sd/MAP/ = 14M / 2.4G
/fs/sd/MAP/ = 7.6M / 1.5G
/fs/sd/MAP/ = 17M / 2.3G
/fs/sd/MAP/ = 21M / 3.8G
/fs/sd/MAP/ = 308K / 40M
/fs/sd/MAP/ = 4.5M / 3.3G
/fs/sd/MAP/ = 26M / 3.2G
/fs/Nuance/ = 28M / 4.8G
/fs/Nuance/ = 29M / 5.0G
/fs/Nuance/ = 26M / 4.4G
/fs/Nuance/ = 36M / 3.7G
/fs/Nuance/ = 91M / 1.9G
/fs/Nuance/grace = 59M / 1.0G
/fs/rwdata/ = 858M / 1.2G
/fs/mp/ = 505M / 1.4G
/fs/mp/resources = 260K / 91M
/fs/images/ = 10G / 54G

Installed Packages
1U5T-14G658-AD
1U5T-14G421-BAK
1U5T-14G421-BBK
1U5T-14G421-BCK
1U5T-14G421-BDK
1U5T-14G421-BEK
1U5T-14G421-BFK
1U5T-14G421-BGK
1U5T-14G421-BHK
1U5T-14G421-BJK
4U5T-14G422-BAK
4U5T-14G422-BBK
4U5T-14G422-BCK
4U5T-14G422-BDK
4U5T-14G391-AJ
4U5T-14G423-AA

APIM AsBuilt
DE00: 086A05DA5002FC0440C2
DE01: 554B0001C08A088028B80005
DE02: 0000010004
DE03: 00001D82010001
DE04: 190819082653
DE05: 80
DE06: 0B0533000000006428000056565F0061

Your clock master is set to 6A=EP On, EPT 60 minutes (FoE), CM BCM (C1MCA and CGEA 1.3), MC Disabled, SWC SWMT - C1MCA and CGEA 1.3. This is not consistent with several asbuilts I looked at for North American 2017 thru 2019 Fiesta’s. Those all indicated A7=EP Off, EPT 30 minutes (FNA), CM APIM (NA Market CGEA 1.2), MC Enabled, SWC SWFC - C1MCA.

According to the Ford Master Clock documentation, Fiesta’s migrated to CGEA 1.3 in the 2017 model year, so the 6A setting would be correct.

Since your system has NAV, does it seem to operate correctly?

Thanks for the feedback… Unfortunately I’m new to this all, can you briefly explain what I need to do to sort this out? Thanks so much.

And yes, the nav works accurately still.

Anyone able to help? Still have found no fix.

You’ll need a copy of something like Forscan and an OBDlink device.

Yes, I have both of these. What do I need to do?

I had that issue.

Ive updated to 3.4.23188 and for a month my time have States correct

Edit it the asbuild as per F150chiefs details above.

Sorry I’m a right noob.
So run forscan and change the APIM settings to those that f150 listed?

Exactly what i said. Make a backup of your system first, also download the factory asbuild and keep handy, just in case.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.