Clock Wont Allow Time Change 3.4.20196

Looking for a little help/guidance here. I updated from 3.3.19052 to 3.4.20196 and now the clock doesn’t work properly. I can tap the time, change it to what I want it to be and after 15 seconds or so it reverts back to whatever it was at to start with. I downgraded back to 3.3 and it works normally. Re-upgraded to 3.4 and it doesn’t work again.

Any suggestions? Tried the Clock Master setting in forscan and it appears to be correct.

Hi there.

From my experience with Sync Updates/ Master Reset, APIM clock has never worked properly until a GPS lock is acquired. As soon as it gets signal, time is automatically corrected.

I’ve always found it akward since the cluster has it’s own clock and they are connected via CAN…

disable auto update and it will stay

In your Focus this is true, however Ford has migrated to using the Sync system (since Sync 3) in new models which supplies time to the BCM, which supplies it back to the systems in the vehicle.

Ford Master Clock.pdf (298.8 KB)

1 Like

It sounds like you do not have a GPS lock for the clock and NAV.
What is you setting for the Clock Master? 7D0-01-01 xx** xxxx xxxx.