Downgrade issues Ford Pass modem Sync 3.4 - 3.3

Hi all,

I today downgraded Sync 3.4 back to 3.3 because I thought it looked awful and has no black theme, others seem to have similar opinion.

Unfortunately since I did this the telematics have not worked. The ford pass app is getting no updates from vehicle and cant access it.

I’ve removed the vehicle from my account and tried to re-add and I receive an error message reading “sorry your authorization rights for F2019 Transit - TF2019 could not be changed. Please try again later”.

This stopped working as soon as I downgraded back to 3.3. could anyone help me please?

Stay safe everyone

Actually a common problem. Try this:

  1. Remove vehicle from app, sign out of app.
  2. Remove app from phone and reboot phone.
  3. Remove power from the modem in the vehicle. You can do this by disconnecting the wiring plug on the modem, or by disconnecting the vehicle battery. Leave disconnected for at least 5 minutes.
  4. Reconnect power.
  5. Start vehicle, engine running. Wait for Sync to fully boot. Perform a master reset on Sync APIM.
  6. Add phone back to Sync. Make sure all your functions work.
  7. Add app back to phone, add your vehicle and accept permissions via Sync unit.
  8. Check all your settings and make sure it all works.

NOTE: It may take anywhere from 5 minutes to a few hours to fully activate all of the FordPass features, depending on the status of the Ford servers, etc.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.