Enforced Downgrade - Map Version did not work

I am trying made Enforced Downgrade - Map Version but see ERROR - PKG_ERR03
What am I doing wrong?

I have sync 3.4 2020.
I want install russian voice package. I have 1.7gb free space. But voice file is very big (5U5T-14G391-AL_1580843150000.TAR.GZ).
**


**
So. i try resolve MEM_ERR03

Log file:

CYANLABS - SYN3 UPDATER - V2.10.6.0
Branch: Stable
Operating System: Майкрософт Windows 11 Домашняя (2009)

PREVIOUS CONFIGURATION
Version: 3.4.20136
Region: NA
Navigation: True
Install Mode: Автоопределение (autoinstall)
Install Mode Overridden: False
My20 Protection Enabled: Включено

DESTINATION DETAILS
Mode: Drive
Model: USB FLASH DRIVE USB Device
FileSystem: exFAT
Partition Type: MBR

AUTOINSTALL.LST
; CyanLabs Syn3Updater 2.10.6.0 Stable - Autoinstall Mode - Enforced Downgrade

[SYNCGen3.0_ALL_PRODUCT]
Item1 = APPS - 4U5T-14G381-AN_1552583626000.TAR.GZ
Open1 = SyncMyRide\4U5T-14G381-AN_1552583626000.TAR.GZ
Options = AutoInstall

FILES (1)
4U5T-14G381-AN_1552583626000.TAR.GZ (479,7MB)

LOG
[28.11.2021 17:49:19] Selected Region: - Release: Enforced Downgrade - Map Version:
[28.11.2021 17:49:19] Install Mode: Автоопределение (autoinstall) Forced: False
[28.11.2021 17:49:19] MY20 Protection: Включено
[28.11.2021 17:49:19] Formatting USB drive
[28.11.2021 17:49:19] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
[28.11.2021 17:49:25] Checking Existing File: 4U5T-14G381-AN_1552583626000.TAR.GZ
[28.11.2021 17:49:25] Downloading: 4U5T-14G381-AN_1552583626000.TAR.GZ
[28.11.2021 17:49:51] Validating: 4U5T-14G381-AN_1552583626000.TAR.GZ
[28.11.2021 17:49:52] Downloaded: 4U5T-14G381-AN_1552583626000.TAR.GZ
[28.11.2021 17:49:52] Preparing USB drive
[28.11.2021 17:49:52] Checking Existing File: 4U5T-14G381-AN_1552583626000.TAR.GZ
[28.11.2021 17:49:52] Copying: 4U5T-14G381-AN_1552583626000.TAR.GZ
[28.11.2021 17:51:07] Validating: 4U5T-14G381-AN_1552583626000.TAR.GZ
[28.11.2021 17:51:37] Copied: 4U5T-14G381-AN_1552583626000.TAR.GZ
[28.11.2021 17:51:37] Generating Autoinstall.lst
[28.11.2021 17:51:37] ALL FILES DOWNLOADED AND COPIED TO THE USB DRIVE SUCCESSFULLY!

Having 1.7 GB free space on the APIM is not enough for what you are trying to do.

And by the way, what are you trying to do exactly?, you are not being clear.

You mentioned maps, but the log you provided is only for a single package installation, no mention to MAPS or DOWNGRADE, but AUTOINSTALL.

If your UNIT is MY20 DO NOT REFORMAT IT.

Also, use a quality branded usb pendrive (not drive or disk, or card), not a generic as you are using.

So again, not sure what you are trying to achieve, so please be descriptive.

UPD: it looks like the problem was in the flash drive. i used another one and the problem went away.
i was able to install old SYNC 3.3
But I still can’t install the language pack. Perhaps there is an option to make the language pack smaller? Is it possible to somehow remove unnecessary languages from it?

Yes. i don’t use reformat. I am using autoinstall.
I have already installed the maps I need and am now trying to just install the language pack. But I can’t think of how I can free up space on APIM.
I have already removed the gracenote and compressed the voice files. But I still don’t have enough free space ;(

Sorry, I misunderstood some things from your first message.
Ok, so you are on 3.3 now, already removed gracenotes and installed the small voice pack. You are left with 1.7 GB of free space, and you are getting PKG3 error while trying to install the voice package.

Do the following: configure Syn3udpater with your current Sync3 version, and create and run an interrogator log.

Post the XML file here, make sure to redact the VIN from the file’s title and content first if you care about it. The log will tell us which packages you have.

Sadly, there’s no way to delete packages like maps without reformating.

Thanks for help
my car is not designed to work with sync 3.3
after installing this version i had a lot of problems. Some of the car’s functions did not work, the image scale on the screen was distorted.
I was able to install the latest 3.4
Now the XML file looks like this
sync_update.xml (11.0 КБ)

Tell me, can you remove something from this list to fit the Russian language pack?
Perhaps I can remove the old language pack?

It would help if you fill out the vehicle info on the preference page in your account.

The APIM is a MY20+, so NO REFORMAT options. (5U5T-14G371-PKC)
This is also a US imported vehicle with a 32GB APIM with NA maps installed. You have 1.9GB of free space, but you need about 2.5 to process the voice file containing Russian language.

Something obvious is that someone tried to autoinstall EU maps on the unit, and now it is out of memory. (1U5T-14G424-BK, 1U5T-14G421-BHH) This is not repairable via autoinstall. This unit cannot be repaired via USB because of this, unless the maps are removed. There are no utilities available that will delete the maps from the APIM.

The following files are installed:
NA Maps and voice:
4U5T-14G421-CAB
4U5T-14G421-CBB
4U5T-14G421-CCB
4U5T-14G421-CDB
4U5T-14G421-CEB
4U5T-14G421-CFB
4U5T-14G421-CGB
4U5T-14G421-CHB
4U5T-14G421-CJB
4U5T-14G422-CAE
4U5T-14G422-CBE
4U5T-14G422-CCE
No NA map license.
No Gracenotes.
Sync App and Voice:
5U5T-14G391-EM
5U5T-14G381-EU
EU Maps:
1U5T-14G424-BK
1U5T-14G421-BHH

understood.
If you disassemble the APIM, is it possible to remove unnecessary cards?
Perhaps FMODS allows you to do this with the delete all maps mod?
Or is the only option to install a voice is to replace the memory chip?

Thank you for the logs.

As said before and based on the information you provided, you are running a MY20 NA APIM (32GB) which is full with EU MAPS (that require 64GB EU APIM). There’s no legal way to delete more things than you already have (installing small voice pack, removed gracenotes, and downgrading to 3.3 which is lighter) without reformatting, which you cannot do since it’s a MY20 APIM. Also, you are changing regions, which is also not supported by Cyanlabs.

You can always explore to see if there are other options available, but if they are, those options will not be supported nor will be covered/discussed in Cyanlabs forums for legal reasons.

Good luck!

Good afternoon, colleagues.
I was able to free up space for the voice pack installation. The voice pack is installed and working well.
Now the problem is that I cannot install the navigation.
My order of actions:

  1. I make a USB flash with a navigation setting (I choose the option to update only maps).
  2. I insert the USB flash drive into the car and wait for the installation, it lasts 40 minutes.
  3. After that I see a message about successful installation and SYNC reboots.
  4. I take out the USB flash.
  5. Sync starts up and gives a navigation error. I also see a message that updates are being installed and that sync has been updated to the latest version.

What am I doing wrong? After this operation, I made a diagnostic USB stick. Here are her details.
Also here is the log of the installation flash drive.
Sync_WY94BSLW_30.11.2021.xml (10.5 КБ)
log.txt (8.7 КБ)

Too many maps in your autoinstall, not enough storage. Even though the xml indicates 7.5GB free, you over ran the storage during the autoinstall so those items are not shown as they did not install. You might want to remove the maps first, update your apps and voice, then reinstall the maps and nav-voice in separate processes. This will make it much easier.

Read this tutorial about the size limitations and selecting the proper files:
Tutorial: Current EU Maps Installation on US Imported Vehicles - Ford / Guides & Info - CyanLabs Official Community

The following is installed, based on the xml file data.
1U5T-14G424-BK
1U5T-14G421-BHH
1U5T-14G421-BGH
5U5T-14G381-EU

1U5T-14G421-BFH
BAH is not installed, this is a required file. NAV will fail without it.
Gracenotes is not installed.

BEH is not installed.
4U5T-14G422-BCF
5U5T-14G391-AR is not installed.
1U5T-14G421-BBH
1U5T-14G658-AG is not installed.

5U5T-14G391-AP is installed.

Region is set to 5253. Make sure this is accurate.

<d2p1:PartitionHealth available=“892K” total=“1.1G” type="/fs/sd/MAP/"/>
<d2p1:PartitionHealth available=“14M” total=“2.8G” type="/fs/sd/MAP/"/>
<d2p1:PartitionHealth available=“21M” total=“3.7G” type="/fs/sd/MAP/"/>
<d2p1:PartitionHealth available=“5.7M” total=“3.2G” type="/fs/sd/MAP/"/>
<d2p1:PartitionHealth available=“35M” total=“3.6G” type="/fs/Nuance/"/>
<d2p1:PartitionHealth available=“8.4M” total=“1.9G” type="/fs/Nuance/"/>
<d2p1:PartitionHealth available=“712M” total=“1.2G” type="/fs/rwdata/"/>
<d2p1:PartitionHealth available=“35M” total=“35M” type="/fs/rwdata/quip/"/>
<d2p1:PartitionHealth available=“90M” total=“90M” type="/fs/rwdata/quip/"/>
<d2p1:PartitionHealth available=“17K” total=“496K” type="/fs/mp/"/>
<d2p1:PartitionHealth available=“132M” total=“1.4G” type="/fs/mp/"/>
<d2p1:PartitionHealth available=“7.5G” total=“25G” type="/fs/images/"/>

i see at autoinstall and logs file 1U5T-14G421-BAH. But i didnt see it at installed files at XML. Why?

This is error message after sync reboot:

I can’t read that! I am sure it says place the USB back in so the installation can finish, though. In this case the installation failed and needs to be redone with less files, as outlined in the tutorial. Pay attention to ‘Compressed’ vs ‘Uncompressed’ file sizes.

Thanks.
Can i made new autoinstall and just add four files now:

  • 1U5T-14G421-BAH
  • 5U5T-14G391-AR
  • 1U5T-14G658-AG
  • 1U5T-14G421-BEH

or i should clear maps and made new install?

You might want to remove the maps first, update your apps and voice, then reinstall the maps and nav-voice in separate processes. This will make it much easier.

Look at the example in the tutorial…but use the map files you need.

For this example, we will use the files for North and Central EU, therefore we will need 4 Map files and 1 NAV_Voice file, and the Map License, as outlined below. The ENH_DAB file is included.

1U5T-14G421-BAH 2.2Gb Sync3 v3.2.20339 EU.2.20 (17.08.2020 F10 EU_Common) Required
1U5T-14G421-BBH 474Mb Sync3 v3.2.20339 EU.2.20 (EU_Map_ext) Required
1U5T-14G421-BCH 1.7Gb Sync3 v3.2.20339 EU.2.20 (EU_North_UK)
1U5T-14G421-BFH 2.4Gb Sync3 v3.2.20339 EU.2.20 (EU_Central)
4U5T-14G422-BAF 2.3Gb Sync3 v3.2.20339 EU (DUN,ENG,FRF,GED)
1U5T-14G424-BK 2KB License for 1U5T-14G421-B*H EU.2.20 (17.08.2020)
1U5T-14G658-AG 56.8Mb Sync3 v3.2. SXM (26.06.2021)

The above files compressed size total to 9.1 GB. Uncompressed, these files will take approximately 15 GB. This fits within the 17 GB of free space available from above on the US APIM.

Thanks. Everything works now.

Glad I could help. Enjoy…

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.