Focus Sync 1 to Sync 3

I recently installed a Sync 3 into my 2012 Ford Focus SE. I have everything working except the steering wheel controls. The volume up and down change the volume but also change the source at the same time. The forward and back only change the source. The voice assistant pull button also only changes the source. Any help is greatly appreciated.
APIM

Your APIM asbuilt needs adjusting to set the proper SWC and Clock Master.

2013 Focus is a C1CMA platform vehicle, so the clock master needs to be set for the BCM. The APIM and FCDIM are slave modules. Your clock probably does not work properly, as far as the time sent to the other modules in the vehicle.
At 7D0-01-01 xxXX-xxxx-xxxx, you show as 1800-0400-00F8. This sets the vehicle platform to CGEA 1.2, which is incompatible for your vehicle. It also disables or ignores the SWC present.
The setting for 7D0-01-01 xxXX-xxxx-xxxx should be ‘28’.
28=EP On, EPT 30 minutes (FNA), CM BCM (C1MCA and CGEA 1.3), MC Disabled, SWC Not Available
The full list of values can be seen at Sync 3 APIM Database - CyanLabs

The rest of the APIM asbuilt needs some work…your country code is incorrect

This is an APIM asbuilt from a 2016 Focus, which is the first year the Focus was Sync 3 equipped. Compare these values to yours using the above APIM database.
7D0-01-01 A328 6503 000C
7D0-01-02 0298 1700 0A95
7D0-02-01 5553 0106 40C9
7D0-02-02 8200 0000 005D
7D0-02-03 0000 DC
7D0-03-01 0002 0100 00DE
7D0-04-01 0100 1301 00F1
7D0-04-02 0000 DD
7D0-05-01 17E8 1798 28B3
7D0-05-02 BE9C
7D0-06-01 805E
7D0-07-01 0E04 3300 0024
7D0-07-02 0000 1356 0049
7D0-07-03 0004 3066 007B
7D0-07-04 694B

Thanks. I went through the APIM settings one by one and got the buttons working. My next issue is with the ACM I think. When I click the dial button I don’t get any audio and the mic is not working. The same thing happens with the Bluetooth. Any ideas of where to start? I can’t find much information about the ACM as built.

ACM (2013-2014) Database - CyanLabs

This is from the 2016 Focus, but this asbuilt does not line up completely. Your APIM is likely an earlier 2013 model without the country code defined. Not important for this…
ACM asbuilt
727-01-01 10A0 F400 00D4
727-01-02 0031
727-02-01 2E5F
727-03-01 3062
727-04-01 0001 0155 53DD
727-05 and above are radio presets, don’t worry about those.

727-01-01: xxXx-xxxx-xxxx Do you have an external amp? Sony system, etc.
727-01-01: xxxx-Xxxx-xxxx Do you have a mast antenna or active little thing on the roof?
727-01-01: xxxx-xxXx-xxxx Do you have an internal CD player?

This is what I would suggest:
727-01-01 10A0 F400 00D4
727-01-02 0435
727-02-01 2E5F
727-03-01 1446
727-04-01 0001 0236

AND: Please post your new APIM asbuilt…

My new APIM is below. I don’t have a Sony system. I upgraded the 4" to the Sync 3. I have a little stubby antenna in front of the rear hatch. I reused the ACM with the built in CD player.
APIM-NEW

I found another forum post and I think I got it fixed. This is what I changed:
727-01-01 920x xxxx xxx
727-01-02 x300 xx

I am still getting 5 APIM DTCs though:
Code: B119F - GPS Antenna - Not sure if it matters because I do not have a NAV unit.
Code: U0121 - Lost Communication With Anti-Lock Brake System (ABS) Control Module A
Code: U0151 - Lost Communication With Restraints Control Module
Code: U0238 - Lost Communication With Digital Audio Control Module D
Code: U2101 - Control Module Configuration Incompatible

You need this for the clock. Did you disable the GPSM module? (If you have one…)

If this is under the APIM DTC tab, then something in the APIM configuration is invalid.

Clear the DTC’s and see if they come back after an ignition cycle. This could be a network incompatibility because of the Sync 3 swap into a 2013 C1CMA vehicle.

The DTCs come back after clearing. I installed the GPS antenna but they seem to pretty hit and miss on working. I have tried 3 different ones.

Did you make any progress on the issues?

Where is the GPS antenna mounted? If it is in the dash (Instrument Panel) then you should change:
7D0-03-01 x*xx xxxx xxxx from ‘0’ to ‘1’.
This will raise the voltage to the antenna for more gain.

The antenna is mounted in the dash on a flat spot behind the radio. I will make the change and see if the error goes away.

1 Like

I tried 3 different antennas and if finally went away. I am still getting these:
apime5
apime4
apime3
apime2
apime1

The U0266 was because I didn’t put the front bezel back on to test.

You might want to look at the APIM connector and see if you are missing an MS-CAN wiring.

APIM Connector Versions.pdf (201.5 KB)

@hustjona

Did you resolve the issues?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.