FORD Escape not recognizing IDS CAN Bus, but able to work with ForScan

Hi!, I have a problem with my Ford Escape 2017 SE, I am able to connect it with ForScan but when I try to connect it with IDS official tool, the software do not recognize my car.
Additionally I have an issue with the radio control panel , the led at the buttons (Volume, Parking, Fwd, Rwd etc.) turned off, buttons still working but the led lights are operating. I tried to replace the control panel with another part but still the issue
Any thoughts to share about this 2 topics? will be really appreciated.

The buttons on the panel get the command to light or not over CANBUS, so the two issues are probably related.
I assume you are using the Ford VCM II with Ford IDS?

That’s correct, actually the car is with a Ford dealer they are using IDS with the VCM and unable to identify the vehicle through IDS they asked me to bring the second key (dont know why)

They need the master (admin) key. You probably gave them the user key (fob).

they were able to force access to IDS dunno what happened, the computer reports these errors ( they appear on IDS and on my ForScan as I was able to show them at the dealer repair site):
(OK) [09:00:47.023] Connection to adapter has been established: FTDI #1:A767I17J
(OK) [09:00:47.024] Adapter: ELM327 v1.5
(WARN) [09:00:47.188] The adapter is NOT recommended for this car - some FORScan functions may not be available or not work properly
(OK) [09:00:47.190] Connection to vehicle has been established
(OK) [09:01:00.410] Vehicle: Ford Kuga/Escape EcoBoost Gasoline Turbocharged Direct Injection 2.0L 2017 ( 2017 MY ), VIN: WF0*********21633
(OK) [09:01:02.012] Found module: PCM - Powertrain Control Module
(OK) [09:01:25.351] Found module: OBDII - On Board Diagnostic II
(OK) [09:01:26.436] Found module: APIM - Accessory Protocol Interface Module
(WARN) [09:01:27.626] DTCs in APIM: U0121:00-0B, U0184:00-08, U0256:00-0B
(OK) [09:01:28.854] Found module: SASM - Steering Angle Sensor Module
(OK) [09:01:32.019] Found module: ABS - Antilock braking system
(OK) [09:01:34.812] Found module: RCM - Restraint Control Module
(OK) [09:01:38.136] Found module: PAM - Parking Aid Module
(OK) [09:01:40.962] Found module: PSCM - Power Steering Control Module
(OK) [09:01:44.016] Found module: BdyCM - Body Control Module
(OK) [09:02:12.230] Found module: FCIM - Front Controls Interface Module
(OK) [09:02:17.521] Found module: PDM - Passengers Door Control Unit
(OK) [09:02:20.093] Found module: DDM - Drivers Door Module
(OK) [09:02:22.442] Found module: HVAC - Heating Ventilation Air Conditioning
(WARN) [09:02:23.263] DTCs in HVAC: U2100:00-0A
(OK) [09:02:23.947] Found module: RFA - Remote Function Actuator
(OK) [09:02:26.336] Found module: ACM - Audio Control Module
(OK) [09:02:27.821] Found module: IPC - Instrument Panel Control Module
(WARN) [09:02:29.840] DTCs in IPC: U0140:00-08, U0159:00-08, U0184:00-08, U0422:00-08, U0422:68-08, U0558:00-08, U0100:00-08, U0121:00-08, U0401:64-08, U0415:64-08

I said them to reset to factory settings and reload factory info modules from IDS to the car to erase these errors, looks like the led light issue is related to error DTCs in APIM: U0121:00-0B, U0184:00-08, U0256:00-0B

That’s why they needed to admin key…

APIM DTC U0256 00-0B - Lost Communication with Front Controls Interface Module A
APIM DTC U0121:00-0B: Lost Communication with Anti-Lock Brake System (ABS) Control
APIM DTC U0184:00-08: Lost Communication with Radio
There is a CANBUS issue with the vehicle…

Right, based on what they are doing right now, if they reinstall everything and restore factory settings the modules, may work back the led lights of the radio control panel?

As long as it is just a configuration issue, then yes. But if there is a hardware issue, like wiring, etc. then that will need to be repaired first.

In the HVAC module you have another DTC: HVAC: U2100:00-0A.
U2100 - Initial Configuration Not Complete

This could likely be the cause of the CANBUS issues if the HVAC module is sending unformatted or incorrect messages on the CANBUS.

The IPC codes look like all communication issues with different modules, so definitely something affecting the CANBUS communications. Probably why they had a hard time connecting to the vehicle, the CANBUS is full of incorrect messages.

Got it thanks so much sir, do you think may need to be replaced the computer or the BCM because of it?,I know is too earlier to establish this but just wondering options on the table to be considered…

I doubt that they need to replace anything, just program and test. The HVAC module is the likely culprit, as it throws the unconfigured code. They need to fix this first before they can diagnose the rest. If that module is bad, then yes, it would need to be replaced. But they should try to configure it with the factory asbuilt information that they can access in IDS.

great, thanks so much, I will keep you posted, they still working on it, as soon as I get more info I will share it here, its good to have your know-how as a good asset here for all of us

1 Like

They were able to fix it, the led light is working back again

however, they said the APIM module still in conflict, they tried 6 times to reprogram it, and the led are working again, nevertheless the APIM Module they mentioned the changes I did on the APIM are “rooted” in the module and cannot be reverted.

Its curious because only I did the Upgrade from Sync 3.2 to 3.4 and then I did the FMOD installation, so I said to them if the led lights are working leave it as is now, I can pick up the car tomorrow.

I will attempt once I have the car again with me to upgrade again to 3.4 using the right version ( in this case Europe ) but due the low capacity I am using Voice and Gracenote from USA and rest of files Europe , this car do not have NAV

Now , thinking something else I did , in ForScan, I modified the configuration as NorthAmerica but the car has configuration Europe as has been build there, may be that caused a conflict perhaps?

I have the SUV back with me, they apparently restored to default factory configuration, excepting they are pushing me to replace the APIM saying that I installed a version that isnt supported for that SUV yet,(only 3.3 not 3.4), nevertheless, the radio control panel led is working back again turn on

I did with Syn3updater a reformat installing Europe but gracenotes and voice files NorthAmerica (reduced size) to avoid conflict of size/capacity at the install, everything went well with no errors, it seems good sign then

How about the DTC’s? Are those all gone and the CANBUS operates normally?

I don’t understand why you are saying using Europe settings and software. All Sync APP software is international, although the voice files, Gracenote files, Logo files are specific to each region. These are just broken down to region for simplicity. You should be using South America files in your APIM if you are in SA, not EU files.

A 2017 Escape would have come from the US, imported to your country? It would have come with Sync 3.0 from the factory, so this is probably what they are referring to. It would not have had Sync 3.2 from the factory. If the DTC’s are gone and everything works, I would disregard their suggestion about the APIM.

However, they are completely correct that the issue may be ‘rooted’ in the APIM. Depending on what you did there could have caused an issue. (We cannot discuss FMods JB due to legal reasons on this website.)

hi !, it seems they are gone, looks the SUV is operating normally, however, they insisted today saying not all the errors in APIM were cleared, I will check with my ODB Cable and ForScan tomorrow and see if there is something else or not

At least the LED lights in panel were restored to work, I assume this was based at the as built modules they restored.

My SUV came from Spain to LATAM where I am located, it comes with Sync 3

I will check with the scan how behave and if there is something , I will share it here. , Many thanks by your support as always.

1 Like