Ford Ranger 2016 sync 3 update maps issue (map update stop in a specific point)

Hello to everyone. I’ve got a Ford Ranger 2016 with sync 3 and software version 2.0. I tried to install the F12 maps version via USB. Firstly I received a red screen with the message “Error in NU5T-14G381-AD_1689364279000.TAR.GZ”. I remove the USB and I downloaded again and copy the specific file to the USB again. The install move forward to the green bar but the map update stops to “Extracting map package”. I tried to reset the screen using the two buttons (on/off and >>) the screen restarts but has stuck to the same point (extracting map package). When I remove the USB the installs green bar starts from the begin and shows me a message “Please insert USB stick”. Is there any way to abort the install and go back to the initial condition or fix the problem? Thank you in advance

SYNC Region: EU

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 2.0

New SYNC Version: 2.0

Do you have a error message, if so what is it?
Error in NU5T-14G381-AD_1689364279000.TAR.GZ

Update Method: CyanLabs Manual Method

As yours is a pre-MY20 why not go the whole hog and do a reformat install with latest software and maps.

1 Like

You say it’s a 2016 but your profile says 2015. Which one is it?

2015 appears to come with Sync 2 so this must be a retrofit? Or is it a 2016 which shows it came with Sync 3?

The correct year could help troubleshoot this.


Hello again. I found some corrupted files in my USB stick. I replaced it and I start over the install. It works fine now. Thank you for your support.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.