Ford says needs new APIM. But most of it works?

'16 SHO. Refuses to connect Android Auto for more than 3 minutes and then won’t reconnect. Usually connects for less than 5 seconds and disconnects as if I plugged the phone, then it reconnects. And it just cycles between connect and disconnect until I get the error message.

Sync updated to 3.3 but kept getting error message that the Flash drive was being removed. Update took 1.5 hours as it would pick up where it left off. Pull flash drive, plug back in and it would start again. The USB hub is solid. I can wiggle the cord and it doesn’t effect anything. But the phone will connect, disconnect, connect, disconnect, over and over continuously until either the phone or the APIM says it can’t connect at all and stops trying.

Music files works fine through flash drive but won’t run Android Auto. Wi-Fi also “says” it’s connected to my router but will not tx/rx any data. Not a big deal. Bluetooth works fine for phone calls and audio.

The satnav, radio, sat radio, BT, CD, hot/cold seats, and massage controls all work. The only thing that just refuses to work is Android Auto.

Ford tech checked the USB hub, it’s fine. He tried an update and it wouldn’t even connect. He says needs new APIM. $1400!!

I’m not worried I can’t do the swap, mechanically it’s not that hard. But do I buy the factory unit? Or is there a better way? A Sync 3.4 or 4.0 APIM I can swap for this Sync3 APIM? Is this hardware or software?? I REALLY just want the stupid Android Auto to work without giving up what I already have.


SYNC Region: North America & Canada

Navigation Variant: Yes

Old SYNC Version: 3.1

New SYNC Version: 3.3

Do you have a error message, if so what is it?
“unable to connect with device”

Update Method: Official Ford Update

Syn3 Updater Version:

Syn3 Updater Documentation Read:

Syn3 Updater Log File

You have a 2016 Taurus SHO with Sync 3.0 equipped from the factory" This is not a Sync 2 retrofit?

If you have not replaced the Sync USB hub with a new unit when you reformatted to Sync 3.3, you will probably need to do so. I would not believe a Ford technician would even be authorized to work on the vehicle if you reformatted the APIM, as this is not an authorized or supported upgrade.

Run the APIM Interrogator Utility and post the results here.

It’s Sync3 from the factory. '16 was the crossover year that had to be updated to add Android Auto and Apple Carplay. The USB hub only had to be updated for Apple Carplay. Android Auto did not need the hub upgrade.

I had the exact same thing in my '16 Mustang Premium. Android Auto worked just fine. It also was Sync3 running v3.3 that was updated to run Android Auto and it ran just fine. As it was supposed to. I don’t have an iPhone so I did’t worry about updating the USB hub as it’s not necessary for Android.

There was no formatting. All updated via USB via Ford download using the vehicle VIN verification.

Which 3.3 do you have?.

The issue you are describing is strange, but as said in the movie “I Robot”, we must always think about “unexpected protocols”, “random segments of code”.

I have Sync3 v3.0.20204

That’s not 3.3 as you stated before, but 3.0.

Please, it’s important: what Sync3 version do you have?

Sorry I was combining the 3 from Sync3 with the first 3 in the version. So in my brain it was Sync3.3.xxx

Go to the car, go into the about sync3 section and check which full version is displayed there please.

Again, it’s important, and you have mentioned 3 different versions in this thread: 3.0, 3.1 and 3.3.

I was thinking 3.0.1 was 3.1 and 3.0.2 was 3.2. I was mistakenly dropping the 0 in the middle.

Not what I asked but ok, it’s your unit after all, not mine, so I won’t ask anymore.

So, summing up, we all thought you had a different Sync3 version until now.
You do not have many options outside a Ford dealership.

The issues you are describing could be related to both HW or SW issues, there’s no real way of telling without performing some modifications.

If it’s SW related, you could upgrade the system to 3.3 or 3.4 and see how it behaves.
If the current SW is corrupted or something like that, that should fix it.
But, this is a one way ticket, you can’t go back to 3.0 once you upgrade.

If after upgrading the unit it works ok, then it was SW related. If it keeps failing the same way, it’s something related to HW.

Also, if the issue is HW related (bad memory on the unit), there’s a chance the upgrade may mess something else up.

I would also try another cable if you haven’t done so already, we had some users with AA issues that were solved by using a quality and original cable.

The pic I posted is the most recent update that I performed just a few weeks ago. No, I didn’t go to the car, because I know that Fords website is correct because I uploaded the data back to Ford after the update was complete.

I’ve tried at least 5 different cables of different lengths. All USB 3.1 Gen 2. The shortest was 1’. It worked the best, which is to say, the phone would stay connected for at least 3 seconds sometimes. The longer 3’ would not connect at all.

I find it Interesting that using a different hardware (cable) you get different results, but that’s not conclusive either. But, it’s interesting…

I just figured the Ford USB hub was underpowered crap and there was a LOT of signal loss for some reason. It was the same in my 2016 Mustang Premium. Android Auto was really twitchy and if I used a long cable it wouldn’t connect at all.

I have verified that the phone connects fine (wired) with other vehicles running Sync3 and Sync4. The Sync3 cars were 17+.

Sounds about right, yes.
If you do not have a clean connection, these issues can happen.

I shouldn’t need the upgraded hub for Android Auto to work, but I’m thinking it might be worth doing it anyway to see if it fixes the issue. If not, at least it’s upgraded for the future once the APIM issue is taken care of. And I can attempt to connect an iPhone, just to see what happens if there’s still an issue with Android.

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.