Help ! No buttons, usb or forscan!

Hi all. I have just ‘upgraded’ my 2018 Transit Custom to 3.4 23088 and all on screen notifications indicated that the procedure had worked

However I have the following major problems :-
The 2 usb slots are now inactive
None of the physical buttons on the head unit have any effect .
Forscan will not connect via the obd

All these were fine prior to the upgrade.

What can I do now ?

Can’t reflash / downgrade as the usb’s don’t acknowledge when I put the usb drive in .

Help !!!

Is the unit operative?, is it touchscreen?.

Hi . The touchscreen works, the radio works , the steering wheel buttons work.

The physical buttons don’t work. The USB connectors don’t work.


Ok, have you master reset?.
Provide the log you used for upgrading.

I have performed numerous master resets.

I am unable to perform a soft reset as the physical buttons don’t work.

I cant find a history of the install log I’m afraid. I have attached a photo of the installed version of that helps ?

The photo does not really tells us anything other than your current setup.

I do not remember other reports like yours.

Has the unit has any modification in the past?, or is it stock?.

Did you try to generate a new profile in FORScan?

I discovered the issue - I had fitted a reverse camera adaptor loom before attempting to make the changes on forscan. The effect of this was blocking off access to apim for whatever reason.

Once I had removed the new loom, forscan would then connect, and I was able to see and make changes to the apim to enable rear view camera etc.

I then refitted the new loom and everything is working properly again.

Live and learn eh !

Thanks for your comments.

Also helps to give ALL the details.

Auto Solved due to inactivity