Issue with Update

I bought a Sync 3.4 upgrade kit from aliexpress and fitted it into my 2015 Ford Focus, replacing sync 2. I have checked the Manufacture date on these and it says 2019. Would I be safe to do a full reformat to update the sync 3.4 to the latest version?

Second image

Yes, most likely fine, but what is the part number of the unit? It will be something like xxxx-14G370-xxx.

Also to be safe, run the APIM Interrogator Utility and post the file if you like.

It is indeed a HB5T-14G370-FCD, where is the apim interrogator utility? I would be happy to run that and see how things fair.

Thank you for your reply!

It’s part of the tool, in the utilities tab

I totally missed that. I will create the log and post it! Thank you so much for pointing me in the right direction!

I have tried this and I get Installation failed LST_ERR07. Below is the log from when I created the USB

I have updated then app only to the most current sync version, but I don’t want to go any further until I can rule things out.

Operating System: Microsoft Windows 10 Home (2009)

Version: 3.4.20196
Region: EU
Navigation: True
Mode: autoinstall FORCED

FileSystem: exFAT
Partition Type: MBR

; CyanLabs Syn3Updater 2.x - Autoinstall Mode - Interrogator Log Utility EU

Options = AutoInstall
Item1 = TOOL - GB5T-14G386-AC_1587495565000.TAR.GZ
Open1 = SyncMyRide\GB5T-14G386-AC_1587495565000.TAR.GZ
Options = Delay,Include,Transaction

GB5T-14G386-AC_1587495565000.TAR.GZ (43.1KB)

15/01/2021 20:30:31 GB5T-14G386-AC_1587495565000.TAR.GZ matches known good checksum
15/01/2021 20:30:31 GB5T-14G386-AC_1587495565000.TAR.GZ exists and successfully validated, skipping download
15/01/2021 20:30:31 Preparing USB drive
15/01/2021 20:30:31 Formatting USB drive
15/01/2021 20:30:31 Re-creating partition table as MBR and formatting as ExFat on selected USB drive
15/01/2021 20:30:38 Generating Autoinstall.lst
15/01/2021 20:30:38 GB5T-14G386-AC_1587495565000.TAR.GZ is missing or invalid, copying
15/01/2021 20:30:38 GB5T-14G386-AC_1587495565000.TAR.GZ matches known good checksum
15/01/2021 20:30:38 copied GB5T-14G386-AC_1587495565000.TAR.GZ and successfully validated
15/01/2021 20:30:38 All files downloaded and copied to USB successfully!

I’m confused, your log shows 2.1.1 but you have some bugs that were present in older versions, are you definitely on

That’s strange…

That log shows that the AUTOINSTALL.LST file has 2 options keywords, it should be only one. For the first one, there’s no items declared, so that’s why you are getting the error.

How did you create the USB?, from a fresh start of the program?, or it was open after your latest USB creation?. Also, are you forcing anything?.

Can you try closing the app and trying making the USB again?, only one operation.

Then, take a look at the AUTOINSTALL.LST, should contain something like this, only one section:

; CyanLabs Syn3Updater 2.x - Autoinstall Mode - Interrogator Log Utility

Item1 = TOOL - GB5T-14G386-AC_1587495565000.TAR.GZ
Open1 = SyncMyRide\GB5T-14G386-AC_1587495565000.TAR.GZ
Options = AutoInstall

If not, just edit the file and save that content to it…

Then try it again at the car.

I have found the bug in the code, if a APPS install is down prior to this it will cause the issue, a restart of the application will fix it :slight_smile:

Hi there, I am on (thats what it says in the title bar) It’s the first time I have ever used and installed Cyanlabs so I am just finding my feet with the software. If there is anything I can do to help with troubleshooting these bugs I will be more than happy too… I downloaded and installed it yesterday. I have restarted and remade the USB key. There seems to be a slight change in the file. So lets see how this goes. I will post my log file when its done! :slight_smile:

Here is my log minus the Vin, I hope that gives some information if I would be able to do a full format with my Aliexpress upgrade kit without bricking it

Sync Version: 5U5T-14G381-EK
APIM Model: GB5T-14G371-BFC
APIM Type: Navigation
APIM Size: 64GB
APIM Free Space: 12G
15/01/2021 21:12:52 +00:00

Partition Type = Free / Total
/fs/sd/MAP/ = 676K / 1.1G
/fs/sd/MAP/ = 16M / 2.7G
/fs/sd/MAP/ = 16M / 2.4G
/fs/sd/MAP/ = 9.3M / 1.5G
/fs/sd/MAP/ = 18M / 2.2G
/fs/sd/MAP/ = 24M / 3.7G
/fs/sd/MAP/ = 308K / 38M
/fs/sd/MAP/ = 8.4M / 3.2G
/fs/sd/MAP/ = 29M / 3.6G
/fs/Nuance/ = 26M / 4.4G
/fs/Nuance/ = 27M / 4.6G
/fs/Nuance/ = 24M / 4.1G
/fs/Nuance/ = 33M / 3.4G
/fs/Nuance/ = 8.4M / 1.9G
/fs/Nuance/grace = 21M / 998M
/fs/rwdata/ = 954M / 1.2G
/fs/rwdata/quip/ = 35M / 35M
/fs/rwdata/quip/ = 90M / 90M
/fs/mp/ = 128M / 1.4G
/fs/mp/resources = 432K / 73M
/fs/images/ = 12G / 54G

APIM AsBuilt (Ford/UCDS)
DE00: 0968659A1002B8130002
DE01: 554B01064012080010000000
DE02: 0000000000
DE03: 01001A00020001
DE04: 17E217BF28B9
DE05: 80
DE06: 04033300000000135600000430670061

Strangly the APIM Model: GB5T-14G371-BFC doesn’t match the Model number of the sticker which reads HB5T-14G370-FCD

They never do for some strange reason

So i have found the bug and fixed it for next release :slight_smile:

Should be fine to upgrade it, newer APIMS aren’t actually the issue it’s the newer screens found on newer cars with newer apims that is the issue.

It’s 64gb so you should be able to install full EU maps :slight_smile:

Phew, thats good to know… after updating (it may have been there before updating the ‘apps’) I have noticed on the information screen my Sync Serial Number (ESN) is blank… though seeing other peoples that field is populated. I would assume this data could be inputted via Forescan? No idea what it is no present. (I do have the serial from a sticker on the unit)

Tutorial section, APIM Utility Tutorial

Thank you, I’ll take a look see!

I have had a look in the tutorials section, and i can’t seem to locate it. No luck with the search function either :frowning: