MEM_ERR03 going from 3.3.19052 to 3.4.20196

I have a 2017 Fusion Non-Nav.

Pre-requisite… I was on the following for a couple of months:
APP: 3.4.19274
VOICE: 3.2.19345
GRACENOTE: 3.3.18082

I decided to use the new updater application to get to 3.4.20196 with no luck. Was stuck at updating system for over 40 minutes. After reading another post on this forum I realized I didn’t have enough storage to do all three at once.

Using the automatic part of updater app, I downgraded to (According to the APIM diag info):
APP: 3.3.19052
VOICE: 3.2.19049
GRACENOTE: 3.3.18082

Looking at the above info, I assume gracenotes wasn’t touched during the downgrade (considering 3.3.18082 was the same gracenotes for 3.3)

Okay so now that I’m on 3.3, I popped in the USB I created with the newest version of SYN3 Updater and I get a MEM_ERR03 (not enough space to extract).

Should I try deleting gracenotes first with the directions on this forum, factory reset, then re-pop in the USB again?

I’m wondering, with the deleted gracenotes… Should I try to update APP+VOICE+GRACENOTES all at once, or just APP+VOICE, and try Gracenotes later?

Delete Gracenotes to make room for the update process. Install App and Voice only. Reboot/reset Sync, make sure all works, then add Gracenotes independently.

By the way… The Syn3 Updater has a method to do this in one process. If that is not working for you, Maybe CyanLabs can help with that.

Thanks. I will do it that exact way.

Unfortunately the Syn3 updater didn’t work. I’d rather not bother Cyan because I can most likely do it myself.

I do wonder why it didnt work. Im sure the original USB has logs, i will try pulling it tomorrow.

Post the log from the root of the usb. With 3.3 you will not have enough storage to update to 3.4 without removing Gracenotes since you have a NON-NAV unit. Removing Gracenotes, you should be able to install app and voice. If you find the log.txt file for the CyanLabs intall, please post it so we can see what happened.

Yep. I have three different logs for three different attempts. The only attempt that worked successfully was the downgrade to 3.3.

First log I tried 19274 to 20196 which was the first failure.
Second log: I used Syn3Updater to downgrade to 3.3 which was a success
Third Log: Then I created the last flash drive to go from 3.3 to 3.4.20196 at which point I got the MEM_ERR03

Like you said, all these are related to gracenotes. My next step is to delete gracenotes. I assume all I have to do is create a SyncMyRide folder on the flashdrive with this in my AutoInstall.lst file

Item1 = GB5T-14G386-SC_85041.tar.gz
Open1 = SyncMyRide\GB5T-14G386-SC_85041.tar.gz
Options = Delay,AutoInstall

And put that actual file “GB5T-14G386-SC_85041.tar.gz” in my SyncMyRide folder?

I have multiple flash drives so I don’t mind creating multiple ones.

3.3 to 3.4 failure.txt (1.9 KB) 19274 to 20196 Failure.txt (1.8 KB) Downgrade to 3.3 success.txt (1.9 KB)

On a side note. I am now on 3.4.20196

But when I pop the gracenote only drive into the car i get LST_ERR07

Any ideas? I used the updater to make the gracenote standalone drive

That error means that there is a mistake in the AutoInstall.lst file. Specifically the Open#= line. Can you post your AutoInstall.lst file?

1 Like

If you have the autoinstall from above…

Then that is fine.


1 Like

Here’s the log for the standalone gracenote failure:
Operating System: Microsoft Windows 10 Pro (2004)

Version: 3.4.20196
Region: NA
Navigation: False
Mode: autoinstall

Model: Patriot Memory USB Device (Size: 118GB)
FileSystem: exFAT
Partition Type: MBR

; CyanLabs Syn3Updater - Autoinstall Mode - Sync 3.4.20196 NA

Options = AutoInstall
Item1 = GRACENOTES - 4U5T-14G423-CA_123766.tar.gz
Open1 = SyncMyRide\4U5T-14G423-CA_123766.tar.gz
Options = Delay,Include,Transaction

4U5T-14G423-CA_123766.tar.gz (724.2MB)

INFO: Starting process (Sync 3.4.20196 - NA - Non Nav APIM)
INFO: Verifying 4U5T-14G423-CA_123766.tar.gz
INFO: Successfully Verified 4U5T-14G423-CA_123766.tar.gz
INFO: All downloads completed!
INFO: Re-creating partition table as MBR and formatting as ExFat on selected USB drive
INFO: Creating autoinstall autoinstall.lst
INFO: Copying 4U5T-14G423-CA_123766.tar.gz
INFO: Verifying 4U5T-14G423-CA_123766.tar.gz
INFO: Successfully Verified 4U5T-14G423-CA_123766.tar.gz

Here’s the Autoinstall.lst the updater created:

; CyanLabs Syn3Updater - Autoinstall Mode - Sync 3.4.20196 NA

Options = AutoInstall
Item1 = GRACENOTES - 4U5T-14G423-CA_123766.tar.gz
Open1 = SyncMyRide\4U5T-14G423-CA_123766.tar.gz
Options = Delay,Include,Transaction

I see AutoInstall isn’t even in the options. Will just add that. Will see what happens. This is what I will use

Item1 = 4U5T-14G423-CA_123766.tar.gz
Open1 = SyncMyRide\4U5T-14G423-CA_123766.tar.gz
Options = Delay,AutoInstall

This is what you need…

The autoinstall.lst isn’t formatted right in the log.

1 Like


Quick Question, I had the old Sync MFT in my Mustang that I upgrade with a 2018 Sync 3 with Nav APIM then did a full upgrade via Cyanlabs to 20136 then just recently did the upgrade to 20196. My forscan line 7D0-02-03 has all 0000 from the original programming change over ASBuilt Data. Should that second octave be 4 since I live in the US . I have HD Radio and Sirius. Please let me know your thoughts!! Will that allow the album and radio logos to start working? Thanks

All set.

Thanks guys!

Most excellent, dude…

1 Like

You can just leave that as is because there are no radio logos in the US other than SiriusXM and HD FM radio.

Did not do the firmware upgrade as stated on:

But did change the letter to C and was able to get the Calm screen to work…

I do have HD Radio, will the logos work on C or 0?

Use 4. You don’t have a traffic modem…
4=TPEG Not Available, CS Available, ED Off, AACF Available

HD radio does not rely on this setting. You don’t need to do a firmware upgrade if you have calm screen working. There is nothing to gain past that on a US car.

I set it at 4. Still no option under Radio Settings for Radio Logo. Still have Calm Screen available. So your saying I’ll never see Radio Station as an option under radio settings?

Can you explain what these codes mean? TPEG, CS, ED, ACCF.

I assume CS = Calm Screen?

Radio logos aren’t a thing in NA. Mostly used for Europe DAB. The most you’ll be able to enable (which you have) is calm screen.

1 Like

Thanks for information…

TPEG traffic modem, EU and not NA
CS is calm screen
ED is Enhanced DAB (Digital Audio Broadcast) EU not NA
AACF is still unknown what the acronym is, but it’s enabled on most vehicles.

Thanks, avdonr, for the answer there…

1 Like