MEMERR03 Upgrade Failure to 3.4.23188 from 3.4.21265 (and even 3.3.19052 via Downgrade Function)

Alright, so I had some issues recently with Android Auto and decided to see if there was an update. I probably was barking up the wrong tree, but here we are. Used the latest Syn3 Updater ( and a fresh flash drive, I followed the instructions, but was unable to get an update to succeed. I let it idle for a full 2 hours with the top bar in the APIM showing the System Updating message.

After that wasn’t going anywhere I started down the path of reducing memory usage by the tools included in Syn3 Updater (Gracenotes removal, followed by Small Voice Package, followed by Downgrade, finally followed by RW Data Cleaner).

After each tool was used, I would reattempt the update. (Gracenotes removal → update attempt, small voice → update attempt, etc.)

After the first one I started getting an actual error (MEMEER03) after about 10min of “updating”. (Before any of this is would just hang)

So now I’m sitting on 3.3.19052, unable to update. The Interrogator Log shows 2.6GB free, which is well above the 1.7GB minimum I’ve read about on here, so I’m quite perplexed with this right now.

Some more info that isn’t requested in the questions below:
Vehicle: 2017 Ford Fusion Sport
APIM Model: HP5T-14G371-BCA
APIM Size: 8GB
APIM Free Space: 2.6GB

SYNC Region: NA

Navigation Variant: Non Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.4.21265

New SYNC Version: 3.4.23188

Do you have a error message, if so what is it?

Update Method: CyanLabs Syn3 Updater

Syn3 Updater Version:

Syn3 Updater Documentation Read: yes

Syn3 Updater Log File

Branch: Stable
Operating System: Microsoft Windows 10 Enterprise (2009)

Version: 3.3.19052
Region: NA
Navigation: False
Install Mode: Auto-Detect (autoinstall)
Install Mode Overridden: False
My20 Protection Enabled: Disabled / Not MY20

Mode: Drive
Model:  USB  SanDisk 3.2Gen1 USB Device
Size: 57.3GB
FileSystem: exFAT
Partition Type: MBR

; CyanLabs Syn3Updater Stable - Autoinstall Mode - Sync 3.4.23188 NA

Item1 = RWDataCleaner TOOL - PU5T-14G386-BB_1690840002000.TAR.GZ
Open1= SyncMyRide\PU5T-14G386-BB_1690840002000.TAR.GZ
Item2 = VOICE - 5U5T-14G391-CS_1660783942000.TAR.GZ
Open2 = SyncMyRide\5U5T-14G391-CS_1660783942000.TAR.GZ
Item3 = GRACENOTES - 4U5T-14G423-CC_1615429225000.TAR.GZ
Open3 = SyncMyRide\4U5T-14G423-CC_1615429225000.TAR.GZ
Item4 = APPS - NU5T-14G381-AD_1689364279000.TAR.GZ
Open4 = SyncMyRide\NU5T-14G381-AD_1689364279000.TAR.GZ
Options = AutoInstall

PU5T-14G386-BB_1690840002000.TAR.GZ (3.2KB)
5U5T-14G391-CS_1660783942000.TAR.GZ (385.5MB)
4U5T-14G423-CC_1615429225000.TAR.GZ (564.2MB)
NU5T-14G381-AD_1689364279000.TAR.GZ (869.8MB)

[3/29/2024 5:36:23 PM] Selected Region: NA - Release: Sync 3.4.23188 - Map Version: Non Nav APIM 
[3/29/2024 5:36:23 PM] Install Mode: Auto-Detect (autoinstall) Forced: False 
[3/29/2024 5:36:23 PM] MY20 Protection: Disabled / Not MY20 
[3/29/2024 5:36:23 PM] Formatting USB drive
[3/29/2024 5:36:23 PM] Re-creating partition table as MBR and formatting as ExFat on selected USB drive
[3/29/2024 5:36:39 PM] Checking Existing File: PU5T-14G386-BB_1690840002000.TAR.GZ 
[3/29/2024 5:36:39 PM] Validated: PU5T-14G386-BB_1690840002000.TAR.GZ (Skipping Download) 
[3/29/2024 5:36:39 PM] Checking Existing File: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[3/29/2024 5:36:41 PM] Validated: 5U5T-14G391-CS_1660783942000.TAR.GZ (Skipping Download) 
[3/29/2024 5:36:41 PM] Checking Existing File: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[3/29/2024 5:36:43 PM] Validated: 4U5T-14G423-CC_1615429225000.TAR.GZ (Skipping Download) 
[3/29/2024 5:36:43 PM] Checking Existing File: NU5T-14G381-AD_1689364279000.TAR.GZ 
[3/29/2024 5:36:45 PM] Validated: NU5T-14G381-AD_1689364279000.TAR.GZ (Skipping Download) 
[3/29/2024 5:36:45 PM] Preparing USB drive
[3/29/2024 5:36:45 PM] Checking Existing File: PU5T-14G386-BB_1690840002000.TAR.GZ 
[3/29/2024 5:36:45 PM] Copying: PU5T-14G386-BB_1690840002000.TAR.GZ 
[3/29/2024 5:36:46 PM] Validating: PU5T-14G386-BB_1690840002000.TAR.GZ 
[3/29/2024 5:36:46 PM] Copied: PU5T-14G386-BB_1690840002000.TAR.GZ 
[3/29/2024 5:36:46 PM] Checking Existing File: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[3/29/2024 5:36:46 PM] Copying: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[3/29/2024 5:36:55 PM] Validating: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[3/29/2024 5:36:56 PM] Copied: 5U5T-14G391-CS_1660783942000.TAR.GZ 
[3/29/2024 5:36:56 PM] Checking Existing File: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[3/29/2024 5:36:56 PM] Copying: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[3/29/2024 5:37:12 PM] Validating: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[3/29/2024 5:37:13 PM] Copied: 4U5T-14G423-CC_1615429225000.TAR.GZ 
[3/29/2024 5:37:13 PM] Checking Existing File: NU5T-14G381-AD_1689364279000.TAR.GZ 
[3/29/2024 5:37:13 PM] Copying: NU5T-14G381-AD_1689364279000.TAR.GZ 
[3/29/2024 5:37:42 PM] Validating: NU5T-14G381-AD_1689364279000.TAR.GZ 
[3/29/2024 5:37:45 PM] Copied: NU5T-14G381-AD_1689364279000.TAR.GZ 
[3/29/2024 5:37:45 PM] Generating Autoinstall.lst

Do you have that XML file?, share it with us please. Redact the VIN from the file’s title and content if you care about it.

Also, have you tried a master reset?

I do not have that log, I just took a screenshot of the output in Syn3. However, here is a log I just took. (Probably not helpful, but let me know.)

Sync_VW4C03GU_3FA6P0VP4HR379372.xml (9.8 KB)

I did try a master reset originally before I started all of this. I have not done it since the downgrade though.

Ok, everything looks good.
At this point, I would try either one of these 2 options:

A) Autoinstall a package at a time. Start with the APPS package, then the VOICE one and leave the GRACENOTES one for last. You may or may not be able to install GN at a later time.

B) Reformat the unit if you can (I see it’s a NO-MY20 APIM), create a reformat USB without gracenotes selected. You may or ma not be able to install GN at a later time.

Another question: have you tried with a different USB?.

Option A did the trick, was even able to install GN. Thanks for the help there!

It did pop an Installation Failed with Error Code _SIGN_ERR01 after reboot, but it was on the newer 3.4 software, so it did update correctly. I just proceeded to install Voice, then GN, and everything appears to be functional.

Great!, thank you for the feedback.
Just remember that you may need to do that kind of installation in the future should a big new update is released.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.