My Solution for Sync 3 Screen flickering on Focus MK3

Hey, I found a solution to the Sync 3.4 Build 21194 flickering screen issue in Fcous mk3

Important: You do all the instructions on your own responsibility, there is no guarantee that it will work exactly for you as it did for me. So I am not responsible for your actions.

ForScan is required, I have done the following:

  1. Program APIM via Forscan with the following settings:
  2. ambilight: enable (write setting, sync 3 restarts)
  3. ambilight type: Single Color (Write setting, Sync 3 restarts)

Please make sure whether you also have single color or multicolor, with me it is only single color.

  1. iliatration gateway strategy: C1MCA (write setting, Sync 3 restarts)
  2. After the restart, the Auto Dim function was available for a short time, I then switched it off and ended the programming in the Foscan.

After the next restart of Sync, the Auto Dim option was no longer present in the options, but it remained disabled and the flickering has gone away so far.

Hope it maybe helps you.

2 Likes

Doesn’t changing this prevent other illumination working correctly? for my friends @jiminald Kuga it did.

Good question, I haven’t asked it before, my light works, my daytime running lights too, and my ambilight (red) works too.

I haven’t been able to find any disadvantages with me so far and if I understood that correctly, you can tell the APIM with the config which vehicle it is and the functions that should be displayed.

what exactly was his problem? Does he have the Multicolor ambilight? that I don’t have.

Edit:

I checked again when it got darker outside and I didn’t notice anything that didn’t work after the setting.

I now have the Ambilights option with color selection in the settings, but I have the standard lighting (red color)

maybe it depends on the equipment, I’ll list what my vehicle has here, maybe we’ll find a difference.

Year of manufacture: 2018 (according to FordPass App) FaceLift Model (MK3.5)
Sync 3 non Navi APIM
Equipment: titanium

European version

otherwise the car has no real extras.

Question: since auto brightness is off, the screen always show the same amount of illumination right?, no change at all?.

Almost right, my screen is currently behaving in such a way that the screen lighting dims directly when the vehicle light is on. When that’s off, the screen is brighter, but it no longer reacts to changing light conditions while driving, only when it’s darker for a longer period of time does the screen adapt itself.

According to the description of the Auto Dim function, this receives the lighting information from the ambient lighting. However, I only have the standard version which turns on when the light is on and off when the light goes out again. Accordingly, no error can be seen for me
with the laws settings. It will probably not be the same solution for everyone as I currently have, but I hope that the knowledge I have gathered will help one or the other.

Well this is interesting.

I was counting on it dimming once you turn on your lights, since the car of course will dim it naturally, as any car. But the fact that it “reacts” to darkness over time, I was not expecting that.

Maybe this is misunderstood, but it is not ‘ambient lighting’ like the system in the vehicle. The system responds to "ambient light conditions’, meaning the environment you are in.

1 Like

When set to NA Illumination GW Strategy, CGEA 1.3, this is how it works. If you set your APIM to night mode only with CGEA 1.3, then there is only this dimming, no other.

Before the changes, I could observe that the screen flickers when I set the cockpit lighting to a certain brightness with the buttons, there is a sensor in the car that evaluates this data for the cockpit. Sync appears to have used this data as well when auto-dimming was on, when the feature was off the screen behaved normally and just turned the lights down when the sensor noticed the car’s lights were on.

I guess the change to the sync of the Auto Dim function, which is also supposed to dim the ambience light (according to the description) in connection with the information from the cockpit sensor for the backlight, caused the flickering because the data was not interpreted correctly.

The setting with the Auto Dim function only came when I told the APIM I had the ambient lighting before it didn’t.

I guess there is a bug here, because the option disappears again after the normal reboot if the option was turned off.

But I can only guess what it is exactly.

In any case, it seems to work without it flickering.

I fixed it buy just setting the gateway to C1MCA. This also allowed the radio to stay on when the ignition is off. Only when I lock the doors does every shut down…might not suit all but I think it’s pretty cool. My ‘autodim’ function in settings hasn’t disappeared like others have reported, nor has anything changed over time. My understanding is the gateway should always be set to C1MCA unless you’ve updated the calibration.

I have now found that there is a bug when an APIM setting is set via Forscan that adds a new menu item (such as ambient lighting) and at the same time the lighting strategy is changed to C1MCA, the setting appears briefly in the screen settings.

@NickEaglandShaw how did you configure your APIM, the option remains in the settings, there must be some condition for the display of the Dim function that the software requires.

If you are using the “EASY” menu in FORScan to do this, then you might see settings change that you may not need changed or want changed. The proper way to do this is to use the As Built Configuration Menu, not the Easy tab. Also use a valid value for your vehicle related to the equipment and options.

Setting the Illumination Gateway value should have no effect on the Ambient Lighting values or add any kind of menu. I suspect that there is something else being changed using the EASY menu feature.

For your vehicle the 2 valid options for the Illumination Gateway are:
7D0-06-01 x*xx
0=PAK Not Present, TBA Not Available, IGS CGEA 1.3
1=PAK Not Present, TBA Not Available, IGS C1MCA

I actually used the simple configuration menu as that’s what Forscan recommends. I’ll take a look at the weekend which value was saved without the drop-down menu. maybe then you can spot the error.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.